Results 1 to 6 of 6

Thread: Upgrading Zimbra from 4.5.8 to 5.0.2 on CentOS 5 and getting errors.

  1. #1
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default Upgrading Zimbra from 4.5.8 to 5.0.2 on CentOS 5 and getting errors.

    I am trying to upgrade Zimbra from 4.5.8 to 5.0.2 and kept getting the following installation error:

    Code:
    Starting logger mysql
    This appears to be 4.5.8_GA
    Redolog Version: 1.21 New Redolog Version: 1.21
    Schema upgrade required
    Running /opt/zimbra/libexec/scripts/migrate20070306-Pop3MessageUid.pl
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/DBI/DBI.so: undefined symbol: Perl_Tstack_sp_ptr
    Script failed with code 32512:  - exiting
    UPGRADE FAILED - exiting
    I search the forums and saw people were getting a similar error and the idea was to setup a SplitDNS which I did and that didn't help.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Run the following command on the ZImbra server:

    Code:
    host `hostname`  <--type as-is with backtiucks not single quotes
    dig yourdomain.com mx
    dig yourdomain.com any
    and post the output.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    Code:
    # host `hostname`
    mail.monkeyinyoursoul.com has address 192.168.1.98
    # dig monkeyinyoursoul.com mx
    
    ; <<>> DiG 9.3.3rc2 <<>> monkeyinyoursoul.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44083
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;monkeyinyoursoul.com.		IN	MX
    
    ;; ANSWER SECTION:
    monkeyinyoursoul.com.	86400	IN	MX	10 mail.monkeyinyoursoul.com.
    
    ;; AUTHORITY SECTION:
    monkeyinyoursoul.com.	86400	IN	NS	mail.monkeyinyoursoul.com.
    
    ;; ADDITIONAL SECTION:
    mail.monkeyinyoursoul.com. 86400 IN	A	192.168.1.98
    
    ;; Query time: 2 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Feb  7 11:02:41 2008
    ;; MSG SIZE  rcvd: 89
    
    # dig monkeyinyoursoul.com any 
    ; <<>> DiG 9.3.3rc2 <<>> monkeyinyoursoul.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9527
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;monkeyinyoursoul.com.		IN	ANY
    
    ;; ANSWER SECTION:
    monkeyinyoursoul.com.	86400	IN	SOA	monkeyinyoursoul.com. mail.monkeyinyoursoul.com.monkeyinyoursoul.com. 42 10800 900 604800 86400
    monkeyinyoursoul.com.	86400	IN	NS	mail.monkeyinyoursoul.com.
    monkeyinyoursoul.com.	86400	IN	MX	10 mail.monkeyinyoursoul.com.
    monkeyinyoursoul.com.	86400	IN	A	192.168.1.98
    
    ;; ADDITIONAL SECTION:
    mail.monkeyinyoursoul.com. 86400 IN	A	192.168.1.98
    
    ;; Query time: 2 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Feb  7 11:02:54 2008
    ;; MSG SIZE  rcvd: 167
    Last edited by phoenix; 02-07-2008 at 12:35 PM.

  4. #4
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    Does anyone have any ideas.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Is your version of CentOS up to date, specifically is which version of perl is installed?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Feb 2006
    Location
    Toronto, Ontario
    Posts
    45
    Rep Power
    9

    Default

    I just did a os upgrade.

    I am running:
    Code:
    This is perl, v5.8.5 built for i686-linux
    I am going to upgrade to 4.5.11 and see if that helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •