Results 1 to 9 of 9

Thread: sending mail using your ISP as relay host

  1. #1
    mikelurk Guest

    Default sending mail using your ISP as relay host

    Here is something for everyone who wants to use their ISP as a relay host for outgoing mail. You might want to call it a How to. It took a lot of reading and searching on the zimbra forums, but it was worth it, and it works. Most important make sure that you can send mail internally and receive mail before you continue with this.

    Next step is to set your relay MTA to your ISP's mail host and to remove the check from DNS look-up. This is done in the admin console, editing the server

    From this point on postfix is your friend, considering you need to add to postfix.
    To start you need to enable SMTP authentication on outbound messages: $ postconf -e smtp_sasl_auth_enable=yes

    Next is to create a text file mapping which name/password should be used for each given outbound destination:
    $ echo mailrelay.example.com usernameassword > opt/zimbra/conf/relay_password this is one line

    Create a postfix lookup table
    $ postmap /opt/zimbra/conf/relay_password

    Test that the map is okay
    $ postmap -q mailrelay.example.com /opt/zimbra/conf/relay_password
    that should return usernameassword if done right

    Make postfix use the above
    $ postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password

    Almost done. Two more changes to postfix and then we can send mail externally. We need to change the port we listen on. This is most important for people who use an ISP that does not allow the use of port 25 to listen to ( [I]this is most important for Rogers customers in Canada)

    postconf -e relay_host=relayhost.yourisp.com:465
    Your ISP might want you to use another port, so check with your ISP for an alternate port.

    Restart postfix by entering this

    postfix reload

    If we try to send mail at this point, we might still get an error (in the zimbra log files would be first place to check):

    SASL authentication failure: No worthy mechs found

    It took me a while to find the fix for this but here it is:

    postconf -e smtp_sasl_security_options=

    Thats right nothing after the =. Apparently this option is set to noplaintext,noanonamous by default and that has to be changed.

    Once this has been done you just have to restart postfix and we are done.

    postfix reload

    This should work for all who want to use their ISP as a relay host.

    On a personal note, this is the best looking mail server/client that I have found. To all that are working on Zimbra.... KEEP UP THE GOOD WORK.

    P.S. I wish I knew when the final release was available, then I could set a timeline to put it into production where I work.

  2. #2
    Join Date
    Mar 2006
    Posts
    1
    Rep Power
    9

    Default Additional setting required

    Great guide... however, there is one additional thing i needed to do in order to get it to work with rogers: I had to add noanonymous to the security options.

    smtp_sasl_security_options = noanonymous

    Thanks again for the great guide.

  3. #3
    Join Date
    May 2006
    Posts
    23
    Rep Power
    9

    Default

    thanx a lot for this How To.

    was very useful and works well

  4. #4
    Join Date
    Aug 2006
    Posts
    17
    Rep Power
    9

    Thumbs up Vote this bug


  5. #5
    Join Date
    Jan 2007
    Posts
    16
    Rep Power
    8

    Default

    What if you want to relay mail but don't need to authenticate?? ie all mail from the domain can be relayed through the smtp server.

    Greg

  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    That sounds like a time bomb waiting to explode. . .
    unless it's restricted by IP

  7. #7
    Join Date
    Jan 2007
    Posts
    16
    Rep Power
    8

    Default

    It is. Mail can be relayed from any internal address.

  8. #8
    Join Date
    Apr 2007
    Posts
    21
    Rep Power
    8

    Default details

    $ echo mailrelay.example.com usernamepassword > opt/zimbra/conf/relay_password

    Do i just type "usernamepassword" as is? or is it a real username and password?


    Hope this is not a stupid question. I am new to this.

  9. #9
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    1
    Rep Power
    8

    Default

    Quote Originally Posted by phantom32i View Post
    Do i just type "usernamepassword" as is? or is it a real username and password?
    hi,

    you just type:

    $ echo mailrelay.example.com USERNAME:PASSWORD > opt/zimbra/conf/relay_password

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •