Results 1 to 2 of 2

Thread: 5.0.2 upgrade Tip (STARTTLS: -11: Connect error)

  1. #1
    Join Date
    Dec 2007
    Posts
    1
    Rep Power
    7

    Default 5.0.2 upgrade Tip (STARTTLS: -11: Connect error)

    I'm adding this because I spent hours looking for a solution only to find the solution hidden away in a bug report. Hopefully, this will save someone else some time.

    Seeing errors like this in your /var/log/maillog?

    Feb 13 00:00:33 mail postfix/trivial-rewrite[15099]: error: dict_ldap_connect: U
    nable to set STARTTLS: -11: Connect error
    Feb 13 00:00:33 mail postfix/trivial-rewrite[15099]: error: dict_ldap_connect: U
    nable to set STARTTLS: -11: Connect error
    Feb 13 00:00:33 mail postfix/trivial-rewrite[15100]: error: dict_ldap_connect: U
    nable to set STARTTLS: -11: Connect error


    Although there are several issues that may cause this, the solution that worked for me was hidden away in Bugzilla Bug 23666 "STARTTLS connect error to LDAP after upgrade" in comment #6:

    ------- Additional Comment #6 From Quanah Gibson-Mount 2008-01-15 13:51 PST [reply] -------
    User created /opt/zimbra/conf/ca/bak directory. Postfix trivial-rewrite chokes
    on this additional directory existing (no idea why). Solution is to not create
    anything in /opt/zimbra/conf/ca except certs and keys.


    BTW - this bug is marked as RESOLVED with solution WONTFIX

  2. #2
    Join Date
    Mar 2007
    Posts
    25
    Rep Power
    8

    Default

    Saved me some time.

    Thanks,
    Kirk

    Quote Originally Posted by kimery View Post
    I'm adding this because I spent hours looking for a solution only to find the solution hidden away in a bug report. Hopefully, this will save someone else some time.

    Seeing errors like this in your /var/log/maillog?

    Feb 13 00:00:33 mail postfix/trivial-rewrite[15099]: error: dict_ldap_connect: U
    nable to set STARTTLS: -11: Connect error
    Feb 13 00:00:33 mail postfix/trivial-rewrite[15099]: error: dict_ldap_connect: U
    nable to set STARTTLS: -11: Connect error
    Feb 13 00:00:33 mail postfix/trivial-rewrite[15100]: error: dict_ldap_connect: U
    nable to set STARTTLS: -11: Connect error


    Although there are several issues that may cause this, the solution that worked for me was hidden away in Bugzilla Bug 23666 "STARTTLS connect error to LDAP after upgrade" in comment #6:

    ------- Additional Comment #6 From Quanah Gibson-Mount 2008-01-15 13:51 PST [reply] -------
    User created /opt/zimbra/conf/ca/bak directory. Postfix trivial-rewrite chokes
    on this additional directory existing (no idea why). Solution is to not create
    anything in /opt/zimbra/conf/ca except certs and keys.


    BTW - this bug is marked as RESOLVED with solution WONTFIX

Similar Threads

  1. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 10:10 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •