Results 1 to 2 of 2

Thread: [SOLVED] Moved Zimbra to new server now getting error

  1. #1
    Join Date
    Mar 2007
    Posts
    27
    Rep Power
    8

    Default [SOLVED] Moved Zimbra to new server now getting error

    I moved my Zimbra 5.0.2 installation from one Ubuntu 6.0.2 server to new more powerful Ubuntu 6.0.2 server following guide located at: http://www.zimbra.com/blog/archives/...er_server.html

    Everything seemed to go as explained. But now on some accounts when you delete a message or move from folder to folder you get the error:
    Code:
    msg: No such blob: mailbox=7, item=15985, change=27593
    code: mail.NO_SUCH_BLOB
    method: SearchRequest
    detail: soap:Sender
    I then choose send error report.

    If I was deleting, the message deletes and is placed in Trash folder, If I was moving a message it is found in the folder I was moving it to.

    I then went to Documents, opened a notebook then choose a page and received the following error:
    Code:
    HTTP ERROR: 500
    No such blob: mailbox=7, item=6803, change=29211
    RequestURI=/service/home/phetherington/Notebook/Passwords
    
    Caused by:
    com.zimbra.cs.mailbox.MailServiceException: No such blob: mailbox=7, item=6803, change=29211
    Code:mail.NO_SUCH_BLOB
    	at com.zimbra.cs.mailbox.MailServiceException.NO_SUCH_BLOB(MailServiceException.java:250)
    	at com.zimbra.cs.mailbox.MailItem.getBlob(MailItem.java:814)
    	at com.zimbra.cs.mailbox.MessageCache.fetchFromStore(MessageCache.java:267)
    	at com.zimbra.cs.mailbox.MessageCache.getItemContent(MessageCache.java:132)
    	at com.zimbra.cs.mailbox.MailItem.getContent(MailItem.java:842)
    	at com.zimbra.cs.wiki.WikiPage$LocalWikiPage.getContents(WikiPage.java:211)
    	at com.zimbra.cs.wiki.WikiPage.getTemplate(WikiPage.java:85)
    	at com.zimbra.cs.service.formatter.WikiFormatter.getTemplate(WikiFormatter.java:119)
    	at com.zimbra.cs.service.formatter.WikiFormatter.getTemplate(WikiFormatter.java:104)
    	at com.zimbra.cs.service.formatter.WikiFormatter.handleWiki(WikiFormatter.java:77)
    	at com.zimbra.cs.service.formatter.WikiFormatter.formatCallback(WikiFormatter.java:210)
    	at com.zimbra.cs.service.formatter.Formatter.format(Formatter.java:93)
    	at com.zimbra.cs.service.UserServlet.doAuthGet(UserServlet.java:454)
    	at com.zimbra.cs.service.UserServlet.doGet(UserServlet.java:354)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:174)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
    	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
    	at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
    	at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
    	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
    	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
    	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
    	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:716)
    	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:406)
    	at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)
    	at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
    	at org.mortbay.jetty.handler.RewriteHandler.handle(RewriteHandler.java:176)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
    	at org.mortbay.jetty.Server.handle(Server.java:313)
    	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)
    	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:830)
    	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
    	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
    	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)
    	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)
    	at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)
    
    Powered by Jetty://
    I am not sure which direction to take to correct this error.
    Any help would be greatly appreciated.

    Paul H.

  2. #2
    Join Date
    Mar 2007
    Posts
    27
    Rep Power
    8

    Default

    I have worked out the problem and it was all my fault. The more I thought about it the more I wondered if it was really stating the truth, NO BLOB FOUND.

    I checked folder sizes and found that the new server folder was much smaller then the old folder. I believe that The USB drive I was using for folder transfer was not done writing before it was dismounted.

    I went into each user account, fowarded the important e-mails that came down before I saw the problem and stopped all incoming mail, to an external account.

    I then deleted the Zimbra folder, re-rsync'd from the old server, making sure that drive was completely done writing before unmounting the drive.

    Re-rsync'd on to new server, ran zmfixperms and reinstalled zimbra.

    Everything worked fine now. I got brave and even upgraded to 5.0.2GA.

    I went to external e-mail box and re-forwarded all e-mails back to their original accounts. Now all seems fine.


    Paul H.

Similar Threads

  1. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  2. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •