Results 1 to 3 of 3

Thread: Upgrading from 4.5.1 NE to 5.0.2

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Default Upgrading from 4.5.1 NE to 5.0.2

    We're currently running the (rather old) 4.5.1 version of the Zimbra Network Edition.

    Are there any known problems / caveats in upgrading directly to 5.0.2, or should we go through newer 4.5 versions first?

  2. #2
    Join Date
    Mar 2006
    Beaucaire, France
    Rep Power


    Welcome to the forum.

    You should have no problem with a direct upgrade (4.5.1 to 5.0.2).
    However, if you wish, you can upgrade 4.5.1 to 4.5.10, then to 5.0.2.

    Don't forget a backup (just in case) before the upgrade and just after the upgrade (because once upgraded your old backup files will be unusable).

  3. #3
    Join Date
    Feb 2008
    Rep Power

    Default Upgrade done


    The upgrade went mostly smoothly. We went the careful route, upgrading first to 4.5.6, then 4.5.11 and only after that to 5.0.2.

    In 5.0.2 upgrade there were some issues with certificates. I'd installed our own certificates in tomcat/etc/keystore and conf/smtpd.crt.

    The upgrade process asked for the passphrase to ca/ca.key. We didn't know what the passphrase is, so I just typed 'changeit' after some failed attempts. After this, the upgrade process went mostly smoothly, only failing in 'Initializing Documents' phase:

    *** Running as zimbra user: /opt/zimbra/bin/zmprov mc default zimbraFeatureNotebookEnabled TRUE
    ERROR: zclient.IO_ERROR (invoke Received fatal alert: handshake_failure, server: localhost) (cause: Received fatal alert:
    (and a few more)

    Since we don't really use documents, we didn't think much of that.

    However, after the upgrade, the tomcat certificate was missing from jetty/etc/keystore. Because of that, the web client or the admin interface didn't work. The problem was solved by copying the old keystore from 4.5.11 backup over jetty's keystore.

    Now everything seems to work nicely. The only thing that bothers me is that mailboxd certificate is not displayed in the admin interface. I guess that can be fixed somehow..?

Similar Threads

  1. Problem upgrading from 5.0.1 -> 5.0.2 (documents)
    By ad8mustanggt in forum Installation
    Replies: 1
    Last Post: 03-10-2008, 09:15 PM
  2. [SOLVED] Upgrading to 5.0.2 Backup steps
    By cecil in forum Installation
    Replies: 4
    Last Post: 02-11-2008, 11:34 PM
  3. Replies: 5
    Last Post: 02-08-2008, 08:50 AM
  4. Replies: 7
    Last Post: 02-04-2008, 09:51 AM
  5. [SOLVED] Unable to connect after upgrading to 5.0.2
    By pornsakb in forum Administrators
    Replies: 3
    Last Post: 02-03-2008, 04:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts