Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost)

  1. #1
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost)

    Hey! I've been trying to get mailbox to work but it wont :/

    Errors;

    zimbra@homer:~/log$ zmcontrol start
    Host hostname
    Starting logger...FAILED


    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...FAILED


    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.
    zimbra@homer:~/log$ zmcontrol status
    Host hostname
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running
    mta Running
    snmp Running
    spell Running
    stats Running
    zimbra@homer:~/log$ zmperditionctl stop
    Stopping imap4
    Stopping imap4s
    Stopping pop3
    Stopping pop3s
    zimbra@homer:~/log$ zmprov -- ms hostname -zimbraServiceEnabled imapproxy
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@homer:~/log$ zmprov ms hostname zimbraPop3ProxyBindPort "" zimbraImapProxyBindPort "" zimbraPop3SSLProxyBindPort "" zimbraImapSSLProxyBindPort ""
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@homer:~/log$ zmprov ms hostname zimbraPop3BindPort 110 zimbraImapBindPort 143 zimbraPop3SSLBindPort 995 zimbraImapSSLBindPort 993
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@homer:~/log$ tomcat stop
    bash: tomcat: command not found
    zimbra@homer:~/log$ tomcat start
    bash: tomcat: command not found

    The server is a Debian 4.0 with a 2.6 kernel

    Thanks in advance

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You need valid DNS A & MX records and a correct /etc/hosts file for Zimbra to be installed correctly, you will also need a Split DNS set-up if you're behind a NAT router - do you have all of those? You'll probably find errors in the install log if you check.

    It would also appear that you've enabled the proxy service, you don't need that for a single server install.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    How could I fix this error? :/ I tried the Split DNS but it still wont start and i edited /etc/hosts aswell :|

    But no, it wont start

    Thanks

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Did you reinstall Zimbra? Is this a new install or update?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    This is the newest Zimbra for Debian 4.0 from your download page, and no i havn't tried to re-install it yet, should i? :P

    Sincerly

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Post the output of the following commands (run on the zimbra server):

    Code:
    host `hostname`  <--type as-is with backticks not single quotes
    dig yourdomain.com mx
    dig yourdomain.com any
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    Replies;

    Code:
    zimbra@homer:~$ host 'homer.mindns.se'
    homer.mindns.se         A       84.218.51.191
    zimbra@homer:~$ dig mindns.se mx
    dig: /opt/zimbra/openssl/lib/libcrypto.so.0.9.8: no version information availabl                                                                             e (required by /usr/lib/libdns.so.22)
    ;; reply from unexpected source: 192.168.1.1#3073, expected 192.168.1.1#53
    ;; reply from unexpected source: 192.168.1.1#3073, expected 192.168.1.1#53
    ;; reply from unexpected source: 192.168.1.1#3073, expected 192.168.1.1#53
    
    ; <<>> DiG 9.3.4 <<>> mindns.se mx
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    zimbra@homer:~$ dig mindns.se any
    dig: /opt/zimbra/openssl/lib/libcrypto.so.0.9.8: no version information availabl                                                                             e (required by /usr/lib/libdns.so.22)
    ;; reply from unexpected source: 192.168.1.1#3073, expected 192.168.1.1#53
    ;; reply from unexpected source: 192.168.1.1#3073, expected 192.168.1.1#53
    ;; reply from unexpected source: 192.168.1.1#3073, expected 192.168.1.1#53
    
    ; <<>> DiG 9.3.4 <<>> mindns.se any
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Based on the fact your DNS server is on a 192.168.1.1 LAN IP I'm guessing that your Zimbra server is also on the LAN, correct? If that is correct you need your hosts file to point at the LAN IP of your server (details in the documentation here) and you'll need the Split DNS set-up I mentioned earlier. As this is a new install I's suggest you make the above changes and then uninstall the current version of zimbra (run the install like this: ./install.sh -u) to remove it from your system, when that's done reinstall Zimbra and see how you get on.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Feb 2008
    Posts
    9
    Rep Power
    7

    Default

    I changed my dhclient-script to this;
    Debian User Forums :: View topic - Solving DNS problem (dhclient & resolv.conf)

    So now It wont put /etc/resolv.conf nameserver as 192.168.1.1 now I got the real nameservers from my ISP, and I got new dig results;

    Code:
    homer:~# host 'homer.mindns.se'
    homer.mindns.se         A       84.218.51.191
    homer:~# dig mindns.se mx
    
    ; <<>> DiG 9.3.4 <<>> mindns.se mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64002
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mindns.se.                     IN      MX
    
    ;; ANSWER SECTION:
    mindns.se.              3600    IN      MX      10 mail.dindns.se.
    
    ;; AUTHORITY SECTION:
    mindns.se.              2552    IN      NS      ns4.loopia.se.
    mindns.se.              2552    IN      NS      ns3.loopia.se.
    
    ;; ADDITIONAL SECTION:
    ns3.loopia.se.          9312    IN      A       194.9.94.245
    ns4.loopia.se.          9312    IN      A       194.9.95.245
    
    ;; Query time: 51 msec
    ;; SERVER: 195.58.103.21#53(195.58.103.21)
    ;; WHEN: Sun Feb 24 21:29:49 2008
    ;; MSG SIZE  rcvd: 130
    
    homer:~# dig mindns.se any
    
    ; <<>> DiG 9.3.4 <<>> mindns.se any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31303
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mindns.se.                     IN      ANY
    
    ;; ANSWER SECTION:
    mindns.se.              3595    IN      MX      10 mail.dindns.se.
    mindns.se.              3537    IN      A       84.218.51.191
    mindns.se.              6145    IN      RRSIG   NSEC 5 2 7200 20080229073444 20080222201228 59613 se. nKlB5jlYJ81c2oT7VAn0CE/lNZvT1Rrrk6pgIlo0j92CDQjb7eO/TR+o CzD9zfPcty8nsFxg1/7JA3/FRyGVKzBe7ZqXC7eKmfE8Z5Klg0Awke/D d2OPrk9aFhxPUPIZz7AMrku0BYOofkRgANQhzn01Gk5Hc8gYgeGChn4L 0QY=
    mindns.se.              6145    IN      NSEC    mindo.se. NS RRSIG NSEC
    mindns.se.              2547    IN      NS      ns3.loopia.se.
    mindns.se.              2547    IN      NS      ns4.loopia.se.
    
    ;; AUTHORITY SECTION:
    mindns.se.              2547    IN      NS      ns4.loopia.se.
    mindns.se.              2547    IN      NS      ns3.loopia.se.
    
    ;; ADDITIONAL SECTION:
    ns3.loopia.se.          9307    IN      A       194.9.94.245
    ns4.loopia.se.          9307    IN      A       194.9.95.245
    
    ;; Query time: 55 msec
    ;; SERVER: 195.58.103.21#53(195.58.103.21)
    ;; WHEN: Sun Feb 24 21:29:54 2008
    ;; MSG SIZE  rcvd: 366

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    That doesn't really answer my question, is the zimbra server on a Private LAN IP? It alos begs another question, is your domain name mindns.se?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Replies: 2
    Last Post: 02-12-2008, 10:55 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 10:57 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •