Results 1 to 7 of 7

Thread: Zimbra 5.0.2 and OS X Leopard, java 1.5 error

  1. #1
    Join Date
    Feb 2008
    Posts
    4
    Rep Power
    7

    Default Zimbra 5.0.2 and OS X Leopard, java 1.5 error

    Hello. I'm trying to find a PIM I like for OS X, and thought I'd give Zimbra a try.

    I downloaded the open source version for OS X, version 5.0.2, and am trying to install it on Leopard. The install seems to go okay, and it tells me to run /opt/zimbra/libexec/zmsetup.pl as root, so I do:

    > sudo /opt/zimbra/libexec/zmsetup.pl
    and give the appropriate password. Unfortunately, I get an error

    su: unknown login: zimbra
    Operations logged to /tmp/zmsetup.02242008-113411.log
    Checking java version...su: unknown login: zimbra

    ERROR

    Java version 1.5 required - please update your java version
    and set the default version to be 1.5 before proceeding

    But I do seem to have version 1.5 set. If I do:

    > java -version
    I get
    java version "1.5.0_13"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05-237)
    Java HotSpot(TM) Client VM (build 1.5.0_13-119, mixed mode, sharing)

    I've searched the web and the forums (I don't seem to have much success searching for keywords on the zimbra forums, for some reason) and have checked the settings. My Java preferences has a choice of 1.4.2 or 5.0, but it does seem that 1.5 is the default setting.

    Does anyone have any ideas what I'm doing wrong?

  2. #2
    Join Date
    Feb 2008
    Posts
    4
    Rep Power
    7

    Default

    Looking at my links for Java:
    > ls -l /System/Library/Frameworks/JavaVM.framework/Versions

    Current -> A
    CurrentJDK -> 1.5

    I'm not sure what A is. Presumably, it's another version of Java. Since /usr/bin/java -version showed the java version to be 1.5, I presume this is okay, but just in case, I set:

    Current -> 1.5

    Still, no dice. I get the same error. Should I try building from source? Any thoughts, anyone?

  3. #3
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    Leopard uses the Class Data Sharing feature available in J2SE 5.0

  4. #4
    Join Date
    Feb 2008
    Posts
    4
    Rep Power
    7

    Default

    Thank you Daniel, but I'm not sure what this means. Does it mean it simply won't work with Leopard? I saw that there were incompatibilities with the server. Do I just need to wait?

  5. #5
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    ZCS is currently only supported on Tiger. A leopard build is scheduled for 5.0.4.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    Join Date
    Feb 2008
    Posts
    4
    Rep Power
    7

    Default

    Thanks Daniel. I'll wait. I appreciate you taking the time to enlighten me on something that is probably obvious to many. It just wasn't clear to me.

  7. #7
    Join Date
    Mar 2007
    Posts
    26
    Rep Power
    8

    Default Zimbra 5.02 on Leopard

    The error with regards to the installer reporting the wrong Java version is actually really easy to fix. If you look at the setup script, you can see the error is raised because the installer does 'java -version' as the 'zimbra' user.

    Unfortunately, the installer doesn't create the 'zimbra' account (though it does copy the files to /opt/zimbra and symlink to /Users/).

    You can fix the Java version exception by creating the user account manually.

    However, though the installer then gets past the Java version point, it stalls on ldapinit, which brian's post indicates will be solved later. I really don't know what Daniel's class sharing comment is related too.

Similar Threads

  1. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  2. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •