Results 1 to 6 of 6

Thread: MTA not starting

  1. #1
    Join Date
    Feb 2006
    Rep Power

    Default MTA not starting

    I have attempted the install on FC4 I've actually installed removed and reinstalled after disabling/removing some FC4 services as recommended in other posts. I nearly have the open source zimbra fully launching but the MTA won't start.

    Starting ldap...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting mta...FAILED
    getService: sasl
    getService: webxml
    getService: perdition
    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter='smtp-amavis:[]:10024'
    DO: /opt/zimbra/postfix/sbin/postconf -e myhostname=''
    DO: /opt/zimbra/postfix/sbin/postconf -e recipient_delimiter=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit='10240000'
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_sender, reject_unauth_destination, permit'
    /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd: error while loading shared libraries: cannot open shared object file: No such file or directory

    I've tried doing some googling and looked at various posts but I coudn't find much more information.

    zimbra.log doesn't contain any useful information that i can see and my hosts file has the two lines as specified.

    Any help appreciated,

  2. #2
    Join Date
    Sep 2005
    Rep Power

    Default missing package

    [zimbra@wolfowitz ~]$ ldd cyrus-sasl/sbin/saslauthd => (0x00c4d000) => /usr/lib/ (0x00101000) => /usr/lib/ (0x00c23000) => /lib/tls/ (0x00cfe000) => /lib/tls/ (0x00bfe000) => /usr/lib/ (0x001f6000) => /lib/ (0x00d79000) => /lib/ (0x00224000) => /usr/lib/ (0x00ccb000) => /usr/lib/ (0x00d12000) => /lib/ (0x00ca3000) => /usr/lib/ (0x00ca8000) => /lib/ (0x00c8d000) => /lib/ (0x00bf8000) => /usr/lib/ (0x0030d000) => /lib/ (0x0033d000) => /lib/ (0x00ce1000) => /lib/tls/ (0x00acb000)
    /lib/ (0x00ab1000)

    [zimbra@wolfowitz ~]$ rpm -qf /usr/lib/

    So, install the kerberos libraries, and sasl should start fine.

  3. #3
    Join Date
    Feb 2006
    Rep Power

    Default missing package

    I should have said, I already tried this:

    > yum search kerberos
    krb5-libs.i386 1.3.6-7 installed

    > yum provides libkrb5support
    No Matches found

    Any idea what kerberos related package or version should be installed?

  4. #4
    Join Date
    Sep 2005
    Rep Power

    Default ldd

    run the ldd command on saslauthd and find out what it's missing.

    If the krb-libs are installed, rpm -ql will give you a list of files in the package.

  5. #5
    Join Date
    Feb 2006
    Rep Power

    Default Missing Lib

    Very sorry- stupid error.

    For anyone else reading this thread, this is an error you get if you accidentily try to install the zimbra FC4 release onto FC3.

  6. #6
    Join Date
    Jul 2006
    Rep Power


    For anyone else struggling with this....

    On CentOS4.4 x86_64 i ran into this same error. after going around in circles for a while I figured it out.

    For some reason I wound up with libcurl installed but not libcurl 64.

    yum install curl.x86_64
    yum install curl-devel.x86_64


    su - zimbra
    zmcontrol stop && zmcontrol start &&

    everything looks ship shape.

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM
  3. starting mta...FAILED
    By timjenne in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 06:09 PM
  4. Zimbra MTA died and won't restart
    By lallhands in forum Installation
    Replies: 3
    Last Post: 01-19-2006, 12:31 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts