Results 1 to 4 of 4

Thread: Won't start with too much memory on 32 bits

Hybrid View

  1. #1
    Join Date
    Sep 2005
    Rep Power

    Default Won't start with too much memory on 32 bits

    Hi guys.

    I'm trying to install Zimbra in a machine with 8Gb RAM. I already had noticed that zimbra sets memory use for MySql and Java/Tomcat in percert to the total memory, 30 percent to Java/Tomcat and 40 percent to MySql. But only now I realized the error this could lead to.

    Well, the thing is: 30% of 8Gb is 2.4 Gb and 40% of 8Gb is 3.2Gb. In a 32 bit system, one proccess can only have, at most, 2Gb of memory, because of addressing it with 32 bits.

    So, what happened when I tried to install Zimbra with too much memory? Mysql and Tomcat simply didn't start. I tried to change the configs manually to 2Gb for each, but it seems that, once these servers didn't start (or at least MySql), installation didn't finish correctly, and I coudn't start them, even limiting the memory.

    Any workaround for now?

    Hope it can be fixed in the next releases and, if possible, on install let the user select the amount of memory to each server.



  2. #2
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    Which kernal are you using:

    kernel-smp can use >4GB by using PAE (3 level paging w/ indirect pointers at kernel level to higher mem)
    kernel-hugemem uses 4/4 split: 4GB addrees space for system/kernel, 4GB address space per user process

    There's at least one install I know of where they installed on 6GB ram machines. I guess we could put in some limitss so the math doesn't ever try to give more that 2GB to any process.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Sep 2005
    Rep Power


    It's kernel-smp 2.6.13-15. I have installed Suse 10 for 64 bits, but that should not be a problem with the 32 bits Zimbra installation.

  4. #4
    Join Date
    Sep 2005
    Rep Power

    Default bug filed

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. Zimbra .pids / service monitoring
    By bin2hex in forum Administrators
    Replies: 24
    Last Post: 04-03-2010, 09:12 PM
  3. After reboot mailbox and tomcat don't start
    By gon in forum Administrators
    Replies: 1
    Last Post: 11-02-2007, 11:50 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM
  5. No listener on port 7071
    By earthling in forum Installation
    Replies: 3
    Last Post: 11-14-2005, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts