Results 1 to 10 of 10

Thread: Can someone help me with this error?

  1. #1
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default Can someone help me with this error?

    Installing packages

    zimbra-core......zimbra-core_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-ldap......zimbra-ldap_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-logger......zimbra-logger_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-mta......zimbra-mta_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-snmp......zimbra-snmp_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-store......zimbra-store_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-apache......zimbra-apache_5.0.2_GA_1975.UBUNTU6_i386.deb...done
    zimbra-spell......zimbra-spell_5.0.2_GA_1975.UBUNTU6_i386.deb...done

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    HOSTNAME=
    LDAPHOST=
    LDAPPORT=
    SNMPTRAPHOST=
    SMTPSOURCE=
    SMTPDEST=
    SNMPNOTIFY=0
    SMTPNOTIFY=0
    LDAPROOTPW=
    LDAPZIMBRAPW=
    LDAPPOSTPW=
    LDAPREPPW=
    LDAPAMAVISPW=
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    cp: cannot stat `/opt/zimbra/.saveconfig/keystore': No such file or directory
    chown: cannot access `/opt/zimbra/conf/keystore': No such file or directory
    Operations logged to /tmp/zmsetup.02262008-171218.log
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Setting defaults...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    done.
    Upgrading from to 5.0.2_GA_1975
    Stopping zimbra services
    Stop failed - exiting
    UPGRADE FAILED - exiting

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    New Install or Upgrade?

  3. #3
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    First i was trying to upgrade...but i was receiving an ldap error...
    And nobody here in forum helped me to solve that.

    Now i renamed my zimbra folder to zimbra.old...and i am trying a new install.

    This error that i post on this thread is from new install.

    Please give me a hand on this.

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    So if this is a new install, you have to make sure to uninstall before installing again.

    The installer is confused, and thinks that (because the RPM packages are installed) it's an upgrade.

    Uninstall (./install.sh -u)

    And install again.

  5. #5
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    But if i make this it will delete my zimbra.old folder with all mailboxes inside?

  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    what's the path to that dir?

  7. #7
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    It worked!
    Thanks!

    Now i need some help to move mailboxes from old installation to new.

    path of old installation: /opt/zimbra.old
    path of new installation: /opt/zimbra

    Can you give me a hand to finish this?

  8. #8
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Well
    Try this article
    http://www.zimbra.com/blog/archives/...er_server.html

    Start at Part 3, and pretend that it's a backup.

    FYI
    This will likely fail, but we need to know why Which is why you're going back down the path.

  9. #9
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    This will not work for me.

    I was using zimbra 4.5.6 then i tried to upgrade it to 5.0.2...i got some errors that you can see on my another thread. And my actual zimbra 4.5.6 stopped to work.

    So i renamed the folder from /opt/zimbra to /opt/zimbra.old and installed a new zimbra 5.0.2 installation.

    Now i need to move the mailboxes from /opt/zimbra.old to /opt/zimbra, but /opt/zimbra.old is not working so its impossible to make a backup.

    If i just move the folder STORE with all its contents from /opt/zimbra.old to /opt/zimbra, it will work?

  10. #10
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Start at step 3
    It'll work. We just need to work through it

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-15-2005, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •