Results 1 to 2 of 2

Thread: going crazy....

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Rep Power

    Default going crazy....


    I was installing zimbra for the first time, and noticed that the domain on the hostname was wrong. Aborted instalation, changed hostname in /etc/sysconfig/network (i'm in CentOS) and didn't had nothing in /etc/hosts.

    When i try to install, i get this error:
    Press Return to continue
            ERROR: Installation can not proceeed.  Please fix your /etc/hosts file
            to contain:
   localhost.localdomain localhost
            Zimbra install grants mysql permissions only to localhost and
            localhost.localdomain users.  But Fedora/RH installs leave lines such
            as these in /etc/hosts:
   myhost localhost.localdomain localhost
            This causes MySQL to reject users coming from as users from
    You can read more details at:
    That's ok, but if i do this, the instalation will configure all servers with this domain, (localhost.localdomain) and the servers wont start.

    if i leave it empty, i've got an java error:
    Setting defaults...hostname: Unknown host
            at com.zimbra.cs.localconfig.LC.(
            at com.zimbra.cs.localconfig.KnownKey.(
            at com.zimbra.cs.localconfig.LocalConfig.verify(
            at com.zimbra.cs.localconfig.LocalConfig.(
            at com.zimbra.cs.localconfig.LocalConfig.readConfig(
            at com.zimbra.cs.localconfig.LocalConfig.(
            at com.zimbra.cs.localconfig.Main.main(
    Tryed to install dozens of times, erased all files from zimbra install...

    Is there an uninstall?
    Is there a way to solve this?

    Thanks in advance.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Yes, there is an uninstall you just run the install script again with '-u' (no quotes) and it'll completely remove the Zimbra installation. If you've had install problems I suggest you do an uninstall before trying another install.

    You also need a hosts file in the format: localhost.localdomain localhost
    a.b.c.d host

    with a.b.c.d set as the fixed IP address of your Zimbra server, that should solve your problem. I also use CentOS and that works fine for me.
    Last edited by phoenix; 02-02-2006 at 11:54 AM.


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 1
    Last Post: 06-12-2007, 09:28 PM
  2. Crazy webmail Inbox
    By Adriano_Duarte in forum Administrators
    Replies: 3
    Last Post: 10-29-2006, 07:22 AM
  3. adding button to compose toolbar with a zimlet
    By sdouglass in forum Zimlets
    Replies: 1
    Last Post: 09-18-2006, 06:39 PM
  4. Going Crazy (Fresh Install Problems)
    By hirnschmalz in forum Installation
    Replies: 2
    Last Post: 09-16-2006, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts