Results 1 to 2 of 2

Thread: Problem with Upgrade from 4.5.4_GA_736 to 5.0.3_GA_1975 on RHEL 4.0

  1. #1
    Join Date
    Feb 2008
    Posts
    1
    Rep Power
    7

    Default Problem with Upgrade from 4.5.4_GA_736 to 5.0.3_GA_1975 on RHEL 4.0

    I have RHEL 4.0. system with zimbra. I was trying to upgrade zimbra from 4.5.4_GA_736 to 5.0.3_GA_1975. During the upgrade process my system hung. I tried restarting the system but it hung while starting zimbra service. I had to stop zimbra service from starting automatically to start RHEL.

    Attached is the setup log from /tmp

    I've also try upgrading again but setup now shows following error

    ************
    Shutting down zimbra mail

    Backing up the ldap database...failed.

    bdb_db_open: unclean shutdown detected; attempting recovery.
    bdb_db_open: Recovery skipped in read-only mode. Run manual recovery if errors are encountered.
    bdb(): Program version 4.2 doesn't match environment version
    bdb_db_open: Database cannot be opened, err 22. Restore from backup!
    bdb(): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
    backend_startup_one: bi_db_open failed! (22)
    slap_startup failed


    Any help would be by higly appriciated. Thanks
    Attached Files Attached Files

  2. #2
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    My search-logic brain isn't working yet this am so I can't come up with a reference for you, but your problem is that the 5.x installers won't upgrade in a single bound from that old a version of 4. I think (but can't remember) that the oldest version of 4.x.x from which you can upgrade to 5.x is 4.5.7.

    In any case, you can upgrade from your current version to 4.5.11 which is downloadable, and then go from there to 5.0.2 and you should have smooth sailing. No need to jump through all the other versions stepwise; just get onto a later 4 and then fire off 5.

    Don't forget to take a full backup of /opt/zimbra before each upgrade!

    Cheers,

    Dan

Similar Threads

  1. Problem after upgrade to 5.0
    By bmannella in forum Installation
    Replies: 6
    Last Post: 01-26-2008, 01:35 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-29-2006, 12:36 AM
  4. Certificate problem following 3.1.0 -> 4.0 upgrade
    By simonellistonball in forum Migration
    Replies: 5
    Last Post: 09-26-2006, 02:56 PM
  5. nonsecure items popup on ie 6.0 since 4.0 upgrade
    By frostpaw in forum Administrators
    Replies: 10
    Last Post: 09-07-2006, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •