Results 1 to 10 of 47

Thread: Zimbra 5 install on CentOS 5 / MX Record

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Posts
    50
    Rep Power
    8

    Default Zimbra 5 install on CentOS 5 / MX Record

    To begin, I apologize if this answer is in another post. If it is, then I didn't find it.

    I am working to install Zimbra 5.02 on a 64-bit CentOS 5 Linux server. The current email setup for this organization is a simple POP3 email service to its hosting service, so I can't afford to redirect the MX record in order to setup Zimbra. Here are my questions / issues:
    1. Can Zimbra be successfully installed and setup without resolving a MX record during setup?
    2. If so, will it be easy for Zimbra to pick up the email traffic once the MX record is redirected?
    3. Is anyone else having trouble with the SQL databases not populating during setup? Setup for Zimbra-store can not connect to the MySQL server via its socket.


    I know that these are detailed questions, but any help would be greatly appreciated!

    Thanks!

    ~ Bryce

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    1. Can Zimbra be successfully installed and setup without resolving a MX record during setup?
    >yes
    1. If so, will it be easy for Zimbra to pick up the email traffic once the MX record is redirected?
    >Depending on your TTL for you MX records. I would decrease it to abou 30 min about 2 days before the actual move.
    1. Is anyone else having trouble with the SQL databases not populating during setup? Setup for Zimbra-store can not connect to the MySQL server via its socket.
    >Can you post your zmsetup.log and install.log?

  3. #3
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default

    For testing purposes, I setup a second MX record and A record for my machine while testing ZCS. Then when I was ready to go online, I changed everything to the new server. If you're hosting your own DNS this is rather simple. If your ISP is hosting your DNS they may get a little perturbed if you ask them to make too many changes. Setting up the second set of records put to rest the question of no MX record while testing.

  4. #4
    Join Date
    Feb 2008
    Location
    Holland
    Posts
    5
    Rep Power
    7

    Default

    Zimbra works without MX record.

    For MTA outgoing email use your providers smtp server (relayMTA for external delivery).

    For incoming email, uncheck dns reverse lookup for MTA

    Use fetchmail to get external pop3 mail

  5. #5
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default

    Unchecking DNS checks will open up the mail server to a lot more spam. DNS checking blocks 80% of the spam trying to come into my mail server.

    It's best to follow the RFC's for setting up a mail server and its DNS. Then everybody wins.

  6. #6
    Join Date
    Jul 2007
    Posts
    50
    Rep Power
    8

    Default

    I apologize for the delay in replying (life happens).

    Where is the Zimbra setup log? Is it in the /tmp or /opt/zimbra folder?

    Thanks for your help!

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    When doing any dig commands you should only use the domain name not the FQDN of your server, the correct check for the A record would be:
    Code:
    dig fairhavenchurch.org any
    Also the test for the hostname must be in this format:

    Code:
    host `hostname`  <-- that's backticks not single quotes
    you must enter the word 'hostname' not the FQDN of your mailserver and that will test if your your /etc/hosts file is correct.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  2. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  3. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •