Results 1 to 7 of 7

Thread: DNS Problem on Ubuntu

  1. #1
    Join Date
    Mar 2008
    Location
    Carpi ( Modena ) - ITALY
    Posts
    13
    Rep Power
    7

    Default DNS Problem on Ubuntu

    Hi all.

    I need to install Zimbra on a DMZ server ( 192.168.1.180 ) with Ubuntu 6.06.2 LTS and FQDN hostname ( /etc/hostname ) "mx.domain.it"
    My default gateway ( 192.168.1.254 ) route correctly all port needed.

    I haven't a DNS server in my DMZ or LAN but I use a ISP DNS ( 212.97.32.2 )

    How can i configure my installation for a full Zimbra install on a server ?

    Is right this howto to set-up bind9 on the same server?

    In:
    Code:
    "/etc/bind/zones/domain.it.db"
    from the example
    Code:
    // replace example.com with your domain name. do not forget the . after the domain name!
    // Also, replace ns1 with the name of your DNS server
    example.com.      IN      SOA     ns1.example.com. admin.example.com. (
    // Do not modify the following lines!
                                                            2006081401
                                                            28800
                                                            3600
                                                            604800
                                                            38400
     )
    
    // Replace the following line as necessary:
    // ns1 = DNS Server name
    // mta = mail server name
    // example.com = domain name
    example.com.      IN      NS              ns1.example.com.
    example.com.      IN      MX     10       mta.example.com.
    
    // Replace the IP address with the right IP addresses.
    www              IN      A       192.168.0.2
    mta              IN      A       192.168.0.3
    ns1              IN      A       192.168.0.1
    I change:
    "example.com" with "domain.it"
    "ns1.example.com" with "mx.domain.it"
    "mta.example.com" with "mx.domain.it"
    "mta" with "mx" and ip address 192.168.1.180
    "ns1" with "mx" and ip address 192.168.1.180

    In
    Code:
    "/etc/bind/zones/rev.1.168.192.in-addr.arpa"
    from the example
    Code:
    //replace example.com with yoour domain name, ns1 with your DNS server name.
    // The number before IN PTR example.com is the machine address of the DNS server. in my case, it's 1, as my IP address is 192.168.0.1.
    @ IN SOA ns1.example.com. admin.example.com. (
                            2006081401;
                            28800; 
                            604800;
                            604800;
                            86400 
    )
    
                         IN    NS     ns1.example.com.
    1                    IN    PTR    example.com
    I change:

    "ns1.example.com" with "mx.domain.it"
    "example.com" with "domain.it"

    When I install Zimbra there's some errors on the DNS resolution.

    Could you help me ???
    Filloweb

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    This appears to be your third post on this subject, I've already answerd this questions once so please don't post duplicates.

    You need a Split DNS set-up for mail delivery, follow the instructions on the wiki if you are a Ubuntu user or the other link in the wiki if you're on another o/s.
    Last edited by phoenix; 03-12-2008 at 07:06 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2008
    Location
    Carpi ( Modena ) - ITALY
    Posts
    13
    Rep Power
    7

    Default

    Ops...
    I can't see the other post... The other posts return me an error of SPAM.

    Sorry.
    filloweb

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    What are the error messages you are receiving ?

    Would you also please perform these commands on the server where Zimbra is being installed and post the results :-

    Code:
    cat /etc/resolv.conf
    cat /etc/hosts
    dig @localhost domain.it ns
    dig @localhost domain.it mx
    Many thanks.

  5. #5
    Join Date
    Mar 2008
    Location
    Carpi ( Modena ) - ITALY
    Posts
    13
    Rep Power
    7

    Default

    Hi,

    thanks a lot for you support.

    I've follow the guide Ubuntu 6.06 Server (Dapper Drake) Beginner's Install Guide - Zimbra :: Wiki
    and the DNS chapter and I think all work fine.

    Here "cat /etc/resolv.conf" output
    Code:
    nameserver 192.168.1.180
    Here "cat /etc/hosts"
    Code:
    127.0.0.1       localhost.localdomain   localhost
    192.168.1.180   mx.domain.it           mx
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Here "dig @localhost domain.it ns"
    Code:
    ; <<>> DiG 9.3.2 <<>> @localhost domain.it ns
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20002
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;domain.it.                    IN      NS
    
    ;; ANSWER SECTION:
    domain.it.             604800  IN      NS      mx.domain.it.
    
    ;; ADDITIONAL SECTION:
    mx.domain.it.          604800  IN      A       192.168.1.180
    
    ;; Query time: 4 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Mar 13 12:33:14 2008
    ;; MSG SIZE  rcvd: 61
    And here "dig @localhost domain.it mx"
    Code:
    ; <<>> DiG 9.3.2 <<>> @localhost domain.it mx
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38570
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;domain.it.                    IN      MX
    
    ;; ANSWER SECTION:
    domain.it.             604800  IN      MX      10 mx.domain.it.
    
    ;; AUTHORITY SECTION:
    domain.it.             604800  IN      NS      mx.domain.it.
    
    ;; ADDITIONAL SECTION:
    mx.domain.it.          604800  IN      A       192.168.1.180
    
    ;; Query time: 3 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Mar 13 12:34:35 2008
    ;; MSG SIZE  rcvd: 77
    Is it all right ???

    Thanks a lot.
    filloweb

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    and the following aswell please :-

    Code:
    host `hostname` <- backticks not quotes

  7. #7
    Join Date
    Mar 2008
    Location
    Carpi ( Modena ) - ITALY
    Posts
    13
    Rep Power
    7

    Default

    Here is:
    Code:
    mx.domain.it has address 192.168.1.180
    Thanks a lot.filloweb

Similar Threads

  1. Zimbra Beta 5_3 with Ubuntu problem, stats
    By mugendai in forum Installation
    Replies: 2
    Last Post: 10-04-2007, 03:33 PM
  2. Problem with Postfix on Ubuntu
    By kgmeyer in forum Installation
    Replies: 6
    Last Post: 01-22-2007, 03:49 AM
  3. Replies: 12
    Last Post: 04-13-2006, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •