Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] LDAP Error

  1. #1
    Join Date
    Mar 2008
    Location
    Jakarta, Indonesia
    Posts
    8
    Rep Power
    7

    Exclamation [SOLVED] LDAP Error

    Help !!!
    *** I am new to zimbra and am trying to install it onto OpenSuse 10.3 with Zimbra 5.
    Below is the result of zmcontrol -H :

    Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN

    *** I am using Compaq 3600 Series P4 1.5Ghz with 512 MB Ram (Knowing it is below recommendation)
    I have followed BigMudCake instruction to the detail. However when I run the last instruction, it gave me the following result :

    zimbra@mail:/opt/zcs-5.0.2_GA_1975.openSUSE_10.2.20080130231825> /opt/zimbra/bin/zmcontrol stop
    Host mail.nojima.com
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping logger...Done
    Stopping ldap...FAILED
    ldap_url and ldap_master_url cannot be the same on an ldap replica


    zimbra@mail:/opt/zcs-5.0.2_GA_1975.openSUSE_10.2.20080130231825> /opt/zimbra/bin/zmcontrol start
    Host mail.nojima.com
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.
    zimbra@mail:/opt/zcs-5.0.2_GA_1975.openSUSE_10.2.20080130231825>

    *** When I use ldapsearch on ldap_url & ldap_master_url it produced :

    zimbra@mail:~/bin> ldapsearch ldap_url
    ldap_sasl_interactive_bind_s: Can't contact LDAP server (-1)
    zimbra@mail:~/bin> ldapsearch ldap_master_url
    ldap_sasl_interactive_bind_s: Can't contact LDAP server (-1)

    *** When I looked into /opt/zimbra/openldap-data it is empty with no files except 2 folders which is db & logs. Both the db & logs folder is empty too.
    My guesse would be that the installation have not created any ldap databases. Any instruction for manual creation ?

    Thanks.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums misc

    While Zimbra is shutdown could you perform the following please :-

    Code:
    netstat -an | grep 389
    ps -ef | grep slap
    just to ensure that no other LDAP services are running.

  3. #3
    Join Date
    Mar 2008
    Location
    Jakarta, Indonesia
    Posts
    8
    Rep Power
    7

    Default

    Dear uxbod,
    Thx for the responds.

    This is what I get :

    zimbra@mail:~/bin> zmcontrol stop
    Host mail.nojima.com
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping logger...Done
    Stopping ldap...FAILED
    ldap_url and ldap_master_url cannot be the same on an ldap replica

    zimbra@mail:~/bin> netstat -an | grep 389
    zimbra@mail:~/bin> ps -ef | grep slap
    zimbra 14951 14749 0 22:13 pts/1 00:00:00 grep slap
    zimbra@mail:~/bin>

    *** Any suggestion ?

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Hi Misc,

    i think this may be a DNS issue. Is your installation on a private LAN behind a firewall ?

    Would do post the output from the following commands please :-

    Code:
    cat /etc/resolv.conf
    cat /etc/hosts
    dig nojima.com ns
    dig nojima.com mx
    Thanks. We shall get you up and running.

  5. #5
    Join Date
    Mar 2008
    Location
    Jakarta, Indonesia
    Posts
    8
    Rep Power
    7

    Default

    Dear uxbod,

    Its actually a single linux machine at the moment and I have diasble the firewall.
    Below is the requested action result :

    mail:/opt/zimbra/libexec # cat /etc/resolv.conf
    domain nojima.com
    mail:/opt/zimbra/libexec # cat /etc/hosts
    #
    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    127.0.0.2 mail.nojima.com mail
    192.168.1.50 mail.nojima.com mail
    mail:/opt/zimbra/libexec # dig nojima.com ns

    ; <<>> DiG 9.4.1-P1 <<>> nojima.com ns
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15311
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;nojima.com. IN NS

    ;; ANSWER SECTION:
    nojima.com. 172800 IN NS mail.nojima.com.
    nojima.com. 172800 IN NS gateway.nojima.com.

    ;; ADDITIONAL SECTION:
    mail.nojima.com. 172800 IN A 192.168.1.50
    gateway.nojima.com. 172800 IN A 192.168.1.1

    ;; Query time: 4 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Mar 12 23:17:09 2008
    ;; MSG SIZE rcvd: 101

    mail:/opt/zimbra/libexec # dig nojima.com mx

    ; <<>> DiG 9.4.1-P1 <<>> nojima.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41095
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;nojima.com. IN MX

    ;; ANSWER SECTION:
    nojima.com. 172800 IN MX 0 mail.nojima.com.

    ;; AUTHORITY SECTION:
    nojima.com. 172800 IN NS mail.nojima.com.
    nojima.com. 172800 IN NS gateway.nojima.com.

    ;; ADDITIONAL SECTION:
    mail.nojima.com. 172800 IN A 192.168.1.50
    gateway.nojima.com. 172800 IN A 192.168.1.1

    ;; Query time: 5 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Mar 12 23:17:20 2008
    ;; MSG SIZE rcvd: 117

    *** Thx for the assistance. I wish to get it up and running so that I can test zimbra out.
    Best Regards.

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Why in your hosts file do you have your server name listed twice ?

    Code:
    127.0.0.2 mail.nojima.com mail
    192.168.1.50 mail.nojima.com mail

  7. #7
    Join Date
    Mar 2008
    Location
    Jakarta, Indonesia
    Posts
    8
    Rep Power
    7

    Default

    Dear uxbod,

    *** I did not enter 127.0.0.2 as mail.nojima.com mail, it was created by Suse Yast DNS Server. Should I deleted that entry ?


    ***# ldap_url and ldap_master_url cannot be the same on an ldap replica
    *** Can you teach me how to look up ldap_url & ldap_master_url in Zimbra LDAP ?
    For my situation, what would the normal value for the 2 paremater be ?
    Also can you teach me how to manually set the value for ldap_url & ldap_master_url ? The password I used for Zimbra LDAP is sasuke

    Thanks for the attention & help.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    if that entry is not used on the server then delete it.

    would you also change in /etc/hosts the localhost entry so that it looks like :-

    Code:
    127.0.0.1 localhost.localdomain localhost
    once that is have been done would you please run the following command and post the result :-

    Code:
    host `hostname`  <-- with backticks not single quotes
    Last edited by uxbod; 03-13-2008 at 02:03 AM.

  9. #9
    Join Date
    Mar 2008
    Location
    Jakarta, Indonesia
    Posts
    8
    Rep Power
    7

    Default

    Dear uxbod,

    *** This is the requested result :

    mail:/opt/zimbra/bin # host `hostname`
    mail.nojima.com has address 192.168.1.50

    *** Would this help ?

    zimbra@mail:~/bin> ./zmcontrol stop
    Host mail.nojima.com
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping logger...Done
    Stopping ldap...Done
    zimbra@mail:~/bin> ./zmcontrol start
    Host mail.nojima.com
    Starting ldap...Done.
    FAILED
    Failed to start slapd. Attempting debug start to determine error.

    zimbra@mail:~/bin>

    *** Thanks for the attention & help

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Now your hosts has been tidied up, and as this is a fresh install I would say shutdown ZM, remove /opt/zimbra and start a fresh. As you have no existing mailstores it would ensure that everything is setup nice and clean

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 03:44 PM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •