Results 1 to 5 of 5

Thread: [SOLVED] VMware/rPath Zimbra won't start up - "Failure in name resolution"?

  1. #1
    Join Date
    Mar 2008
    Posts
    3
    Rep Power
    7

    Default [SOLVED] VMware/rPath Zimbra won't start up - "Failure in name resolution"?

    I'm trying to evaluate Zimbra by installing the VMware virtual machine distro in my virtual test network. I'm getting this message in the "Zimbra Services" menu item of the rPath web admin portal:

    Code:
    error: /etc/conaryrc:3: when processing includeConfigFile: /etc/conary/config.d/zimbra:1: when processing includeConfigFile: Error reading config file http://updates.zimbra.com/conaryrc: Temporary failure in name resolution Release RPL1
    
    Cannot determine services - exiting
    "failure in name resolution" - hmm, sure sounds like a DNS problem. My VM, however, has a correct IP address, correct hostname entered, full name resolution (internally) forwards and reverse from DNS for mail.example.foo, both A and MX records, and can correctly resolve updates.zimbra.com as 72.3.241.122. At first blush, you'd think that name resolution wouldn't be a problem.

    There are no other helpful log entries I could uncover.

    There are two other (unresolved) posts on this board referencing this issue (search for 'em). They're not much help though.

    What else could this be? What am I doing wrong?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Okay, lets just double check the basics first (I know you have done this but for others to see). Please run the following commands and post the results :-

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    host `hostname` <-- with backticks not single quotes
    dig _domainname_ ns
    dig _domainname_ mx
    Thanks.
    Last edited by uxbod; 03-13-2008 at 02:19 AM.

  3. #3
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    dig ns
    dig mx
    you can't put stuff inside angle brackets on this forum, doesn't work

  4. #4
    Join Date
    Mar 2008
    Posts
    3
    Rep Power
    7

    Default

    Thanks for the replies, all.

    Since I posted this thread, without having changed my configuration at all, Zimbra miraculously got past the resolution error. Unfortunately it acquired a new one - the LDAP server won't start, and seems to have been misconfigured by rPath - but that's for another post.

    Code:
    [root@mail ~]# cat /etc/hosts
    #Installed by rBuilder
    127.0.0.1 mail.example.foo localhost.localdomain localhost mail
    [root@mail ~]# cat /etc/resolv.conf 
    ; generated by /sbin/dhclient-script
    nameserver 10.0.0.10
    search example.foo
    [root@mail ~]# host `hostname`
    mail.example.foo has address 10.0.1.120
    mail.example.foo mail is handled by 10 mail.example.foo.
    [root@mail ~]# dig mail.example.foo mx
    
    ; <<>> DiG 9.3.4 <<>> mail.example.foo mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26317
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mail.example.foo.		IN	MX
    
    ;; ANSWER SECTION:
    mail.example.foo.	259200	IN	MX	10 mail.example.foo.
    
    ;; AUTHORITY SECTION:
    example.foo.		259200	IN	NS	ns1.example.foo.
    
    ;; ADDITIONAL SECTION:
    mail.example.foo.	259200	IN	A	10.0.1.120
    ns1.example.foo.	259200	IN	A	10.0.0.10
    
    ;; Query time: 4 msec
    ;; SERVER: 10.0.0.10#53(10.0.0.10)
    ;; WHEN: Thu Mar 13 12:50:11 2008
    ;; MSG SIZE  rcvd: 100
    
    [root@mail ~]# dig mail.example.foo ns
    
    ; <<>> DiG 9.3.4 <<>> mail.example.foo ns
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52303
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.example.foo.		IN	NS
    
    ;; AUTHORITY SECTION:
    example.foo.		86400	IN	SOA	example.foo. admin.example.foo. 2008031211 43200 7200 1209600 86400
    
    ;; Query time: 2 msec
    ;; SERVER: 10.0.0.10#53(10.0.0.10)
    ;; WHEN: Thu Mar 13 12:50:18 2008
    ;; MSG SIZE  rcvd: 76
    It all looks pretty normal to me. I know example.foo isn't a real FQDN but this is a test environment and hasn't caused trouble with any of my other VMs thusfar.

    Rather than uncovering whatever error next awaits after getting the LDAP server up, I'm inclined to start again with a fresh copy of the VM. I'm going to give that a try and report back.

    I'm of the belief that an application appliance should more or less work out of the box. Once the proper, basic configuration has been made, an administrator shouldn't have to puzzle out arcane implementation details like why the LDAP server won't start. That's the whole point of an appliance.

    I gotta tell ya, I've tried implementing Zimbra three times in three years, and failed every time. I'm usually clever enough to eventually work out the issues, but Zimbra has always seemed a little opaque to me....

    Thanks again for the replies.

  5. #5
    Join Date
    Mar 2008
    Posts
    3
    Rep Power
    7

    Default

    Well, what do you know...

    A fresh copy of the Zimbra/rPath VM works out of the box, no issues.

    It's enough to make you suspicious of cp -R....

Similar Threads

  1. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  2. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  4. Replies: 8
    Last Post: 02-27-2007, 03:10 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •