Results 1 to 7 of 7

Thread: Options when running from damaged install

  1. #1
    Join Date
    Nov 2005
    Posts
    63
    Rep Power
    10

    Default Options when running from damaged install

    I'm currently running 4.5.6 on CentOS5 and have been for quite some time without any notable problems. This is a server that has been progressively upgraded from the 3.x series on CentOS4 then the 4.x series on CentOS4 and then continuing the 4.5.x series on CentOS5.

    My issue is that I'm unable to upgrade from 4.5.6 to any other version (including a reinstall of 4.5.6). I've tried (at least) 4.5.7, 4.5.10, 4.5.11 and 5.0.2 with no success. After each attempt, I've rolled back to a previous backup to avoid any cross-version contamination.

    The manifests itself as though my system no longer knows what version it is, although zmcontrol -v reports 4.5.6 successfully. The symptoms seem to be very similar to those described in this thread http://www.zimbra.com/forums/adminis...html#post81563
    and I've attempted the fixes suggested there, but they have had no affect; the original poster seems to have had a similar lack of success.

    My install attempts all end with the following, and I will attach a couple of the install logs as well .

    Code:
    Upgrading from  to 5.0.2_GA_1975
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql
    Starting logger mysql
    I can't upgrade version
    
    UPGRADE FAILED - exiting
    Any help or suggestions (even long shots) would be greatly appreciated.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2005
    Posts
    63
    Rep Power
    10

    Default Crossplatform Rescue

    Is it plausible that taking this install, moving it to a new server (running anything EXCEPT CentOS 5 - but is supported by 4.5.6) and letting a slightly different installer (new OS) have a pass at it would yield positive results?

    --Will

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Getting off 4.5.6 and it's clamav fun is definitely a good idea.

    Ya, doesn't seem to know what it is:
    Upgrading from to 5.0.2_GA_1975
    Upgrading from to 4.5.6_GA_1044
    Different things to try (as you're already doing make a backup before attempting any of the below of course):

    Fresh packages might help:
    /blog/archives/2007/10/moving_zcs_to_another_server.html
    -Either with a new OS or still CentOS 5 (I'm feeling the platform isn't as key to this as you're thinking, but feel free to do it twice and prove me wrong!)

    Before upgrading did you check for any stray processes?
    zmcontrol stop
    ps aux | grep zimbra
    For instance logger is notorious for sticking around Bug 18653 - zmlogger orphaned on shutdown
    Starting logger mysql
    I can't upgrade version
    UPGRADE FAILED - exiting
    Have you checked the 'health' of your logger instance lately? Logger - Zimbra :: Wiki

    Or perhaps, as it seems to be stopping just after starting the logger, maybe remove it altogether?
    zmprov mcf -zimbraComponentAvailable logger
    zmprov ms `zmlocalconfig -m nokey zimbra_server_hostname` -zimbraServiceEnabled logger
    zmprov ms `zmlocalconfig -m nokey zimbra_server_hostname` -zimbraServiceInstalled logger
    rpm -e zimbra-logger
    Good luck!

  4. #4
    Join Date
    Nov 2005
    Posts
    63
    Rep Power
    10

    Default

    Quote Originally Posted by mmorse View Post
    Fresh packages might help:
    /blog/archives/2007/10/moving_zcs_to_another_server.html
    -Either with a new OS or still CentOS 5 (I'm feeling the platform isn't as key to this as you're thinking, but feel free to do it twice and prove me wrong!)
    What do you mean by fresh packages? I've been installing using re-downloaded files and the RPMs always uninstall and reinstall properly (or so it seems). Is there something beyond this?

    Quote Originally Posted by mmorse View Post
    Before upgrading did you check for any stray processes?
    Every time.

    Quote Originally Posted by mmorse View Post
    Have you checked the 'health' of your logger instance lately?
    Or perhaps, as it seems to be stopping just after starting the logger, maybe remove it altogether?
    Good luck!
    The logger DB contained tables that were in need of repair, but fixing them made no difference. I then followed your last piece of advice and removed the logger (successfully) - but on my next install attempt, it was the same story, minus one line:
    Code:
    Setting defaults from existing config...Upgrading from  to 4.5.6_GA_1044
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql
    I can't upgrade version
    
    UPGRADE FAILED - exiting
    Is there anyway to force the installer script to assume a certain existing version? If not, is there any way to force my existing installation to report back a given version when checked by the install script?

    Thanks for your suggestions. I really appreciate the help in getting to the bottom of this.

    --Will

  5. #5
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    post the contents of /opt/zimbra/.install_history it's likely corrupted.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    Join Date
    Nov 2005
    Posts
    63
    Rep Power
    10

    Default

    Hope this is meaningful.

    Thanks,

    Will
    Attached Files Attached Files

  7. #7
    Join Date
    Nov 2005
    Posts
    63
    Rep Power
    10

    Default

    Quote Originally Posted by brian View Post
    post the contents of /opt/zimbra/.install_history it's likely corrupted.
    I just compared that file to the one on another Zimbra server that I admin and found the differences. I spliced in what I guessed the installer was looking for and am now (happily) running 4.5.8

    Thanks for the help.

    --Will

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 09:22 AM
  3. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •