Wow so much to learn...

I'm facing a problem with mail that goes out but can't come in. When I started with 4.5.9 the solution was to use a separate MTA to convert the internal domain names to the external domain names. I'm not so comfortable with scripts and time is not abundant to load postfix with a bunch of manual entries, as I don't have well lexed personnel to work with me at command line level.

Anyway, I'm running 5.0.2 GA on SuSE 10.2, one server as I have less than 50 users. Config was a snap, except that the MTA set up is too simple to make it work. I run 2 internal DNS servers for local resolution, and cache for internet. I have defined the ZCS on the internal DNS as mail2.mydomain.int (since it is my internal domain anyway) with both A and MX records. I also have defined A and MX records for the public domain.com on our ISP DNS servers. The external MX record points to the firewall IP and it port forwards to the ZCS server IP all port 25 traffic.

When I send msg to my yahoo acct, I get it fine, when I reply, I get message that mydomain.com mail relay has denied access to deliver message. I can access the ZCS when I telnet to both mx.mydomain.com or the IP with port 25. HELO responds fine. However, I don't want to open my MTA to unscrupulous use, but I can't make it let any msg sent to mydomain.com work.

Docs mention that it is a good idea to set up a relay MTA between the ZCS server(s) and the Internet. As I said, working with postfix may be easy for me if I had time, but I'd rather show my backups (people) how to make changes via a GUI as they are not Unix/Linux anything. I tried to just install the Zimbra MTA but I get no Mgmt. CLI only??

Now, here is the big wrench to the problem. I run several companies and use the same people for different things (blame the state's laws for this) but I need to be able to differentiate between each domain's inbound message, and when a user replies to it, I need to maintain the domain that it was received from. Since I run an internal domain, all messages will route to the same mailbox. i.e. I may receive a message TO:carpicker@domain.com or carpicker@domain.biz but when I reply it needs to go back as if I was responding from only one domain. My users can't seem to comprehend the multiple ID/mailbox, so I have to put the brains on the server.

This is my current approach, but unable to receive msg gives me no proof that it works. Define user1@domain.com, user1a@domain.biz, share mailbox from user1a with user1 and use the 'On behalf of' feature to send mail as if user1a.

Any suggestions?? BTW, multiple servers are not an issue as I have them all inside VMware hosts and have resources left for up to 4 servers, but like to 'KISS' as I'm the whole IT Dept, and the big boss too, so IT is only 40% of my time.

Thanks
carpicker