Results 1 to 10 of 16

Thread: zmmailboxdctl is not running

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Posts
    8
    Rep Power
    7

    Default zmmailboxdctl is not running

    Hi!

    I have been having some trouble with the FOSS edition of Zimbra.

    The server was running w/o problems during the last 2 months. We rebooted the server last night.

    After a server reboot zimbra did not load up anymore, and the following where the results of my tests:

    zimbra@poseidon:~$ zmcontrol status
    Host wglatina.dyndns.org
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running
    mta Running
    snmp Running
    spell Running
    stats Running


    zimbra@poseidon:~$ zmprov
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@poseidon:~$

    zimbra@poseidon:~$ zmprov gs wglatina.dyndns.org
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@poseidon:~$

    tail -f /var/log/zimbra.log
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: antivirus: Running
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: ldap: Running
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: logger: Running
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: mailbox: Stopped
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: mta: Running
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: snmp: Running
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: spell: Running
    Mar 25 12:40:14 poseidon zimbramon[22137]: 22137:info: 2008-03-25 12:40:01, STATUS: wglatina.dyndns.org: stats: Running


    The following message is also displayed
    Mar 25 12:17:10 poseidon zmmailboxdmgr[16321]: manager woke up from wait on mailboxd/JVM with pid 16365
    Mar 25 12:17:10 poseidon zmmailboxdmgr[16321]: mailboxd/JVM exited twice in 3 seconds (tolerance=60)

    I tryed to see what the problem is, however I have no clue. I also tryed to reinstall the zimbra software (running on ubuntu LTS) and did not help.

    root@poseidon:~# hostname
    poseidon.wglatina.dyndns.org
    root@poseidon:~# hostname -f
    poseidon.wglatina.dyndns.org
    root@poseidon:~# dig mx wglatina.dyndns.org

    ; <<>> DiG 9.3.2 <<>> mx wglatina.dyndns.org
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39490
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;wglatina.dyndns.org. IN MX

    ;; ANSWER SECTION:
    wglatina.dyndns.org. 604800 IN MX 20 poseidon.wglatina.dyndns.org.
    wglatina.dyndns.org. 604800 IN MX 10 wglatina.dyndns.org.


    Does anyone have any clue what might be happening?
    Last edited by gargola; 03-25-2008 at 05:35 AM. Reason: addendum

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    What O/S and version of Zimbra ?

    Please post /opt/zimbra/log/zmmailboxd.out

  3. #3
    Join Date
    Mar 2008
    Posts
    8
    Rep Power
    7

    Default

    Hi,

    OS: Ubuntu 6.06 LTS (Server)
    Version: 5.0.2

  4. #4
    Join Date
    Mar 2008
    Posts
    8
    Rep Power
    7

    Default cat /opt/zimbra/log/zmmailboxd.out

    see attachment
    Attached Files Attached Files

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Looks like something is already using the ports :-

    Code:
    Zimbra server reserving server socket port=143 bindaddr=null ssl=false\
    Zimbra server reserving server socket port=993 bindaddr=null ssl=true\
    Fatal error: exception while binding to ports\
    java.net.BindException: Address already in use\
    While Zimbra is down could you run the following :-

    Code:
    netstat -an
    so we can see what ports are in use.

  6. #6
    Join Date
    Mar 2008
    Posts
    8
    Rep Power
    7

    Default

    Yes I thought so too, however a netstat -an says does not lead into anything:

    root@poseidon:~# netstat -an
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:49409 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2049 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
    tcp 0 0 192.168.178.2:53 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:19000 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:19001 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:925 0.0.0.0:* LISTEN
    tcp 0 0 192.168.178.2:39660 129.13.251.52:24 ESTABLISHED
    tcp6 0 0 :::1100 :::* LISTEN
    tcp6 0 0 :::2222 :::* LISTEN
    tcp6 0 0 :::53 :::* LISTEN
    tcp6 0 0 :::22 :::* LISTEN
    tcp6 0 0 ::1:19000 :::* LISTEN
    tcp6 0 0 ::1:953 :::* LISTEN
    tcp6 0 256 ::ffff:192.168.178.2:22 ::ffff:192.168.178.5:55339 ESTABLISHED
    tcp6 0 0 ::ffff:192.168.178.2:59299 ::ffff:192.168.178.2:389 TIME_WAIT
    tcp6 0 0 ::1:33750 ::1:59639 TIME_WAIT
    udp 0 0 0.0.0.0:2049 0.0.0.0:*
    udp 105216 0 0.0.0.0:514 0.0.0.0:*
    udp 0 0 0.0.0.0:32770 0.0.0.0:*
    udp 0 0 192.168.178.2:137 0.0.0.0:*
    udp 0 0 0.0.0.0:137 0.0.0.0:*
    udp 0 0 192.168.178.2:138 0.0.0.0:*
    udp 0 0 0.0.0.0:138 0.0.0.0:*
    udp 0 0 0.0.0.0:922 0.0.0.0:*
    udp 0 0 0.0.0.0:32801 0.0.0.0:*
    udp 0 0 192.168.178.2:53 0.0.0.0:*
    udp 0 0 127.0.0.1:53 0.0.0.0:*
    udp 0 0 0.0.0.0:67 0.0.0.0:*
    udp 0 0 0.0.0.0:69 0.0.0.0:*
    udp 0 0 0.0.0.0:987 0.0.0.0:*
    udp 0 0 0.0.0.0:990 0.0.0.0:*
    udp 0 0 0.0.0.0:111 0.0.0.0:*
    udp6 0 0 :::32802 :::*
    udp6 0 0 :::53 :::*
    raw 0 0 0.0.0.0:1 0.0.0.0:* 7
    Active UNIX domain sockets (servers and established)
    Proto RefCnt Flags Type State I-Node Path
    unix 2 [ ] DGRAM 5335 @/org/kernel/udev/ude
    vd
    unix 8 [ ] DGRAM 323051 /dev/log
    unix 2 [ ] DGRAM 931414
    unix 3 [ ] STREAM CONNECTED 931413
    unix 3 [ ] STREAM CONNECTED 931412
    unix 2 [ ] DGRAM 930560
    unix 2 [ ] DGRAM 325021
    unix 2 [ ] DGRAM 324343
    unix 2 [ ] DGRAM 323446
    unix 2 [ ] DGRAM 323098
    unix 2 [ ] DGRAM 262510
    unix 2 [ ] DGRAM 9624

    aswell as a nmap to the localhost:

    root@poseidon:~# nmap localhost

    Starting Nmap 4.20 ( Insecure.Org - Nmap Free Security Scanner, Tools & Hacking resources ) at 2008-03-25 23:52 CET
    Interesting ports on localhost (127.0.0.1):
    Not shown: 1688 closed ports
    PORT STATE SERVICE
    22/tcp open ssh
    53/tcp open domain
    111/tcp open rpcbind
    139/tcp open netbios-ssn
    445/tcp open microsoft-ds
    925/tcp open unknown
    953/tcp open rndc
    993/tcp open imaps
    2049/tcp open nfs

    Nmap finished: 1 IP address (1 host up) scanned in 0.148 seconds
    root@poseidon:~# nmap wglatina.dyndns.org

    Starting Nmap 4.20 ( Insecure.Org - Nmap Free Security Scanner, Tools & Hacking resources ) at 2008-03-25 23:53 CET
    Interesting ports on poseidon.wglatina.dyndns.org (192.168.178.2):
    Not shown: 1689 closed ports
    PORT STATE SERVICE
    22/tcp open ssh
    53/tcp open domain
    111/tcp open rpcbind
    139/tcp open netbios-ssn
    445/tcp open microsoft-ds
    925/tcp open unknown
    993/tcp open imaps
    2049/tcp open nfs

    Nmap finished: 1 IP address (1 host up) scanned in 0.147 seconds
    root@poseidon:~#

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 09:22 AM
  3. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •