Hello im having problems installing Zimbra 5.0.2 in this machine.

I Dont Know what is wrong, i checked through the forums but couldnt find a good solution...

I followed this Guide:

How To Install Zimbra Collaboration Suite (ZCS) On Ubuntu | HowtoForge - Linux Howtos and Tutorials

During installation everything its ok untill this step:

Code:
DNS ERROR resolving MX for mail.tvi.cl
It is suggested that the domain name have an MX record configured in DNS
Change domain name? [Yes] yes
Create Domain: [mail.tvi.cl] tvi.cl
        MX: mail.tvi.cl (200.75.31.110)

        Interface: 192.168.169.33
        Interface: 127.0.0.1


DNS ERROR - none of the MX records for tvi.cl
resolve to this host
It is suggested that the MX record resolve to this host
Re-Enter domain name? [Yes]
Create Domain: [mail.tvi.cl] mail.tvi.cl


DNS ERROR resolving MX for mail.tvi.cl
It is suggested that the domain name have an MX record configured in DNS
Re-Enter domain name? [Yes]
Create Domain: [mail.tvi.cl] mail.tvi.cl
My Dns Configuration for the domain its the following:

A mail 200.75.31.110
A www 200.75.31.110
MX tvi.cl mail.tvi.cl

NOTE THAT: This machine is currently running thorugh a NAT the Internal IP Address its 192.168.168.33. And the EXTERNAL IP 200.75.31.110

What can i do?

Here's my /etc/hosts

Code:
127.0.0.1       localhost.localdomain localdomain
127.0.1.1       tvi.gtdinternet.com     tvi
192.168.169.33  mail.tvi.cl             mail
192.168.169.33  tvi.cl                  mail
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Anyways , if i just continue the installation saying "NO" everything seems fine untill
Code:
Notification complete

Starting servers...done.
Checking for deprecated zimlets...done.
Installing zimlets...
        com_zimbra_cert_manager
        com_zimbra_email
        com_zimbra_phone
        com_zimbra_date
        com_zimbra_search
        com_zimbra_url
        com_zimbra_local
done.
Initializing Documents...failed to initialize documents...see logfile for details.
Restarting mailboxd...done.


Moving /tmp/zmsetup.03252008-185427.log to /opt/zimbra/log
Here's what the log says:

[CODE]
Initializing Documents...
COS attribute retrieved for COS default: zimbraFeatureNotebookEnabled=TRUE
*** Running as zimbra user: /opt/zimbra/bin/zmprov mc default zimbraFeatureNotebookEnabled TRUE
ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
*** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraNotebookAccount wiki@mail.tvi.cl
ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
*** Running as zimbra user: /opt/zimbra/bin/zmprov in wiki@mail.tvi.cl
ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
*** Running as zimbra user: /opt/zimbra/bin/zmprov mc default zimbraFeatureNotebookEnabled FALSE
ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
failed to initialize documents...see logfile for details.
*** Running as zimbra user: /opt/zimbra/bin/zmprov mc default zimbraFeatureNotebookEnabled TRUE
ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
Restarting mailboxd...
*** Running as zimbra user: /opt/zimbra/bin/zmmailboxdctl restart
mailboxd started.
done.
*** Running as zimbra user: /opt/zimbra/bin/zmsshkeygen
ssh-keygen: /opt/zimbra/openssl/lib/libcrypto.so.0.9.8: no version information available (required by ssh-keygen)
Generating public/private dsa key pair.
Your identification has been saved in /opt/zimbra/.ssh/zimbra_identity.
Your public key has been saved in /opt/zimbra/.ssh/zimbra_identity.pub.
The key fingerprint is:
ab:44:27:d2:cc:aa:ad:a1:e2:07:2f:08:80:a9:53:e3 mail.tvi.cl
*** Running as zimbra user: /opt/zimbra/bin/zmupdateauthkeys
updating mail.tvi.cl
Fetching key for mail.tvi.cl
Updating /opt/zimbra/.ssh/authorized_keys

checking isEnabled zimbra-ldap
zimbra-ldap is enabled
checking isEnabled zimbra-store
zimbra-store is enabled
checking isEnabled zimbra-logger
zimbra-logger is enabled
checking isEnabled zimbra-mta
zimbra-mta is enabled
[CODE/]

So I have these 2 problems.

Any Advice would be appreciatted
Thanks In Advance