Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Polling PoP email accounts

  1. #1
    Join Date
    May 2007
    Posts
    53
    Rep Power
    8

    Default Polling PoP email accounts

    Hi,

    Could some one tell me the correct arguments for zmpov mds (user) (ext pop account) zimbraDataSourcePollingInterval 60 ??

    I keep getting "error: account.NO_SUCH_DATA_SOURCE

    trying to switch on pop email polling on FOSS 5.0.x

    Thanks.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Check the setting with:

    zmprov gc default | grep zimbraDataSourcePollingInterval

    Set the interval:

    zmprov mc default zimbraDataSourcePollingInterval 60

    Confirm setting:

    zmprov gc default | grep zimbraDataSourcePollingInterval
    zimbraDataSourcePollingInterval: 60

    Check if the feature is enabled with:

    zmprov gc default | grep zimbraFeatureMailPollingIntervalPreferenceEnabled

    Enable the feature with:

    zmprov mc default zimbraFeatureMailPollingIntervalPreferenceEnabled TRUE
    Last edited by phoenix; 03-29-2008 at 01:21 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    May 2007
    Posts
    53
    Rep Power
    8

    Default

    Thanks Bill,

    "zmprov mc default zimbraFeatureMailingPollingIntervalPreferenceEnabl ed= TRUE"

    everything but the last step works I get the following error:-

    ERROR: account.INVALID_ATTR_NAME (invalid attr name: [LDAP: error code 17 - zimbraFeatureMailingPollingIntervalPreferenceEnabl ed=: AttributeDescription contains inappropriate characters])

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    My fault, there shouldn't be an equals sign in that last command - remove it and it'll work fine.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    May 2007
    Posts
    53
    Rep Power
    8

    Default

    nope took away equals sign still same error.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    What does the following return:

    Code:
    zmprov gc default | grep Polling
    post the results.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    May 2007
    Posts
    53
    Rep Power
    8

    Default

    It seems ok it has returned:-

    zimbraDataSourceMinPollingInterval: 1m
    zimbraDataSourcePollingInterval: 60
    zimbraFeatureMailPollingIntervalPreferenceEnabled: TRUE
    zimbraMailMinPollingInterval: 2m
    zimbraPrefMailPollingInterval: 5m

    But mail still is not coming through. is the above correct?

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Yes, those setting all look OK. What I suggest you now do is go through each of the external accounts save each of their settings again (including the passwords) and save the settings from the accounts tab. Wait until a couple of periods have passed and check your /opt/zimbra/log/mailbox.log and see what messages you are getting about the retrieval.

    Where are you putting the mail when it's retrieved, is it in your Inbox or in separate folders? If you don't retrieve mail on a timed interval, what happens if you hit the Get Mail button?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Mar 2006
    Location
    Kansas City
    Posts
    36
    Rep Power
    9

    Default

    We are having a similar issue. From what I've found, searching the forums, we have things set up correctly (polling interval and polling set to true), yet it doesn't appear that the pollling ever occurs. I can manually check mail and it works without issue, but it does not actually pull it automatically.

    Something I'm missing?

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Post the details of the Polling intervals as per my post above.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  2. Mutiple POP email address on a single User
    By drdre in forum Administrators
    Replies: 12
    Last Post: 11-05-2007, 09:18 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •