Results 1 to 2 of 2

Thread: Initializing ldap Error.

  1. #1
    sajidfiaz Guest

    Unhappy Initializing ldap Error.

    Hello,

    Here are my deployment environment details:

    OS: CENTOS Version 4.4
    Zimbra: zcs-5.0.2_GA_1975.RHEL4.20080130212006.tgz

    I did YUM UPGRADE to update all the libs.

    Followed the installation Guide: disbaled sendmail, postfix, firewall.

    During Installation all the process executes well but when it comes to "APPLY" applying the configuring throughs the following Error:
    /////////// ****************** \\\\\\\\\\\\\\\

    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 970.
    failed. (2304)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.
    /////////// ****************** \\\\\\\\\\\\\\\




    After going through different postings What I DID is:

    cpan -i Scalar::Util

    then executed install.sh got the same Error Again.


    What is the solution to this Error.

    Please Help.

    Regards,
    Sajid

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Welcome to the forums,
    5.0.x GA ships an XS compiled version of Scalar::Util in its perl modules for RHEL4. So before that as root, read the ~zimbra/.bashrc, and set the PERLLIB and PERL5LIB environment variables to match what the zimbra user does, and then try installing.
    export PERLLIB=/opt/zimbra/zimbramon/lib:/opt/zimbra/zimbramon/lib/i386-linux-thread-multi
    export PERLLIB
    PERL5LIB=$PERLLIB
    export PERL5LIB
    This should tell perl to use the Zimbra perl libraries before using the system perl libraries.

    The root of the problem is that RedHat, for whatever reason, decided to build Scalar::Util without XS support on 32-bit RHEL4. RHEL4 64-bit, RHEL5, and RHEL5 64-bit did not have this issue. But in order to have consistency though, for 5.0.1+ we shipped Scalar::Util for all of those, so that our perl builds are identical regardless of platform.

    Just curious - what's your perl version show as? (perl -v)
    You could also see jdell's post on downgrading perl.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 03:58 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  4. Replies: 4
    Last Post: 11-15-2006, 11:16 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •