Results 1 to 10 of 19

Thread: [SOLVED] Error Upgrading 5.0.2 to 5.0.4 URGENT

Hybrid View

  1. #1
    Join Date
    Dec 2007
    Location
    Belgium
    Posts
    85
    Rep Power
    8

    Default [SOLVED] Error Upgrading 5.0.2 to 5.0.4 URGENT

    Hello I have following error when upgrading. Pleas help. Mailserver got to work urgent.
    Code:
    Upgrading from 5.0.2_GA_1975 to 5.0.4_GA_2101
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql
    Starting logger mysql
    Sun Mar 30 12:11:18 2008: SELECT value FROM config WHERE name = 'db.version'
    ERROR 1040 (08004): Too many connections
    This appears to be 5.0.2_GA
    Redolog Version: 1.22 New Redolog Version: 1.22
    Backup Version: 7.0 New Backup Version: 7.0
    Stopping mysql
    An upgrade of the logger schema is necessary from version 0
    Running /opt/zimbra/libexec/scripts/migrateLogger1-index.pl
    Sun Mar 30 12:11:39 2008: Adding Indices
    Sun Mar 30 12:11:39 2008: alter table mta add index i_arrive_time (arrive_time);
    alter table amavis add index i_arrive_time (arrive_time);
    alter table mta_aggregate add index i_period_start (period_start);
    alter table mta_aggregate add index i_period_end (period_end);
    alter table amavis_aggregate add index i_period_start (period_start);
    alter table amavis_aggregate add index i_period_end (period_end);
    CREATE TABLE config (
            name        VARCHAR(255) NOT NULL PRIMARY KEY,
            value       TEXT,
            description TEXT,
            modified    TIMESTAMP
    ) ENGINE = MyISAM;
    
    ERROR 1040 (08004): Too many connections
    Running /opt/zimbra/libexec/scripts/migrateLogger2-config.pl
    Sun Mar 30 12:11:41 2008: Adding Config
    Sun Mar 30 12:11:41 2008: DROP TABLE IF EXISTS config;
    CREATE TABLE config (
            name        VARCHAR(255) NOT NULL PRIMARY KEY,
            value       TEXT,
            description TEXT,
            modified    TIMESTAMP
    ) ENGINE = MyISAM;
    
    ERROR 1040 (08004): Too many connections
    Sun Mar 30 12:11:42 2008: DELETE from zimbra_logger.config WHERE name = 'db.version';
    INSERT into zimbra_logger.config (name,value) values ('db.version',2);
    
    ERROR 1040 (08004): Too many connections
    Running /opt/zimbra/libexec/scripts/migrateLogger3-diskindex.pl
    Sun Mar 30 12:11:44 2008: SELECT value FROM config WHERE name = 'db.version'
    ERROR 1040 (08004): Too many connections
    Sun Mar 30 12:11:44 2008: Schema version mismatch.  Expected version 2.  Version in the database is 0.
    
    Script failed with code 1 - exiting
    UPGRADE FAILED - exiting
    Help

    Greets John

  2. #2
    Join Date
    Dec 2007
    Location
    Belgium
    Posts
    85
    Rep Power
    8

    Unhappy

    How do I return to 5.0.2

    I know it is sunday but we are open and the email server doesn't work. Its about 4 hours now that I am trying to make it work. When just want to run zmcontrol start after the error of upgrading i get.
    Code:
    Host mail.robotronic.be
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...FAILED
    postmap: fatal: bad string length 0 < 1: mail_owner =
    postalias: fatal: bad string length 0 < 1: mail_owner =
    postfix failed to start
    
    
            Starting stats...Done.
    John

  3. #3
    Join Date
    Dec 2007
    Location
    Belgium
    Posts
    85
    Rep Power
    8

    Unhappy

    I tried to rerun the old zimbra 5.0.2 to upgrade. that doesn't work also
    Pleas help guys.
    This is in zimbra.log file
    Code:
    Mar 30 14:32:04 mail CRON[8615]: (pam_unix) session opened for user zimbra by (uid=0)
    Mar 30 14:32:13 mail zmmailboxdmgr[8808]: status requested
    Mar 30 14:32:13 mail zmmailboxdmgr[8808]: status OK
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: antispam: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: antivirus: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: ldap: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: logger: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: mailbox: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: mta: Stopped
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: saslauthd: is
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: snmp: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: spell: Running
    Mar 30 14:32:14 mail zimbramon[8618]: 8618:info: 2008-03-30 14:32:04, STATUS: mail.robotronic.be: stats: Running
    Mar 30 14:32:14 mail CRON[8615]: (pam_unix) session closed for user zimbra
    Mar 30 14:32:31 mail postfix/postqueue[8884]: fatal: bad string length 0 < 1: mail_owner =
    John

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    your upgrade failed for whatever reason, repairing it will be very difficult. restore from your backup.

  5. #5
    Join Date
    Dec 2007
    Location
    Belgium
    Posts
    85
    Rep Power
    8

    Default

    Hey thx for the response.

    Restore from my backup ?
    How do I do that?
    I can't get the mailserver running !! How can I restore the backup then?

    John

  6. #6
    Join Date
    Dec 2007
    Location
    Belgium
    Posts
    85
    Rep Power
    8

    Default

    Hey,

    I am al out of ideas here. I am not an Linux expert.
    We bought a 5 years license in january.
    But with a simpel upgrade, my mail system crashes???

    I can't believe that there is nobody that can help me ??

    John

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

Similar Threads

  1. Upgrade 5.0.2 to 5.0.4 OSS Failed
    By Grejao in forum Installation
    Replies: 15
    Last Post: 04-04-2008, 02:13 PM
  2. Replies: 1
    Last Post: 03-28-2008, 02:47 AM
  3. Replies: 4
    Last Post: 03-27-2008, 11:11 AM
  4. [SOLVED] Upgrade 5.0.2 to 5.0.4 OSS Failed
    By Chewie71 in forum Installation
    Replies: 3
    Last Post: 03-25-2008, 12:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •