Hello I have following error when upgrading. Pleas help. Mailserver got to work urgent.
Code:
Upgrading from 5.0.2_GA_1975 to 5.0.4_GA_2101
Stopping zimbra services
Verifying /opt/zimbra/conf/my.cnf
Starting mysql
Starting logger mysql
Sun Mar 30 12:11:18 2008: SELECT value FROM config WHERE name = 'db.version'
ERROR 1040 (08004): Too many connections
This appears to be 5.0.2_GA
Redolog Version: 1.22 New Redolog Version: 1.22
Backup Version: 7.0 New Backup Version: 7.0
Stopping mysql
An upgrade of the logger schema is necessary from version 0
Running /opt/zimbra/libexec/scripts/migrateLogger1-index.pl
Sun Mar 30 12:11:39 2008: Adding Indices
Sun Mar 30 12:11:39 2008: alter table mta add index i_arrive_time (arrive_time);
alter table amavis add index i_arrive_time (arrive_time);
alter table mta_aggregate add index i_period_start (period_start);
alter table mta_aggregate add index i_period_end (period_end);
alter table amavis_aggregate add index i_period_start (period_start);
alter table amavis_aggregate add index i_period_end (period_end);
CREATE TABLE config (
        name        VARCHAR(255) NOT NULL PRIMARY KEY,
        value       TEXT,
        description TEXT,
        modified    TIMESTAMP
) ENGINE = MyISAM;

ERROR 1040 (08004): Too many connections
Running /opt/zimbra/libexec/scripts/migrateLogger2-config.pl
Sun Mar 30 12:11:41 2008: Adding Config
Sun Mar 30 12:11:41 2008: DROP TABLE IF EXISTS config;
CREATE TABLE config (
        name        VARCHAR(255) NOT NULL PRIMARY KEY,
        value       TEXT,
        description TEXT,
        modified    TIMESTAMP
) ENGINE = MyISAM;

ERROR 1040 (08004): Too many connections
Sun Mar 30 12:11:42 2008: DELETE from zimbra_logger.config WHERE name = 'db.version';
INSERT into zimbra_logger.config (name,value) values ('db.version',2);

ERROR 1040 (08004): Too many connections
Running /opt/zimbra/libexec/scripts/migrateLogger3-diskindex.pl
Sun Mar 30 12:11:44 2008: SELECT value FROM config WHERE name = 'db.version'
ERROR 1040 (08004): Too many connections
Sun Mar 30 12:11:44 2008: Schema version mismatch.  Expected version 2.  Version in the database is 0.

Script failed with code 1 - exiting
UPGRADE FAILED - exiting
Help

Greets John