Results 1 to 5 of 5

Thread: [SOLVED] unistalling a broken installation

  1. #1
    Join Date
    May 2007
    Posts
    46
    Rep Power
    8

    Default [SOLVED] unistalling a broken installation

    Hi There,
    I am having a nightmare with the installation.
    (CENTOS 5.5)

    Ok i download and unpack the rpms, then i try to run the configure command, it tells me that it can find any packages. So i decide to install the packages one by one.
    however i get to the 3rd one (zimbra-core) and if gets to the end (trough the gui installer for centos). The progress bar is complete but the installer hangs and won't finish, it takes 20 mins.
    So i killed the process and got on with the rest thinking this was some issue with the installer GUI.
    Apparently not, zimbra wont start.
    So i decide to reinstall, first i try to remove the rpms but it says that the rpms have not been installed.
    I then delete the whole /opt/zimbra directory manually.
    Then i do the whole process again but it wont let me install rpms now because they are already installed?!!!!!!
    So i force the rpm to install using --force argument. This works however zimbra moans at me a bit when it installer runs, then it only gives me the chance to Update the current installation, which i do. It then gets halfway through and then dies moaning about something to do with "slapd" config.

    Is there any way i can just scrap everything and start from fresh getting rid of all rpm records and each and every file zimbra has ever put near the machine???????

  2. #2
    Join Date
    May 2007
    Posts
    46
    Rep Power
    8

    Default

    Incidentally i have successfully installed zimbra 3 times now without problems.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You can remove everything by running './install.sh -u' and it will wipe everything out. Don't try and install the rpms manually, use the installer and post any problems you may have here. I assume you've disabled SElinux & Firewall and got all the pre-requisite DNS A & MX records set-up plus the correct hosts file?

    BTW, I assume you mean CentOS 5.1 - I don't think they're up to 5.5 yet.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    May 2007
    Posts
    46
    Rep Power
    8

    Default

    Thanks bill i will ive it a try now
    All the best

  5. #5
    Join Date
    May 2007
    Posts
    46
    Rep Power
    8

    Default

    got it eventually, lot's of digging and late late night. Please can someone prioritize CentOS on the next build

Similar Threads

  1. Installation Issues - SLES 10_Zimbra 5.0 Beta 3
    By rhartman in forum Installation
    Replies: 3
    Last Post: 01-14-2008, 06:18 AM
  2. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-17-2006, 11:38 PM
  3. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 07:19 AM
  4. Replies: 16
    Last Post: 01-05-2006, 08:55 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •