Results 1 to 4 of 4

Thread: [SOLVED] issue receiving mail - problem with name resolution

  1. #1
    Join Date
    Mar 2008
    Rep Power

    Default [SOLVED] issue receiving mail - problem with name resolution

    I created a fresh setup of Zimbra 5.0.5 on a fresh installed Ubuntu 6.06 behind an ipcop firewall.

    When receiving e-mails, the e-mail is received and virus checked fine. The next step the logfile shows is postfix/lmtp ... deferred ... connection refused. The reason is that the name resolution is done for the external IP address of my MX record.

    Tests I did to check the configuration: is configured in /etc/hosts as well as on the internal DNS server pointing to my internal IP address
    My mail MX record points to host -x mx confirms
    ping talks to my internal IP address
    /etc/resolv.conf shows my internal DNS as the first DNS

    Nevertheless the mail delivery catches the external IP address for my mail server rather the internal one. Any hints?
    Last edited by mfehr; 04-24-2008 at 12:38 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    If you're behind a NAT router you need a Split DNS set-up and a correct /etc/hosts file. You need to post some information showing your DNS resolves OK & the hosts file is correct
    Last edited by phoenix; 04-24-2008 at 06:31 AM.


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    May 2007
    Rep Power


    When a mail client/server delivers to another mail server, it checks DNS for the MX record with the lowest serial number. Then it checks for the A record that resolves to the MX record.

    It is the delivering mail server which determines which IP to deliver to by the info it receives from it DNS querry. The receiving mail server can be made to listen on a specific IP but other than that it has nothing to do with which IP a sending server or client uses.

  4. #4
    Join Date
    Mar 2008
    Rep Power

    Default Solved

    Thanks. Installing and configuring bind9 on my zimbra host (ubuntu 6.06 server) solved the problem. Now zimbra got it's own dedicated DNS server.

Similar Threads

  1. Zimbra won't start: slapd loglevel wildness
    By blackpuma in forum Administrators
    Replies: 6
    Last Post: 03-23-2009, 09:07 PM
  2. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  3. SMTP SSL Problem
    By nexus in forum Installation
    Replies: 8
    Last Post: 03-15-2007, 08:26 AM
  4. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 03:31 AM
  5. Problem sending and Receiving mail
    By geroshea in forum Installation
    Replies: 3
    Last Post: 03-06-2006, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts