Results 1 to 3 of 3

Thread: centos 4.2 and ldap failure

  1. #1
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Default centos 4.2 and ldap failure

    Hi, a minimum centos 4.2 install with zimbra RPM for RHEL4 gives the following error:

    Adding centos.myvnc.com to zimbraMailHostPool in default COS...ERROR:
    service.FAILURE (system failure: getDirectContext) (cause:
    javax.naming.CommunicationException centos.myvnc.com:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause:
    javax.naming.CommunicationException centos.myvnc.com:389)
    Done

    But I tested ldap configuration and here is the result:

    [root@centos zcs]# su - zimbra
    [zimbra@centos ~]$ /opt/zimbra/libexec/zmldapinit
    slapd already running: pid 4377
    [zimbra@centos ~]$ ps auxww | grep slapd
    zimbra 4377 0.0 0.6 53628 4988 ? Ssl 13:25 0:00
    /opt/zimbra/openldap/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps://
    ldap://:389/ -f /opt/zimbra/conf/slapd.conf
    zimbra 30499 0.0 0.0 2268 504 tty1 S+ 21:15 0:00 grep
    slapd
    [zimbra@centos ~]$

    I have disabled IPv6, did the unicode stuff (a previous problem but already solved) and verified that the hostname is resolvable via DNS.

    Suggestions?

    Thanks in advance.

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    DOes the hostname resolve to a local interface? Can you telnet to that IP on 389?

  3. #3
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Default

    I guess my DUMB MODE was set to ON today.

    Since I'm running a virtual machine, i had to enable port forwarding on the vmware adapter.

    MARCMAC: Here are my instructions to setup a NOW WORKING Zimbra on Centos 4.x RHEL 4.x, should I repost the working instructions or will you do it?
    ***************************************
    Installation in Centos 4.x / RHEL 4.x

    I assume that you will do a "minimum install" to run the zimbra server, because you will not need anything else at this stage.

    IPv6 NOTE: for those who do not use ipv6, please disable it by doing the following, otherwise the ldap process might incorrectly bind to an ipv6 address while you're using ipv4.

    #insert in /etc/modprobe.conf
    #alias net-pf-10 off
    #alias ipv6 off

    #insert in /etc/sysconfig/network
    #NETWORKING_IPV6=no
    #NOZEROCONF=yes

    now please reboot and you will not have IPv6 scheme and the zeroconf.

    END IPV6 NOTE

    Note to VMWARE Users:
    If you're running a Winhost and a linux guest, make sure you go to
    EDIT/Virtual Network Settings/NAT/EDIT/PORT FORWARDING in the VMWARE program so you can allow the ports to travel internet<-->winhost<-->linux_guest
    Otherwise you may have installation errors like

    Adding centos.myvnc.com to zimbraMailHostPool in default COS...ERROR:
    service.FAILURE (system failure: getDirectContext) (cause:
    javax.naming.CommunicationException centos.myvnc.com:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause:
    javax.naming.CommunicationException centos.myvnc.com:389)
    Done

    This is due to the fact that the zimbra process use the resolved DNS address and if you don't enable the port forwards, then the zimbra processes cannot communicate. Zimbra processes go to the resolved address but using the virtual vmware adapter in the form of a loop.
    How to test?
    after a failed zimbra install, don't reboot and do:
    #su - zimbra
    #/opt/zimbra/libexec/zmldapinit
    you will get a message saying that slapd is already running.
    now telnet to 127.0.0.1 389, it will connect
    but when you telnet to the resolvable dns address at port 389 it wont connect due to the lack of the port forwarding setup in vmware.
    END Note to VMWARE users.

    UNICODE Errors in virtual settings:
    If you use unicode charsets you will get thousands of spawned java processes that will kill your server and it will make the installation last for at least 6 hours (yes, 6 hours)
    do this to avoid the error:
    #feel free to adjust to your personal settings, these are mine.
    #LANG="en_US"
    #xxxORIGINAL_SETTINGxxxxLANG="en_US.UTF-8"
    #SUPPORTED="en_US:en:es_MX:es:es_PA:es:es_ES:es"
    #xxxORIGINAL_SETTINGxxxxSUPPORTED="en_US.UTF-8:en_US:en:es_MX.UTF-8:es_MX:es:es_PA.UTF-8:es_PA:es:es_ES.UTF-8:es_ES:es"
    #SYSFONT="latarcyrheb-sun16"

    As you can see I removed the .UTF-x entries.

    After doing this, run the install.sh script for zimbra, It will install in less than 10 minutes if you have a nice machine and it will work inmediately.

    After installation, read the manual and start editing to your needs.

    *********************************

Similar Threads

  1. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  2. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 02:39 PM
  4. Centos Server 4.2 & LDAP
    By IVD01 in forum Installation
    Replies: 4
    Last Post: 03-08-2006, 06:51 AM
  5. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •