Results 1 to 5 of 5

Thread: [SOLVED] Bypassing Antispam/Antivirus for one user

  1. #1
    Join Date
    Mar 2008
    Posts
    4
    Rep Power
    7

    Default [SOLVED] Bypassing Antispam/Antivirus for one user

    Hello,

    I need to turn off antispam for a specific user (If possible just the antispam, but as I need to solve this matter with urgency, I'm accepting a temporary solution with some way to turn off both, as long it works per-user). There is some easy way to archieve it?

    Thanks in advance.

  2. #2
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    You might check out this wiki section which allows per-user whitelisting. I believe that the instructions on "spamlover accounts" would accomplish your goal.
    Cheers,

    Dan

  3. #3
    Join Date
    Mar 2008
    Posts
    4
    Rep Power
    7

    Default

    Thanks for the answer, but I think this won't help me much.

    Let me explain it better:

    My client send a newsletter (spam), and of course there are lots of bounces. All these bounces goes through amavis and because of that the server is under strong stress (Yesterday my queue had 24k messages). I need to completely disable the antispam for it. This solutions lowers the score, but the message is still processed by spamassassin, what takes a good load of cpu. On normal postfix+amavis setup i would use @bypass_spam_checks, but apparently its not working. I've checked the amavisd version that comes with zimbra and maybe something like bypass_spam_checks_maps? How can I configure it?

    Thanks!

  4. #4
    Join Date
    Mar 2008
    Posts
    4
    Rep Power
    7

    Default

    Ok! Found a solution:

    Actually i found this wiki page.

    Although the solution is IP-based I changed it to a user-based with some little tweaks:

    On postfix_recipient_restrictions:
    check_recipient_access pcre:/opt/zimbra/postfix/conf/no_filter

    On /opt/zimbra/postfix/conf/no_filter
    /^user\@domain\.com$/ FILTER smtp:[127.0.0.1]:10026

    On /opt/zimbra/conf/amavisd.conf.in
    $inet_socket_port = [10024, 10026]; # change from original setting
    $interface_policy{'10026'} = 'DOMAINWHITELIST';
    $policy_bank{'DOMAINWHITELIST'} = {
    bypass_spam_checks_maps => [1],
    final_spam_destiny => D_PASS,
    };

    Then restarted amavis and postfix.

    Now its works.

    Thanks!

  5. #5
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Quote Originally Posted by tenchimuyou View Post
    Ok! Found a solution
    Now its works.
    Great! I'll mark this thread solved.

    Meanwhile, remember that any changes you make to ANY of the config files will be wiped out every time you do an upgrade, so be prepared to back up and restore them whenever you do one. Since other (necessary) changes might also be made in later versions, it's probably wiser to plan to re-edit the new files on an upgraded version rather than to backup and restore the same old file.
    Cheers,

    Dan

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. DNS Questions and Trouble Installing
    By smurraysb in forum Installation
    Replies: 22
    Last Post: 03-14-2008, 03:27 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •