Results 1 to 9 of 9

Thread: [SOLVED] Howto Change Postfix HELO?

  1. #1
    Join Date
    May 2008
    Posts
    10
    Rep Power
    7

    Default [SOLVED] Howto Change Postfix HELO?

    I need to change my smtp HELO so that it matches my MX record. I tried changing it in my "main.cf" postifx file, but when I restarted the zimbra services it overwrote it to my servers hostname again. I did find this bug post, but I couldn't follow where to change zimbraMtaMyHostname. Any help would be appreciated!! Thanks!

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    Search is your friend http://www.zimbra.com/forums/adminis...-variable.html

  3. #3
    Join Date
    May 2008
    Posts
    10
    Rep Power
    7

    Default

    Thanks, uxbod, for the link but the commands listed in the link above didn't work for me. When I telnet to my server it still shows up as
    "220 zimbraserver.domain.local ESMTP Postfix"

  4. #4
    Join Date
    May 2008
    Posts
    10
    Rep Power
    7

    Default

    One other thing, and I could easily be getting this wrong (I haven't been operating MTAs for decades so...), but I don't think the banner is the same thing the MTA sends when acting as an SMTP client. When it (the local, sending MTA) is sending a message to a remote mail server, it receives the remote MTAs banner when it connects, and the local MTA then has to say HELO (or EHLO) and it's FQDN

    so

    EHLO mail.realdomainthatwouldhavebeenvalid[DOT]com

    which I don't think is the same thing as the banner.

    And I believe the FQDN that I provide is what the remote server checks to see if it really is a FQDN (fully qualified domain name) and that the FQDN exists (ie: is resolvable). .loc and .local TLD (top level domains) aren't likely to ever be globally resolvable.

  5. #5
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Hi Dan,

    You are not obligated to use the "$mydomain" variable in the banner string; you can replace it with something literal, like:

    Code:
    zmlocalconfig -e postfix_smtpd_banner="mail.mydomain.com NO UCE ESMTP"
    postconf -e smtpd_banner="mail.mydomain.com NO UCE ESMTP"
    zmmtactl reload
    And just to confirm, the Postfix variable smtpd_banner is indeed what Postfix uses to HELO other mail clients.

    Hope that helps,
    Mark

  6. #6
    Join Date
    May 2008
    Posts
    10
    Rep Power
    7

    Default

    I ran the commands posted above. It did indeed change my smtpd_banner.

    "telnet mail.REDACTED.net 25"

    220 mail.REDACTED.net ESMTP Postfix
    ehlo smtp1
    250-zimbraserver.REDACTED.local

    As you can see, changing the smtpd_banner did not change what the mail server says HELO/EHLO as.

    Here is what yahoo records show in their received header from the MTA after the proposed change was made and the daemons restarted

    Received: from zimbraserver.REDACTED.local (rrcs-XX-XXX-73-145.central.biz.rr.com [XX.XXX.73.145])
    by flpi119.prodigy.net (8.13.8 inb regex/8.13.8) with ESMTP id m451if19028913
    for ; Sun, 4 May 2008 18:44:46 -0700

    As you can see, it records the HELO (which is not what is in the banner) and the reverse DNS. Again, I'm pretty sure that when the MTA is acting as an SMTP client, the banner has nothing to do with the HELO/EHLO of the server. The header recorded by Yahoo seems to agree with that.

    From Chapter 3, Pg. 19 of "The Book Of Postfix" by Ralf Hildebrandt and Patrick Koetter
    (This is nested inside the "Setting the Hostname in the smtpd Banner" section)

    "CAUTION - When Postfix transports messages to other mail servers, it acts as a mail client. While introducing itself to the mail server, it uses the MYHOSTNAME paramater as the HELO name by default. Some mail servers are configured to reject mail if the HELO name and the reverse-resolvable FQDN of the server do not match. Either make sure that the hostname you set for Postfix matches the hostname of your server's IP, or set SMTP_helo_name to match your official FQDN in the DNS namespace."

  7. #7
    Join Date
    May 2008
    Posts
    2
    Rep Power
    7

    Default Here's what I did

    I had the same problem. My host was zimbra.corp.city.mydomain.com and I wanted the helo to say it was mail.mydomain.com

    I eventually found this :

    Bug 17794 - add global config values for postfix myhostname and myorigin to ldap

    Which lead me to eventually do this :

    zmprov mcf zimbraMtaMyHostname mail.mydomain.com
    zmcontrol stop && zmcontrol start

    And the helo used when talking to outside mailservers is now using mail.mydomain.com

  8. #8
    Join Date
    May 2008
    Posts
    10
    Rep Power
    7

    Default

    Thanks cyberdex! That was exactly what I was looking for, I really appreciate it!!

  9. #9
    Join Date
    Jun 2010
    Posts
    56
    Rep Power
    5

    Default

    Great!!

    using

    zmprov mcf zimbraMtaMyHostname mail.mydomain.com
    zmcontrol stop && zmcontrol start


    was the ONLY working way to set the Postfix HELO.
    Really annoying, that the documentation does not cover such simple topics (which could render a whole mailserver unusable if set to the wrong value).

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 04:02 PM
  2. Helo command - Need Change postfix settings
    By DEALER in forum Installation
    Replies: 11
    Last Post: 03-13-2008, 04:29 AM
  3. 5.0 RC1: admin interface: no statistics, no mail queue
    By christian.kieft in forum Administrators
    Replies: 1
    Last Post: 11-13-2007, 09:22 AM
  4. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  5. Howto change zimbra postfix main.cf
    By NIRMESH KUMAR in forum Administrators
    Replies: 2
    Last Post: 02-15-2007, 01:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •