Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: [SOLVED] Postfix: Unable to Bind: 49 invalid credentials.

  1. #11
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Now that has been done could you shutdown all the ZCS services, and also ensure any potential stale processes are also killed off. Especially slapd and Postfix. Then start ZCS back up again.

  2. #12
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    Rebooted completely. Same error.

  3. #13
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by ecologist09 View Post
    Rebooted completely. Same error.
    Use ldapsearch to validate you can bind as the user with the password you believe is the correct one. If not, you need to fix the password in the LDAP server. If it does work, then you need to fix zmlocalconfig's value for the password for the postfix user. If that matches the password value you have set as well, then you need to run "postfix stop" followed by "postfix start rewrite" so it'll update the postfix files used to bind to LDAP.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #14
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    I tried all of the suggestions posted in this thread but the following is what actually worked.

    We viewed the contents of /opt/zimbra/conf/ldap-vad.cf and found the password stored therein. Then we used an ldap browser/editor to set the password for zmamavisd and zmpostfix to the value that was in the file - NOT to what was in zmlocalconfig. Now it is connecting again and has returned me to my original problem which i will post in a separate thread so as not to hijack this one.

    So the question that remains is - why wasn't :

    Code:
    zmlocalconfig -e ldap_postfix_password=password
    or
    zmldappasswd -p password
    updating the passwords in the /opt/zimbra/conf/ldap* files?

  5. #15
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    Quote Originally Posted by quanah View Post
    Use ldapsearch to validate you can bind as the user with the password you believe is the correct one. If not, you need to fix the password in the LDAP server. If it does work, then you need to fix zmlocalconfig's value for the password for the postfix user. If that matches the password value you have set as well, then you need to run "postfix stop" followed by "postfix start rewrite" so it'll update the postfix files used to bind to LDAP.

    --Quanah
    Yes, ldapsearch was authenticating with my "new" password, the one that was set in zmlocalconfig. However, per my post (above) i had to reset the password to the one in /opt/zimbra/conf/lpda-vad.cf in order to get it working again.

  6. #16
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by ecologist09 View Post
    Yes, ldapsearch was authenticating with my "new" password, the one that was set in zmlocalconfig. However, per my post (above) i had to reset the password to the one in /opt/zimbra/conf/lpda-vad.cf in order to get it working again.
    Running postfix start rewrite is what would have updated the ldap-*.cf files to use the new password. In 5.0.6, any time you restart postfix, it will update those files, but that's not the current behavior.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #17
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    Quote Originally Posted by quanah View Post
    Running postfix start rewrite is what would have updated the ldap-*.cf files to use the new password. In 5.0.6, any time you restart postfix, it will update those files, but that's not the current behavior.

    We ran the rewrite option several times and it did not appear to have any effect.

  8. #18
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    My original problem, before this password mess was:

    http://www.zimbra.com/forums/install...html#post90869

  9. #19
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by ecologist09 View Post
    We ran the rewrite option several times and it did not appear to have any effect.
    Sorry, it is "postfix reload" in 5.0.5 and previous. With 5.0.6, postfix will always rewrite the configs when restarted.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  10. #20
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    Thanks. Will mark as solved.

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 04:02 PM
  2. LDAP error code 49 - invalid credentials
    By fieze in forum Installation
    Replies: 8
    Last Post: 05-09-2008, 06:12 AM
  3. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 12:03 PM
  4. Inconsistent Zimbra install behaviour
    By mkolbjor in forum Installation
    Replies: 2
    Last Post: 02-07-2008, 03:52 AM
  5. Replies: 3
    Last Post: 11-03-2007, 11:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •