Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: [SOLVED] All messages deferred - lost connection while sending RCPT TO

  1. #1
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default [SOLVED] All messages deferred - lost connection while sending RCPT TO

    I am getting this error for all messages.

    Code:
    May  8 10:37:15 zimbra postfix/qmgr[16756]: B3530D68264: from=, size=1481, nrcpt=1 (queue active)
    May  8 10:37:15 zimbra postfix/smtp[21870]: B3530D68264: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=85189, delays=85189/0.01/0.01/0.02, dsn=4.4.2, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
    They arrive fine but are not delivered. If i turn off BOTH antivirus and antispam then they get delivered.

    DNS does not appear to be the issues as everything was working previously. I have tried to track down this issue through the forums but with no luck.

    Any suggestions? Mail without spam and virus filtering would not be good for me.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    you may have a stale process somewhere. Re-enable AV/AS, and then shutdown down ZCS
    Code:
    ps -ef | grep -i amavis
    if there are any processes kill them off, and then restart ZCS.

  3. #3
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    But this happens even across reboots. I have rebooted many times and the problem persists.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Can you check /opt/zimbra/log/clamd.log for any error messages. Maybe you have a corrupt signature file that is killing it.

  5. #5
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    I see no error keywords nor do i see anything that would indicate a problem with clamd.

    Code:
    zimbra@zimbra:~/log$ cat clamd.log | grep -i error
    zimbra@zimbra:~/log$

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    what does
    Code:
    ps -ef | grep -i amavis
    show ?

  7. #7
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    Code:
    root@zimbra:/opt/zimbra/log# ps -ef | grep amavis
    zimbra   18685     1  0 11:36 ?        00:00:00 amavisd (master)
    zimbra   18687 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18688 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18689 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18690 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18691 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18693 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18694 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   18695 18685  0 11:36 ?        00:00:00 amavisd (virgin child)
    zimbra   19365 18685  0 11:37 ?        00:00:00 amavisd (virgin child)
    zimbra   22726 18685  0 11:43 ?        00:00:00 amavisd (virgin child)
    root     24153 17494  0 11:46 pts/0    00:00:00 grep amavis
    root@zimbra:/opt/zimbra/log#

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    hmm, something is wrong there as you should have something like
    Code:
    zimbra   32350     1  0 11:46 ?        00:00:00 amavisd (master)
    zimbra   32352 32350  0 11:46 ?        00:00:02 amavisd (ch8-avail)
    zimbra   32353 32350  0 11:46 ?        00:00:02 amavisd (ch10-avail)
    zimbra   32354 32350  0 11:46 ?        00:00:02 amavisd (ch12-avail)
    zimbra   32355 32350  0 11:46 ?        00:00:03 amavisd (ch13-avail)
    zimbra   32356 32350  0 11:46 ?        00:00:01 amavisd (ch6-avail)
    zimbra   32357 32350  0 11:46 ?        00:00:01 amavisd (ch6-avail)
    zimbra   32358 32350  0 11:46 ?        00:00:05 amavisd (ch19-avail)
    zimbra   32359 32350  0 11:46 ?        00:00:02 amavisd (ch12-avail)
    zimbra   32360 32350  0 11:46 ?        00:00:03 amavisd (ch17-avail)
    zimbra   32361 32350  0 11:46 ?        00:00:02 amavisd (ch10-avail)

  9. #9
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Okay, it could be a perms issue somewhere, so with ZCS down and as root run /opt/zimbra/libexec/zmfixperms

  10. #10
    Join Date
    May 2008
    Posts
    41
    Rep Power
    7

    Default

    Code:
    root@zimbra:/opt/zimbra/log# /opt/zimbra/libexec/zmfixperms
    root@zimbra:/opt/zimbra/log# su - zimbra
    zimbra@zimbra:~$ zmcontrol start
    Host zimbra.server
    	Starting ldap...Done.
    	Starting logger...Done.
    	Starting mailbox...Done.
    	Starting antispam...Done.
    	Starting antivirus...Done.
    	Starting snmp...Done.
    	Starting spell...Done.
    	Starting mta...Done.
    	Starting stats...Done.
    zimbra@zimbra:~$ ps -ef | grep amavisd
    zimbra    3836     1  4 12:05 ?        00:00:01 amavisd (master)
    zimbra    3846  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3850  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3851  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3852  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3853  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3854  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3855  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3856  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3857  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    3858  3836  0 12:05 ?        00:00:00 amavisd (virgin child)
    zimbra    4518  2324  0 12:06 pts/0    00:00:00 grep amavisd
    zimbra@zimbra:~$

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 08:34 AM
  2. All messages deferred - lost connection with 127.0.0.1 RCPT TO
    By bill@hurricanelabs.com in forum Installation
    Replies: 8
    Last Post: 04-29-2008, 07:54 AM
  3. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  4. Lots of deferred errors all of a sudden
    By CdtDelta in forum Administrators
    Replies: 0
    Last Post: 12-01-2007, 08:27 AM
  5. Replies: 3
    Last Post: 07-19-2007, 03:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •