Results 1 to 3 of 3

Thread: [SOLVED] Initializing ldap...failed. (28416) on Fedora 7

  1. #1
    Join Date
    Mar 2007
    Location
    London, UK
    Posts
    50
    Rep Power
    8

    Default [SOLVED] Initializing ldap...failed. (28416) on Fedora 7

    Hi all,

    I am setting up a separate box so I can perform some DR testing and during the install I got the error 'Initializing ldap...failed. (28416)'. I'm trying to install OSE 5.0.5

    I've seen someone else get this on RHEL5 but seemingly with no solution, I'm running Fedora 7 and didn't get this error on our live box when upgrading to this version.

    Here is an excerpt from the install log. I'm running this install from an ssh session but I also tried running it directly from the console once this error occured.

    Code:
    Tue May 13 16:32:01 2008 Setting up CA...
    Tue May 13 16:32:01 2008 *** Running as root user: /opt/zimbra/bin/zmcertmgr createca
    ** Creating directory /opt/zimbra/ssl/zimbra
    ** Creating directory /opt/zimbra/ssl/zimbra/ca
    ** Creating directory /opt/zimbra/ssl/zimbra/server
    ** Creating directory /opt/zimbra/ssl/zimbra/commercial
    ** Creating directory /opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp
    ** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf...done
    ** Retrieving CA private key from ldap...failed.
    ** Retrieving CA cert from ldap...failed.
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
    ** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
    Tue May 13 16:32:09 2008 done.
    Tue May 13 16:32:09 2008 Deploying CA to /opt/zimbra/conf/ca ...
    Tue May 13 16:32:09 2008 *** Running as root user: /opt/zimbra/bin/zmcertmgr deployca -localonly
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Copying CA to /opt/zimbra/conf/ca...done.
    Tue May 13 16:32:12 2008 done.
    Tue May 13 16:32:12 2008 Creating SSL certificate...
    Tue May 13 16:32:12 2008 *** Running as root user: /opt/zimbra/bin/zmcertmgr createcrt self
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20080513163214
    ** Retrieving server config key zimbraSSLCertificate...failed.
    ** Retrieving server config key zimbraSSLPrivateKey...failed.
    ** Generating a server csr for download
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20080513163219
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    Tue May 13 16:32:21 2008 done.
    Tue May 13 16:32:22 2008 Installing mailboxd SSL certificates...
    Tue May 13 16:32:22 2008 *** Running as root user: /opt/zimbra/bin/zmcertmgr deploycrt self
    ** Installing mta certificate and key...done.
    ** Installing slapd certificate and key...done.
    ** Installing proxy certificate and key...done.
    ** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
    ** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.
    ** Installing CA to /opt/zimbra/conf/ca...done.
    Tue May 13 16:32:25 2008 done.
    Tue May 13 16:32:25 2008 checking isEnabled zimbra-ldap
    Tue May 13 16:32:25 2008 zimbra-ldap is enabled
    Tue May 13 16:32:25 2008 Initializing ldap...
    Tue May 13 16:32:25 2008 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    sudo: sorry, you must have a tty to run sudo
    sudo: sorry, you must have a tty to run sudo
    sudo: sorry, you must have a tty to run sudo
    sudo: sorry, you must have a tty to run sudo
    sudo: sorry, you must have a tty to run sudo
    sudo: sorry, you must have a tty to run sudo
    sudo: sorry, you must have a tty to run sudo
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 160.
    Tue May 13 16:33:32 2008 failed. (28416)
    While typing this up I found the solution at Sudoers - Zimbra :: Wiki

    You need to comment out the line 'Defaults requiretty'

    This thread can be closed but I wanted to post it so anyone else with the same problem can find the solution more easily than I did

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    For others -

    Type:
    visudo
    Comment out requiretty so the line looks like:
    #Defaults requiretty

    You type visudo to edit /etc/sudoers rather than another text editor (vi, nano, nedit, gedit, etc). Visudo provides basic sanity checks, looks for parse errors, and locks the sudoers file against multiple simultaneous edits (say you we're in a multi-admin environment).

    If requiretty is set sudo will only run when the user is logged in to a real tty. Requiring it disallows things like 'rsh somehost sudo ls' since rsh does not allocate a tty, etc, etc. Here we're turning it off because it's saying "you must have a tty to run sudo".

  3. #3
    Join Date
    Oct 2007
    Posts
    19
    Rep Power
    7

    Default

    This totally solved it for me, w/similar issues I was having. Have now done 3 more installs, no problem, using that #requrietty fix.

    Works on Fedora 7 under Qemu, and just got one up on Fedora 8.
    ---------------

    Jettero Heller
    SysAdmin // SEO // Scientologist
    http://jetteroheller.wordpress.com/

Similar Threads

  1. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  2. Initializing ldap......failed. (28416)
    By Izmael in forum Installation
    Replies: 12
    Last Post: 05-06-2008, 04:25 PM
  3. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  4. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  5. Replies: 4
    Last Post: 11-15-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •