Results 1 to 6 of 6

Thread: GA build from CVS, cannot run

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    10

    Default GA build from CVS, cannot run

    I got GA from CVS, then built it on my RHEL4 box.
    Then I use this pkg to install on the same box. The installation is ok. But I cannot log in to zimbra mail (show Apache tomcat screen).
    Do "zmcontrol status" on zimbra user, I get:

    Code:
    Host localhost.localdomain
            antispam                Stopped
            antivirus               Stopped
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
    It seems Amavisd doesnot run (check with a ps)
    zmsetup.log, zmsetup.log attached

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    try starting amavis by hand (zmamavisdctl start) - any error messages?

    If you got the apache tomcat screen, it could be because you've got a default webapp installed. Is there an /opt/zimbra/tomcat/webapps/ROOT directory? If so, delete it and restart tomcat.

  3. #3
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    10

    Default

    run "zmamavisdctl start" show this error:

    Code:
    Problem in the antispam code: Can't locate Mail/SpamAssassin.pm in @INC (@INC contains: /opt/zimbra/zimbramon/lib /opt/zimbra/zimbramon/lib/i386-linux-thread-multi /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi /opt/zimbra/zimbramon/lib/i586-linux-thread-multi /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at (eval 41) line 15.
    BEGIN failed--compilation aborted at (eval 41) line 15.
    Maybe I must rebuilt the perlib.tgz ?
    the directory you said exists, but why we must remove it ?
    Thanks for your fast response.

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    You must remove it because it's the default webapp shipped with tomcat, which is what you're seeing. You posted that you didn't want to see the tomcat welcome page - if that's the case, you need to remove that webapp.

    If you didn't build the perllibs on your box, you'll need to do so.

  5. #5
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    10

    Default

    Thx. It's right. I didn't build perllib on my own box, I got it from your binary release.
    Is there another way to remove it without manually delete it. I mean configure tomcat before building zimbra.
    -----
    Ok, just remove the ROOT folder shipped with tomcat (in the jakarta-tomcat pkg)
    Last edited by vpoorboy; 02-21-2006 at 12:57 AM.

  6. #6
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Yes, you can delete it from the tomcat directory, the directory back up and use that in your builds...???

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 02:44 PM
  2. Updated cvs build instructions?
    By dijichi2 in forum Developers
    Replies: 2
    Last Post: 06-20-2006, 11:51 AM
  3. Latest CVS version build trouble
    By graffiti in forum Developers
    Replies: 9
    Last Post: 12-19-2005, 06:14 PM
  4. CVS Build Troubles
    By andreychek in forum Installation
    Replies: 40
    Last Post: 12-12-2005, 09:28 AM
  5. CentOS 4.2 Build
    By andreychek in forum Developers
    Replies: 2
    Last Post: 12-09-2005, 08:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •