Results 1 to 4 of 4

Thread: [SOLVED] ldap can't connect

  1. #1
    Join Date
    May 2008
    Rep Power

    Default [SOLVED] ldap can't connect

    Hi all,
    I just wanted to install zimbra 5.0.5 on my ubuntu 8.04 server and configure it to use ldap for system and samba log on.

    I followed the instructions to get zimbra ldap working together with samba and pam as described in:
    UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI - Zimbra :: Wiki

    So far everything seems to work. From Zimbra I can see and configure samba and posix options. When trying to log on as a new user it is not possible.

    From the command line of the server getent passwd and grout return all the defined users and groups. Also these defined in Zimbra.

    but ldapsearch -x returns
    ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

    Adding some additional debug info I found out, that this command is always using localhost.
    root@srvhqbat23:/etc# ldapsearch -x -d5
    ldap_new_connection 1 1 0
    ldap_connect_to_host: TCP localhost:389
    ldap_new_socket: 3
    ldap_prepare_socket: 3
    ldap_connect_to_host: Trying
    ldap_pvt_connect: fd: 3 tm: -1 async: 0
    ldap_close_socket: 3
    ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)
    In this case the problem is that it is using localhost:389 instead of

    ldapsearch -x -h

    returns all the requested information.

    In which file I can change ldap to search my my fqdn by default?
    /etc/ldap.conf doesn't seem to be the correct location and I didn't found any other ldap related file containing localhost or as uri.

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Welcome to the forums

    If you want to specify a different URI it can be set via global or local configuration files, or even via environment variables.
    man ldap.conf

  3. #3
    Join Date
    May 2008
    Rep Power


    In the meantime I was able to solve this problem.

    I only configured the server part of ldap, but forgot to configure the client part.

    I also had some other problems resulting in the fact, that it was not possible to logon the system and using samba.

    Finally everything works as it should.

  4. #4
    Join Date
    Mar 2007
    Small village in the center of Italy
    Rep Power


    Quote Originally Posted by thwint View Post
    but forgot to configure the client part.
    where have u configured client into zimbra's /opt/zimbra jail?

Similar Threads

  1. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 09:10 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  4. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  5. Can't send or receive mails from Zimbra
    By ppurama in forum Administrators
    Replies: 4
    Last Post: 11-14-2005, 09:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts