Results 1 to 8 of 8

Thread: Error upgrading

  1. #1
    Join Date
    Sep 2007
    Location
    UK
    Posts
    3
    Rep Power
    8

    Default Error upgrading

    Hi,

    I'm trying to upgrade our Zimbra installation from 4.5.7 GA to 5.0.6 GA (network edition) and am running into severe problems. I fortunately setup a test machine with the same OS version to restore a full backup and test the upgrade from there so we haven't lost any mail or functionality, but I need to get this to work so that we can actually upgrade our live install.

    I keep getting ldap errors like the following during the upgrade:

    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])

    what then happens is that no matter what entries I fill in at the end it keeps not completeing as it claims there are items not completed. The only way to get out from that dialog is to use the q to quit.

    The process I used is as follows:

    * Install 4.5.7
    * Restore full backup using the disaster recovery guide
    * ensure 4.5.7 works (it always does, all messages there, accepts incoming mail etc)
    * Start the 5.0.6 install
    * errors occur

    Interestingly an upgrade to 5.0.6 from a fresh install of 4.5.7 (no restore of backup) works fine. Is there a process to convert a 4.5.x backup into a 5.0.x backup by any chance?

    Any ideas?
    Last edited by philjohn; 05-27-2008 at 05:13 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    I did read a while ago that you should upgrade to 4.5.11 first and then to a 5.0.6 release. You could try that first. Also, what O/S do you have ZCS installed on ? You could also check LDAP - Zimbra :: Wiki to help with any LDAP problems.

    http://www.zimbra.com/forums/announc...r-profile.html please once you have upgraded successfully

  3. #3
    Join Date
    Sep 2007
    Location
    UK
    Posts
    3
    Rep Power
    8

    Default

    Thanks for the reply. I've just tried the upgrade to 4.5.11 and that went without a hitch, however when performing the 5.0.6 upgrade I'm still getting errors. It hasn't completed yet so I don't know if they can be ignore, but the same ldap error is popping up again:

    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])

  4. #4
    Join Date
    Sep 2007
    Location
    UK
    Posts
    3
    Rep Power
    8

    Default

    Nope, didn't work. I got to the last page where you configure everything and it just wouldn't continue, even though there were no items with *** by them.

    I'm thinking there's something in our ldap or local config that the upgrader is choking on so I'm going to try and create the users manually and then restore each mailbox one by one, then perform the upgrade. Either that or write a custom migrator using the API.

  5. #5
    Join Date
    Apr 2008
    Posts
    13
    Rep Power
    7

    Default

    Quote Originally Posted by philjohn View Post
    Nope, didn't work. I got to the last page where you configure everything and it just wouldn't continue, even though there were no items with *** by them.

    I'm thinking there's something in our ldap or local config that the upgrader is choking on so I'm going to try and create the users manually and then restore each mailbox one by one, then perform the upgrade. Either that or write a custom migrator using the API.
    I am running in to this same issue...any resolution?

    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    I got to the last page where you configure everything and it just wouldn't continue, even though there were no items with *** by them

  6. #6
    Join Date
    Sep 2008
    Posts
    2
    Rep Power
    7

    Default I m having the same Problem!

    someone could solve this problem!?

    i think it could be a kind of bug on this version.

    I tried to upgrade from ZCS 4.5.10 to ZCS 5.09 at Ubuntu 6.06.



    Please if someone have more information about this, tell us.

  7. #7
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    You can private message me with a copy of your zmsetup.log and /opt/zimbra/.install_history and I'll take a look at why it's failing.

    Based on the symptoms you are describing it sounds like some of the passwords in localconfig are being reset, either one or all of ldap_root_password, zimbra_ldap_password.

    In a couple cases I've seen the upgrade trying to update /opt/zimbra/conf/localconfig.xml via the zmlocalconfig cli resulting in a truncated localconfig, but I've never been able to reproduce in the lab.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    Join Date
    Sep 2008
    Posts
    2
    Rep Power
    7

    Default

    I could solve the problem using the commando ldappasswd for changing the ldap password. Now is working fine, thank you!

    Quote Originally Posted by brian View Post
    You can private message me with a copy of your zmsetup.log and /opt/zimbra/.install_history and I'll take a look at why it's failing.

    Based on the symptoms you are describing it sounds like some of the passwords in localconfig are being reset, either one or all of ldap_root_password, zimbra_ldap_password.

    In a couple cases I've seen the upgrade trying to update /opt/zimbra/conf/localconfig.xml via the zmlocalconfig cli resulting in a truncated localconfig, but I've never been able to reproduce in the lab.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •