Results 1 to 8 of 8

Thread: Install issues with FC4 and one error

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default Install issues with FC4 and one error

    This is my first install and I am new to Zimbra. I am installing this on FC4 for the second time. There is only one error message that I get (see below), but once the server is running I am not able to log in to provision accounts. Any help would be greatly appreciated.



    The error is a communication exception error below:

    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.3857
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...Done
    Saving CA in ldap...Done
    Installing SSL certificate...Done
    Creating server entry for mailhost.k2guru.com...Done
    Setting spell check URL...Done
    Setting service ports on mailhost.k2guru.com...Done
    Adding mailhost.k2guru.com to zimbraMailHostPool in default COS...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mailhost.k2guru.com:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mailhost.k2guru.com:389)

    Done
    Installing zimlets... com_zimbra_phone... com_zimbra_url... com_zimbra_wikipedia... com_zimbra_amzn... com_zimbra_xslt... com_zimbra_tracking... com_zimbra_ymaps... Done
    Setting MTA auth host...Done
    Creating domain mailhost.k2guru.com...Done
    Creating user _7ofmatog@mailhost.k2guru.com...Done
    Creating user on34jgz0x@mailhost.k2guru.com...Done
    Setting spam training accounts...Done
    Creating user admin@mailhost.k2guru.com...Done
    Creating postmaster alias...Done
    Initializing store sql database...Done
    Setting zimbraSmtpHostname for mailhost.k2guru.com...Done
    Initializing logger sql database...Done
    Initializing mta config...Done
    Configuring SNMP...Done
    Setting services on mailhost.k2guru.com...Done
    Setting up zimbra crontab...no crontab for zimbra
    Done

    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
    The VERSION of zcs installed (3.0.0_GA_156_FC4)
    The ADMIN EMAIL ADDRESS created (admin@mailhost.k2guru.com)

    Notify Zimbra of your installation? [Yes] y
    Notifying Zimbra of installation via http://www.zimbra.com/cgi-bin/notif...host.k2guru.com

    Notification complete
    This is my second install and I am new to Zimbra. I am installing this on FC4 for the second time. There is only one error message that I get (see below), but once the server is running I am not able to log in to provision accounts. Any help would be greatly appreciated.



    The error is a communication exception error below:

    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.3857
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...Done
    Saving CA in ldap...Done
    Installing SSL certificate...Done
    Creating server entry for mailhost.k2guru.com...Done
    Setting spell check URL...Done
    Setting service ports on mailhost.k2guru.com...Done
    Adding mailhost.k2guru.com to zimbraMailHostPool in default COS...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mailhost.k2guru.com:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mailhost.k2guru.com:389)

    Done
    Installing zimlets... com_zimbra_phone... com_zimbra_url... com_zimbra_wikipedia... com_zimbra_amzn... com_zimbra_xslt... com_zimbra_tracking... com_zimbra_ymaps... Done
    Setting MTA auth host...Done
    Creating domain mailhost.k2guru.com...Done
    Creating user _7ofmatog@mailhost.k2guru.com...Done
    Creating user on34jgz0x@mailhost.k2guru.com...Done
    Setting spam training accounts...Done
    Creating user admin@mailhost.k2guru.com...Done
    Creating postmaster alias...Done
    Initializing store sql database...Done
    Setting zimbraSmtpHostname for mailhost.k2guru.com...Done
    Initializing logger sql database...Done
    Initializing mta config...Done
    Configuring SNMP...Done
    Setting services on mailhost.k2guru.com...Done
    Setting up zimbra crontab...no crontab for zimbra
    Done

    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
    The VERSION of zcs installed (3.0.0_GA_156_FC4)
    The ADMIN EMAIL ADDRESS created (admin@mailhost.k2guru.com)

    Notify Zimbra of your installation? [Yes] y
    Notifying Zimbra of installation via http://www.zimbra.com/cgi-bin/notif...host.k2guru.com

    Notification complete

    Starting servers...Done.


    Operations logged to /tmp/zmsetup.log.3857


    Configuration complete - press return to exit

    Starting servers...Done.


    Operations logged to /tmp/zmsetup.log.3857


    Configuration complete - press return to exit
    Last edited by ketank; 03-02-2006 at 11:34 AM.

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    search on that error message and you'll find lots of entries.

  3. #3
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default Thanks let me try to see if one them works

    Quote Originally Posted by marcmac
    search on that error message and you'll find lots of entries.
    I shall keep you posted.

    Regards
    Ketan

  4. #4
    Join Date
    Jan 2006
    Location
    Finland
    Posts
    83
    Rep Power
    9

    Default Check your IP address and DNS settings

    /etc/hosts
    /etc/named.conf

    Are you using Internal Network IP Address while DNS/Hosts is from the External Network?


    Try these commands...
    telnet mailserver.domain.com 389
    telnet ipaddress 389

    Does ether one work?


    Sam

  5. #5
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default Let me try this.

    Sam,

    You guessed correct I have it on an internal network on 192.168.13.66 with a one to one NAT using a SonicWall firewall. I set up an internal DNS now but I am not sure I have set it up correctly. I shall try what you have suggested tonight and let you know

    Regards
    Ketan

  6. #6
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default Seems like there may be a DNS issue

    Sam,

    Tried the commands:

    telnet mailserver.domain.com 389

    >Returns the external IP and then times out

    telnet 192.168.13.66 389
    > Connects and seems to work (what do I do next?)

    When I try the FF browser and type https: 192.168.13.66:7071/zimbraAdmin

    > I get connection was refused when attempting to contact 192.168...

    Any help would be greatly aprreciated.

    Regards
    Ketan

  7. #7
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Either run split DNS, or forward 389 on your external IP to your ldap server.

  8. #8
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default fixed the issue!

    I changed /etc/hosts to be

    127.0.0.1 localhost.localdomain.localhost
    192.168.13.66 mailhost.domain.com (I changed this from a public ip number to the private one that the server is running on)

    I ran the zimbra install again (./install.sh)

    Worked like a charm! Thanks for all the help. Fantastic product!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •