Results 1 to 6 of 6

Thread: Insallation failed (Debian server)

Hybrid View

  1. #1
    Join Date
    Sep 2005
    Posts
    1
    Rep Power
    10

    Default Insallation failed (Debian server)

    Hello all,
    after reading about "zimbra", watching the demo and getting excited about it, I've downloaded the source in order to install it on my Debian server (running

    Sarge).
    I have to mention that on this server are allready Apache and Mysql installed and running.
    I carefully followed your installation orders for dev-install (found on http://www.zimbra.com/blog/archives/...ing_with.html), but alot of steps

    went on producing an error or just failed as you can see in the report.
    Again I have to mention some things.
    First - before installing I stoped Apache and Mysql services completly,
    second - in the step
    " $ /opt/zimbra/bin/zmmyinit
    $ /opt/zimbra/bin/zmldapinit
    $ /opt/zimbra/bin/zmmtainit localhost
    $ /opt/zimbra/bin/zmmtaconfig mta"
    3 of those are located in the wrong path - I located them in "/opt/zimbra/libexec...", on one installation I tried to ln -s them but they had wrong permissions, I tried

    to set the permissions right (enabling "x"), and I managed to get through that step, but still errors and failures kept reaccuring.

    Please check the document referd to and fix it, and please read my report and answare me, as well as publish your answare.
    I'ts a shame.... I realy wanted to use thar tool ("zimbra") for our domain clients, I was realy looking forward to see it working, I was thrilled about it - it looks great!
    Thank you and good luck!

    p.s.
    steps not mentioned on my reort went well.



    ----THE REPORT----

    # /opt/zimbra/postfix/sbin/postfix set-permissions
    postfix: warning: My hostname *************** is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf
    -----------------------------------

    $ /opt/zimbra/bin/zmmyinit
    -bash: /opt/zimbra/bin/zmmyinit: No such file or directory
    -----------------------------------

    $ /opt/zimbra/bin/mzldapinit
    -bash: /opt/zimbra/bin/mzldapinit: No such file or directory
    -----------------------------------

    $ /opt/zimbra/bin/zmmtainit localhost
    -bash: /opt/zimbra/bin/zmmtainit: No such file or directory
    -----------------------------------

    $ /opt/zimbra/bin/zmmtaconfig mta
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only=''
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups=''
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit=''
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks,

    reject_unauth_destination, permit'
    -----------------------------------

    $ /opt/zimbra/bin/zmldappasswd zimbra
    Updating local config
    Stopping ldap
    slapd not running
    Updating ldap configuration
    sed: can't read /opt/zimbra/conf/slapd.conf: No such file or directory
    Starting ldap
    Updating zimbra.ldif
    Running ldapmodify
    Password change complete.

    You may need to restart tomcat, if it is running.
    -----------------------------------

    $ /opt/zimbra/bin/zmmypasswd zimbra
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    **** PASSWORD CHANGE FAILED
    -----------------------------------

    $ /opt/zimbra/bin/zmmypasswd --root zimbra
    /opt/zimbra/bin/mysqladmin -u root --password=zimbra password zimbra
    /opt/zimbra/mysql/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/opt/zimbra/db/mysql.sock' exists!
    **** PASSWORD CHANGE FAILED
    -----------------------------------
    -----------------------------------
    -----------------------------------

    $ /opt/zimbra/bin/postfix stop

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    Password:[home user password entered beacouse the process of defining a password failed earlier]
    Sorry, user ***** is not allowed to execute '/opt/zimbra/postfix/sbin/postalias /etc/aliases' as root on ******.
    Sorry, user ***** is not allowed to execute '/opt/zimbra/postfix/sbin/postfix stop' as root on *****.
    -----------------------------------

    $ /opt/zimbra/bin/postfix start
    Sorry, user ***** is not allowed to execute '/opt/zimbra/postfix/sbin/postalias /etc/aliases' as root on ******
    Sorry, user ***** is not allowed to execute '/opt/zimbra/postfix/sbin/postfix start' as root on ******.
    -----------------------------------

    $ /opt/zimbra/bin/mysql.server stop
    Error: assertion '-r /opt/zimbra/conf/my.cnf' failed
    -----------------------------------

    $ /opt/zimbra/bin/mysql.server start
    Error: assertion '-r /opt/zimbra/conf/my.cnf' failed
    -----------------------------------

    ***@****:~/zcs-src/ZimbraServer$ ant reset-the-world
    Buildfile: build.xml

    build-init:

    compile:
    [echo] Hostname: *****

    generate-buildinfo:
    [javac] Compiling 1 source file to /home/*****/zcs-src/ZimbraServer/build/
    classes

    jar:
    [jar] Building jar: /home/*****/zcs-src/ZimbraServer/build/dist/lib/zimb
    rastore.jar

    stop-servers-windows:

    stop-servers-unix:
    [exec] slapd not running
    [exec] Result: 1
    [exec] Error: no pid in /opt/zimbra/log/tomcat.pid
    [exec] Result: 1

    stop-servers:

    db-init:

    BUILD FAILED
    /home/*****/zcs-src/ZimbraServer/build.xml:461: com.mysql.jdbc.CommunicationsE
    xception: Communications link failure due to underlying exception:

    ** BEGIN NESTED EXCEPTION **

    java.net.SocketException
    MESSAGE: java.net.ConnectException: Connection refused

    STACKTRACE:

    java.net.SocketException: java.net.ConnectException: Connection refused
    at com.mysql.jdbc.StandardSocketFactory.connect(Stand ardSocketFactory.ja
    va:156)
    at com.mysql.jdbc.MysqlIO.(MysqlIO.java:283)
    at com.mysql.jdbc.Connection.createNewIO(Connection.j ava:2541)
    at com.mysql.jdbc.Connection.(Connection.java:1474)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonReg isteringDriver.java
    :264)
    at org.apache.tools.ant.taskdefs.JDBCTask.getConnecti on(JDBCTask.java:30
    4)
    at org.apache.tools.ant.taskdefs.SQLExec.execute(SQLE xec.java:347)
    at org.apache.tools.ant.UnknownElement.execute(Unknow nElement.java:275)
    at org.apache.tools.ant.Task.perform(Task.java:364)
    at org.apache.tools.ant.Target.execute(Target.java:34 1)
    at org.apache.tools.ant.Target.performTasks(Target.ja va:369)
    at org.apache.tools.ant.Project.executeTarget(Project .java:1214)
    at org.apache.tools.ant.Project.executeTargets(Projec t.java:1062)
    at org.apache.tools.ant.Main.runBuild(Main.java:673)
    at org.apache.tools.ant.Main.startAnt(Main.java:188)
    at org.apache.tools.ant.launch.Launcher.run(Launcher. java:196)
    at org.apache.tools.ant.launch.Launcher.main(Launcher .java:55)


    ** END NESTED EXCEPTION **



    Last packet sent to the server was 30 ms ago.

    Total time: 7 seconds
    -----------------------------------

    *****@****:~/zcs-src/ZimbraWebClient$ ant deploy
    Buildfile: build.xml

    check4zimbraajax:

    copy-files-to-build-area:
    [copy] Copying 1 file to /home/*****/zcs-src/ZimbraWebClient/build/WebRoot/WEB-INF
    [copy] Copying 1 file to /home/*****/zcs-src/ZimbraWebClient/build/WebRoot/js
    [copy] Copying 17 files to /home/*****/zcs-src/ZimbraWebClient/build/WebRoot/public
    [copy] Copying 1 file to /home/*****/zcs-src/ZimbraWebClient/build/WebRoot/zimlets
    [copy] Copying 439 files to /home/*****/zcs-src/ZimbraWebClient/build/WebRoot
    [copy] Copying 271 files to /home/*****/zcs-src/ZimbraWebClient/build/WebRoot/js/ajax

    build-init:

    compile:

    jam-files:

    generate-build-info:
    [propertyfile] Updating property file: /home/*****/zcs-src/ZimbraWebClient/build/build.properties

    imagesinit:

    images:

    war:
    [war] Building war: /home/*****/zcs-src/ZimbraWebClient/build/dist/tomcat/webapps/zimbra.war

    deploy:

    BUILD FAILED
    /home/******/zcs-src/ZimbraWebClient/build.xml:496: The type doesn't support the "update" attribute.

    Total time: 10 seconds
    -----------------------------------

    No conection to the server could be established...

    ----END OF REPORT ---

    ln files from licexec:

    $ /opt/zimbra/bin/zmldapinit
    db_recover: Finding last valid log LSN: file: 1 offset 28
    Started slapd: pid
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)

    $ /opt/zimbra/bin/zmmtaconfig mta
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only=''
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups=''
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit=''
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, permit'
    Last edited by popui007; 09-29-2005 at 05:57 AM.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Thanks for the detailed report. Not sure if you've been following the other threads but we only support/build on Red Hat and Fedora. So we know it won't build on Debian at this time. As we get closer to having a portable build we'll ask you to try again with the new bits.

  3. #3
    Join Date
    Sep 2005
    Posts
    2
    Rep Power
    10

    Default adventures with zimbra & debian

    # /opt/zimbra/postfix/sbin/postfix set-permissions
    postfix: warning: My hostname *************** is not a fully qualified name - set myhostname or mydomain in /opt/zimbra/postfix-2.2.3/conf/main.cf
    -----------------------------------


    Fixable by editing the /opt/zimbra/postfix-2.2.3/conf/main.cf file by adding a myhostname line.

    Once you fix this there are several missing library files. I linked them from the /usr/lib dir to the /lib dir:

    ln -s /usr/lib/libssl.so.0.9.7 /lib/libssl.so.4
    ln -s /usr/lib/libpcre.so.3 /lib/libpcre.so.0
    ln -s /usr/lib/libcrypto.so.0.9.7 /lib/libcrypto.so.4

    After which it appears to run ok...


    $ /opt/zimbra/bin/zmmyinit
    -bash: /opt/zimbra/bin/zmmyinit: No such file or directory
    -----------------------------------

    $ /opt/zimbra/bin/mzldapinit
    -bash: /opt/zimbra/bin/mzldapinit: No such file or directory
    -----------------------------------

    $ /opt/zimbra/bin/zmmtainit localhost
    -bash: /opt/zimbra/bin/zmmtainit: No such file or directory
    -----------------------------------


    Run these from the /opt/zimbra/libexec dir. They apparently expect to be in this dir (they call the bin dir through a relative path ../bin).

    Which is contrary to the devel guide http://www.zimbra.com/blog/archives/...ping_with.html.

    Anyways... onto zmmyinit.

    I already have a mysql database running and I don't want to take it down. So I changed the port it configures zmmysql to run on:

    zmlocalconfig -e mysql_port=9110

    Use the command above and don't try to edit the conf/my.cnf since it just gets removed/recreated by the zmmyinit script anyways.

    After this and checking the log/zmmyinit.log file I discovered a problem with my premission settings on the db/data/mysql dir: Had to add rwx for the group. This may have something to do with the rather meandering way that I went about setting it up in the first place but if your server doesn't start I'd look at that dir's permissions.

    Onward to zmldapinit...

    So... I haven't got this working yet. The script fails saying that it couldn't get connected to the ldap service. Checking the debugging output from slapd using the -d 5001 option I see these two errors:

    /opt/zimbra/openldap/etc/openldap/schema/zimbra.schema: line 1229: bad config line (ignored)

    bdb(): /opt/zimbra/openldap-data/__db.001: No such file or directory

    Which I'll be checking on after I eat some food!!

  4. #4
    Join Date
    Sep 2005
    Posts
    2
    Rep Power
    10

    Default

    Looks like the bad config line was caused by a blank line in the file... removed it.

    The second error appears to be from an improper config value somewhere. I set the value in conf/slapd.conf to the right directory.

    After finding the command that is actually being sent to start slapd (A pity that their initialization script doesn't produce a log file like the last one):

    /opt/zimbra/openldap/libexec/slapd -4 -u`whoami` -h "ldap://:389" -f /opt/zimbra/conf/slapd.conf

    I changed it to (so I could get some error messages):

    sudo /opt/zimbra/openldap/libexec/slapd -4 -h "ldap://:389" -f /opt/zimbra/conf/slapd.conf -d 5001

    Which gets me the output:

    @(#) $OpenLDAP: slapd 2.2.26 (Aug 17 2005 00:15:16) $
    marcmac@depot.liquidsys.com:/space/home/marcmac/p4/main/ThirdParty/openldap/openldap-2.2.26/servers/slapd
    daemon_init: listen on ldap://:389
    daemon_init: 1 listeners to open...
    ldap_url_parse_ext(ldap://:389)
    daemon: initialized ldap://:389
    daemon_init: 1 listeners opened
    slapd init: initiated server.
    slap_sasl_init: initialized!
    bdb_back_initialize: initialize BDB backend
    bdb_back_initialize: Sleepycat Software: Berkeley DB 4.2.52: (December 3, 2003)
    >>> dnNormalize:
    => ldap_bv2dn(cn=Subschema,0)
    ldap_err2string
    <= ldap_bv2dn(cn=Subschema)=0 Success
    => ldap_dn2bv(272)
    ldap_err2string

    ....

    slapd startup: initiated.
    backend_startup: starting ""
    bdb_db_open: dbenv_open(/opt/zimbra/openldap/var/openldap-data)
    bdb(): unable to initialize mutex: Function not implemented
    bdb(): /opt/zimbra/openldap/var/openldap-data/__db.001: unable to initialize environment lock: Function not implemented
    bdb_db_open: dbenv_open failed: Function not implemented (38)
    backend_startup: bi_db_open failed! (38)
    slapd shutdown: initiated
    ====> bdb_cache_release_all
    bdb(): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
    slapd shutdown: freeing system resources.
    bdb(): txn_checkpoint interface requires an environment configured for the transaction subsystem
    bdb_db_destroy: txn_checkpoint failed: Invalid argument (22)
    slapd stopped.
    connections_destroy: nothing to destroy.

    At which point I notice I'm getting this statement "ldap_err2string" and I suspect an error, but it doesn't really say more than that. Also more at the end of the output there are clearly some functions missing "bdb(): unable to initialize mutex: Function not implemented"...

    Unfortunately that is all I know for now

  5. #5
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default backend bdb

    Well, i'm kindof following with you guys. I'm sortof lost with the mysql store, but --

    to fix the bdb issue:

    I had to copy my sarge distro slapd binary (i was getting an error--ld: warning: cannot find entry symbol _start; defaulting to 000000000804c55c)

    meanwhile, in the config file for slapd (at /opt/zimbra/openldap/etc/openldap/slapd.conf):

    where it says Modulepath /usr/local/libexec whatever-
    change it to:
    modulepath /usr/lib/ldap
    moduleload back_bdb
    (note, i removed the .la that was originally there).

    This is of course assuming you already have the debian openldap prereq's, which will put back_bdb.so in /usr/lib/ldap.

    immediately after moduleload back_bdb, add the lines:

    backend bdb
    checkpoint 512 30

    and slapd should start AOK.

  6. #6
    Join Date
    Sep 2005
    Posts
    135
    Rep Power
    10

    Default slapd

    btw, my slapd.conf was in /opt/zimbra/openldap/etc/openldap/
    .. i guess i'll symlink to /zimbra/conf

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  5. Replies: 18
    Last Post: 03-20-2006, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •