Page 1 of 5 123 ... LastLast
Results 1 to 10 of 53

Thread: Fresh Install Of Zimbra On SuSE 10

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default Fresh Install Of Zimbra On SuSE 10

    Hello Once Again.

    OK to prevent any confusion I have started a fresh thread.

    Problem: I can send mail out but I can not receive any mail. No spam tools are enabled and no firewall is enabled. Except my Hardware firewall which works fine with my other mail server enabled.

    1. I have installed a fresh copy of SuSE 10
    2. I have installed the required packages.
    3. I have checked the host file.
    4. I have setup DNS and made I can host hostname.
    5. I have disabled the version of postfix which SuSE installed.
    6. I have done a DNS A record check and MX check using http://www.dnsstuff.com
    7. I Re-booted the server and made sure that all changes were applied.
    8. I ran ./install.sh as root user.
    9. See attachments for what happed next.

    As you will see if you browse to http://www.freeos.co.uk the server is online and broadcasting.

    I have also checked everything that was asked in my previous post and supplied you with the error logs, screen shots, and much more.

    Please have a look and see if you can advise me as to what I should do next.

    Thank you for your help in advance.

    Regards

    Yogiman!
    Attached Files Attached Files

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The first thing that seems wrong to me is the /etc/host file, does it need more info in it for SuSE? In your Zimbra log it shows that postfix isn't able to resolve the hostname. I only use SuSE as a workstation not my zimbra server but when you do 'hostname' does it return a FQDN of the server? On my system it doesn't - you may need to edit main.cf to give it a FQDN.

    [edit]

    Ah, it helps if I to read to the end of the hosts file. I see your FQDN there but the question of the 'hostname' command still remains.
    Last edited by phoenix; 02-23-2006 at 04:34 AM. Reason: can't read!
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    When I do:

    hostname

    the return is:

    mail

    which is the name of my mail server.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    .... but my point was, isn't it supposed to return the FQDN of your server. That's what happens on my CentOS server, isn't that what Zimbra is complaining about in the log you posted?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    Pheonix

    I can only assume you are right, however where is the setting missing is the question because I can not find out where this could be!

    Thanks.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I can't find it either, my SuSE 10 installation is set-up correctly and has all the relevant files and entries (/etc/hosts etc) and it still doesn't return a FQDN. For all practical purposes it set-up exactly the same as my CentOS Zimbra server but does not return the same FQDN as the CentOS machine - I'm completely flumoxed by that.

    However, I believe you can set the FQDN that Zimbra should use in the zimbra postfix main.cf - have a look in the forums as I believe it's been mentioned before.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Try changing the /etc/HOSTNAME file and rebooting.

  8. #8
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    Try changing the /etc/HOSTNAME file and rebooting.
    Try changing it to what!

    my domain name is: freeos.co.uk
    the mail server is: mail

    my host files says: 192.168.2.101 mail mail.freeos.co.uk

    To the best of my knowledge that is correct; so why would I change that and what would you suggest I put there!


  9. #9
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    Sorry

    That will teach me to read things slower.

    hostname file

    not hosts file

    Appologies all round. I am sure you will for give the stupid guy!


  10. #10
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    my host files says: 192.168.2.101 mail mail.freeos.co.uk

    To the best of my knowledge that is correct; so why would I change that and what would you suggest I put there!
    That is NOT correct.

    Correct is:
    192.168.2.101 mail.freeos.co.uk mail

    Which is not really the point - a careful reading of my last post will show that I told you, if you want to change the hostname, edit the /etc/HOSTNAME file. But fixing /etc/hosts will actualy fix your problem.

Similar Threads

  1. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 07:29 PM
  2. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 01:11 PM
  3. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 12:59 PM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  5. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •