Results 1 to 8 of 8

Thread: ZCS in RHCS

  1. #1
    Join Date
    Mar 2008
    Posts
    10
    Rep Power
    7

    Default ZCS in RHCS

    Hi All,

    I have installed ZCS cluster in xen environment.
    Have installed it in both mail1 and mail2 server to run on RHCS.

    We are not able to start the cluster service and the owner should be mail1.
    But it is left blank.

    Any idea how should we start to troubleshoot?

    We are totally new to clustering.
    ================================================
    [root@mail1 ~]# clustat
    Member Status: Quorate

    Member Name ID Status
    ------ ---- ---- ------
    mail1.ipmirror.com 1 Online, Local, rgmanager
    mail2.ipmirror.com 2 Online, rgmanager

    Service Name Owner (Last) State
    ------- ---- ----- ------ -----
    service:cluster.ipmi (none) stopped
    ================================================
    [root@mail2 ~]# clustat
    Member Status: Quorate

    Member Name ID Status
    ------ ---- ---- ------
    mail1.ipmirror.com 1 Online, rgmanager
    mail2.ipmirror.com 2 Online, Local, rgmanager

    Service Name Owner (Last) State
    ------- ---- ----- ------ -----
    service:cluster.ipmi (none) stopped

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    What version of ZCS and Redhat ?

  3. #3
    Join Date
    Mar 2008
    Posts
    10
    Rep Power
    7

    Default

    Hi,

    We are using ZCS 5.0.4 in RHEL 5(64bits).

    Kindly assist.
    Thanks

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by IPMHanwei View Post
    We are using ZCS 5.0.4 in RHEL 5(64bits).
    RHCS5 isn't currently supported, only RHCS4 is at the moment. Post the output of the following command:

    Code:
    zmcontrol -v
    also update your profile with that information.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2008
    Posts
    10
    Rep Power
    7

    Default

    HI,

    [zimbra@mail1 root]$ zmcontrol -v


    Release 5.0.4_GA_2101.RHEL5_64_20080321141727 RHEL5_64 NETWORK edition

    We are setting up the clustering use a GUI name LUCI.

    Thanks

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    This is not yet a supported platform for Network Edition. You must install it on a RHCS4 or wait for the resolution to this bug: Bug 18197 - RHEL5 support for cluster/RHCS otherwise you will not receive support for this configuration.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    If you are determined to use Xen rather than bare hardware or VMWare, then you might be better off with the unsupported workarounds than RHEL4.

    Also consider whether you really need clustering. After some messing around with RHEL4 clustering, I decided that pager and manual failover works for me. All of our (few) outages have been due to user error or software bugs, mostly due to attachment indexing. In every instance that comes to mind, had clustering software determined that the service was unresponsive and failed over to the other node, it likely would have made the problem worse.

  8. #8
    Join Date
    Mar 2008
    Posts
    10
    Rep Power
    7

    Default

    Hi,

    For the time being, i would prefer to go for the manual failover.
    We need to store our data in a SAN storage.

    Which are the path that we need to mount to the SAN storage?
    /opt/zimbra
    /opt/zimbra-cluster/mountpoints/cluster.ipmirror.com

    How do we softlink a existing directory to the san storage?

    Thanks

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. Ldap_operations_error
    By tcnj in forum Administrators
    Replies: 4
    Last Post: 05-09-2009, 07:53 AM
  3. ZCS 5.0 FOSS is Released!!!
    By jholder in forum Announcements
    Replies: 1
    Last Post: 12-21-2007, 12:21 PM
  4. Replies: 41
    Last Post: 10-29-2007, 03:36 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •