Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Unable to send mail

  1. #1
    Join Date
    Jun 2008
    Location
    Wolverhampton, UK.
    Posts
    34
    Rep Power
    7

    Default [SOLVED] Unable to send mail

    After a fresh install on Ubuntu I have come to a small issue where users are unable to send any email. the log reflects this with:

    NOQUEUE: reject: RCPT from boredom.geek-web.co.uk[87.194.16.78]: 554 5.7.1 : Relay access denied; from= to= proto=ESMTP helo=
    Jun 10 13:50:24 boredom postfix/smtpd[11646]: disconnect from boredom.geek-web.co.uk[87.194.16.78]

    The error the users are getting:

    Message not sent; one or more addresses were nor accepted.
    Rejected addresses: user@domain.com

    Any suggestions please??

    I've took a guess and added the external IP of the server to the trusted servers in the MTA but that seems to have resolved it but im not sure that it is very safe to do this.
    Last edited by simonb256; 06-10-2008 at 06:22 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Code:
    boredom.geek-web.co.uk[87.194.16.78]
    is that your server or the one attempting to send emails to you ?

  3. #3
    Join Date
    Jun 2008
    Location
    Wolverhampton, UK.
    Posts
    34
    Rep Power
    7

    Default

    Quote Originally Posted by uxbod View Post
    Welcome to the forums

    Code:
    boredom.geek-web.co.uk[87.194.16.78]
    is that your server or the one attempting to send emails to you ?
    It's my server, which is the server im trying to send from. No matter who I sent to i still got the same error.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Did you follow ZimbraMtaMyNetworks - Zimbra :: Wiki and then restart the MTA ?

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by simonb256 View Post
    I've took a guess and added the external IP of the server to the trusted servers in the MTA but that seems to have resolved it but im not sure that it is very safe to do this.
    I would guess from that comment that you are behind a NAT Router, would that be correct? If so, you'll need a Split DNS set-up. As you suspect, it's not wise to have your external IP in the mynetwork setting unless you actually are on a public and not behind NAT.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Just to validate your setting if you were to post the following we can take a look
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig geek-web.co.uk any
    dig geek-web.co.uk mx
    host `hostname` <- note backticks and not double quotes

  7. #7
    Join Date
    Jun 2008
    Location
    Wolverhampton, UK.
    Posts
    34
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    I would guess from that comment that you are behind a NAT Router, would that be correct? If so, you'll need a Split DNS set-up. As you suspect, it's not wise to have your external IP in the mynetwork setting unless you actually are on a public and not behind NAT.
    Nope im not NATed, i was up until I installed the software, but after having NAT issues I just gave up and gave it the public IP.

  8. #8
    Join Date
    Jun 2008
    Location
    Wolverhampton, UK.
    Posts
    34
    Rep Power
    7

    Default

    Quote Originally Posted by uxbod View Post
    Just to validate your setting if you were to post the following we can take a look
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig geek-web.co.uk any
    dig geek-web.co.uk mx
    host `hostname` <- note backticks and not double quotes
    Below is the result of all the requested commands.
    Thank you for you help.
    Code:
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2008.06.10 15:57:08 =~=~=~=~=~=~=~=~=~=~=~=
    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    127.0.1.1 boredom.geek-web.co.uk
    87.194.16.78 boredom.geek-web.co.uk boredom
    
    
    root@boredom: ~root@boredom:~# cat /etc/resolv.conf 
    ### BEGIN INFO
    #
    # Modified_by:  NetworkManager
    # Process:      /usr/bin/NetworkManager
    # Process_id:   5027
    #
    ### END INFO
    
    search config geek-web.co.uk
    
    
    
    
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    domain geek-web.co.uk
    
    
    root@boredom: ~root@boredom:~# dig geek-web.co.uk any
    
    ; <<>> DiG 9.4.2 <<>> geek-web.co.uk any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31467
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;geek-web.co.uk.			IN	ANY
    
    ;; ANSWER SECTION:
    geek-web.co.uk.		84921	IN	NS	ns0.lcn.biz.
    geek-web.co.uk.		84921	IN	NS	ns1.lcn.biz.
    
    ;; Query time: 17 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Tue Jun 10 15:55:40 2008
    ;; MSG SIZE  rcvd: 75
    
    
    
    root@boredom: ~root@boredom:~# dig geek-web.co.uk mx
    
    ; <<>> DiG 9.4.2 <<>> geek-web.co.uk mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9653
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;geek-web.co.uk.			IN	MX
    
    ;; ANSWER SECTION:
    geek-web.co.uk.		86400	IN	MX	10 boredom.geek-web.co.uk.
    geek-web.co.uk.		86400	IN	MX	20 mailforward.lcn.com.
    geek-web.co.uk.		86400	IN	MX	30 backupmx.lcn.com.
    
    ;; Query time: 52 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Tue Jun 10 15:55:48 2008
    ;; MSG SIZE  rcvd: 116
    
    
    
    root@boredom: ~root@boredom:~# host `hostname`
    boredom.geek-web.co.uk has address 87.194.16.78
    Also it is worth mentioning that I am not NAT'ed, the server has its own public address, as shown above.

  9. #9
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    That looks okay as I have checked remotely aswell. You need to check your Postfix MTA settings as in my prior post (wiki) and ensure that its has been restarted.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I'd suggest you also remove this from the hosts file:

    Code:
    127.0.1.1 boredom.geek-web.co.uk
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  4. Issues...
    By timothyalangorman in forum Administrators
    Replies: 3
    Last Post: 11-19-2007, 09:43 AM
  5. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •