Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] high cpu load java

  1. #1
    Join Date
    May 2008
    Posts
    4
    Rep Power
    7

    Default [SOLVED] high cpu load java

    I have a problem with some perseverative (about every 60sec) java process which produce temporary high cpu load. (zcs-5.0.5_GA_2201.UBUNTU8.FRANKLIN on ubuntu hardy 8.04 Celeron(R) CPU 2.00GHz/1,5GB RAM)

    Code:
    97.5% /opt/zimbra/java/bin/java -XX:ErrorFile=/opt/zimbra/log -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars:/opt/zimbra/lib/ext:/opt/zimbra/lib/ext/clamscanner com.zimbra.cs.account.ProvUtil -l garpu
    has someone any ideas?

    first i tried to upgrade to zcs-5.0.6_GA_2314.UBUNTU8.FRANKLIN to see if its better, but it has not worked and i made a rollback.
    i also had problems with my symbolic link which is not supported -> Bug 14725 - Installer fails to follow and destroyes symbolic links

  2. #2
    Join Date
    May 2008
    Posts
    4
    Rep Power
    7

    Default

    i found out that /var/opt/zimbra/bin/zmprov produces high CPU Load
    cat /var/opt/zimbra/bin/zmprov
    Code:
    exec `dirname $0`/zmjava com.zimbra.cs.account.ProvUtil "$@"
    Code:
    zimbra   10464  0.0  0.0   1772   492 ?        Ss   14:20   0:00      \_ /bin/sh -c /opt/zimbra/libexec/zmlogprocess > /tmp/logprocess.out 2>&1
    zimbra   10465  5.3  0.3   8148  5036 ?        S    14:20   0:00          \_ /usr/bin/perl /opt/zimbra/libexec/zmlogprocess
    zimbra   10552  0.0  0.0   1780   496 ?        S    14:20   0:00              \_ sh -c /opt/zimbra/bin/zmprov -l gacf | egrep '^zimbraLogRawLifetime' | sed -e 's/zimbraLogRawLifetime: //'
    zimbra   10553 81.3  1.7 428760 24532 ?        Sl   14:20   0:02                  \_ /opt/zimbra/java/bin/java -XX:ErrorFile=/opt/zimbra/log -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars:/opt/zimbra/lib/ext:/opt/zimbra/lib/ext/clamscanner com.zimbra.cs.account.ProvUtil -l gacf
    so i prevent that zmprov is used in certain periodic script, and modifies some variables with hardcoded standard values eg. in /opt/zimbra/libexec/zmlogprocess

    Code:
    #my $rawRetention = `${zimbra_home}/bin/zmprov -l gacf | egrep '^zimbraLogRawLifetime' | sed -e 's/zimbraLogRawLifetime: //'`;
    my $rawRetention = "31d";
    
    #my $summaryRetention = `${zimbra_home}/bin/zmprov -l gacf | egrep '^zimbraLogSummaryLifetime' | sed -e 's/zimbraLogSummaryLife
    my $summaryRetention = "730d";

  3. #3
    Join Date
    Jun 2008
    Posts
    1
    Rep Power
    7

    Thumbs up Thank you!

    Thank for you're solution, it's work here.

  4. #4
    Join Date
    Aug 2008
    Posts
    3
    Rep Power
    7

    Default

    I've tracked a similar problem down on 8.04.1 x86_64 and found that calls to /opt/zimbra/libexec/zmmtaconfig cause massive spikes in CPU usage. That file contains several references to zmprov which I presume is causing the same sort of delays as experiences by the original poster.

    Does anyone have any advice on how to circumvent calls to zmprov?

  5. #5
    Join Date
    Mar 2009
    Location
    Sarajevo
    Posts
    44
    Rep Power
    6

    Default

    We have the same problem in 6.0.3 version on Ubuntu 8.04.
    It seems that this is the bug:
    Bug 34040 – Zimbra java consumes all memory on Ubuntu 8.0.4 64bit

  6. #6
    Join Date
    Mar 2010
    Posts
    23
    Rep Power
    5

    Smile /opt/zimbra/java/bin/java -XX:ErrorFile=/opt/zimbra/log -client -Xmx256m -Dzimbra.

    Hi

    I would like to share with all of you the resolution of the same problem described in this forum post.

    Infact I had the same problem with the high usage of the cpu with an email message:
    /opt/zimbra/java/bin/java -XX:ErrorFile=/opt/zimbra/log -client -Xmx256m -Dzimbra.

    The resolution was to install:

    Apache Ant

    It is a required package for Zimbra.
    The install.sh script do not check for it and so the installation get place with no error.

    Good use is to read the readme file included in the Zimbra ZCS Folder with all the indication and prerequisite

    Regards

    Alex

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by alex70 View Post
    The resolution was to install:

    Apache Ant

    It is a required package for Zimbra.
    The install.sh script do not check for it and so the installation get place with no error.
    Apart from the fact this thread has already been solved and it's over two years old, there is no requirement to install Apache Ant for a working Zimbra installation unless you are building it from source.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Mar 2010
    Posts
    23
    Rep Power
    5

    Default

    sorry If I attached a reply to a post already close but I thought it gave more sense to share my experience in a thread where this problem was already spoken. Probabily you are right but for the moment I have no more problem with the high usage of cpu by java. Furthermore this problem seems to still exist as described in Bug 34040 – Zimbra java consumes all memory on Ubuntu 8.0.4 64bit.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by alex70 View Post
    sorry If I attached a reply to a post already close but I thought it gave more sense to share my experience in a thread where this problem was already spoken. Probabily you are right but for the moment I have no more problem with the high usage of cpu by java. Furthermore this problem seems to still exist as described in Bug 34040 – Zimbra java consumes all memory on Ubuntu 8.0.4 64bit.
    That's fine and the problem may exist as per that bug report but you've posted in this thread that Apache Ant is a prerequisite for Zimbra when it not required at all.

    If you think that by installing Apache Ant your problem has been resolved then you should add the information to that bug report with a full description of what you did with complete steps to reproduce the fix and details of why you think the problem went away.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Mar 2010
    Posts
    23
    Rep Power
    5

    Default

    Phoenix you were right. This morning I had again the same problem so as you say Apache Ant is not the resolution.

    At this point If you want, delete my previous post.

    Thanks

    Best Regards,

    Alex

Similar Threads

  1. High CPU usage on server and client
    By jack-Z in forum Administrators
    Replies: 10
    Last Post: 01-07-2009, 09:12 PM
  2. High CPU Load every couple of days
    By pornsakb in forum Administrators
    Replies: 13
    Last Post: 11-30-2007, 11:12 AM
  3. poor performance ZCS NE vs. ZCS OSS
    By fisch09 in forum Administrators
    Replies: 5
    Last Post: 08-19-2007, 06:17 AM
  4. CPU Load
    By claros in forum Administrators
    Replies: 1
    Last Post: 08-11-2006, 06:56 PM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •