Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] ldap...failed. (28928)

  1. #1
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default [SOLVED] ldap...failed. (28928)

    /tmp/zmsetup.01001900-0000500574944.log
    Fri Jun 13 12:47:52 2008 done.
    Fri Jun 13 12:47:53 2008 checking isEnabled zimbra-ldap
    Fri Jun 13 12:47:53 2008 zimbra-ldap is enabled
    Fri Jun 13 12:47:53 2008 Initializing ldap...
    Fri Jun 13 12:47:53 2008 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 160.
    Fri Jun 13 12:48:33 2008 failed. (28928)
    Fri Jun 13 12:48:33 2008

  2. #2
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    I tried this, but my sudoers already 0440

    06-03-2008, 10:54 PM
    phoenix
    Zimbra Employee
    Join Date: Sep 2005
    Location: Vannes, France
    Posts: 7,188

    Fix the following error and run the install again:


    Code:
    sudo: /etc/sudoers is mode 0640, should be 0440

  3. #3
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    Fixed it...had to service network restart... probably just needed to breathe

  4. #4
    Join Date
    Jun 2008
    Posts
    6
    Rep Power
    7

    Default

    I tried this as well, and there is no go. I am not having this issue.. I checked the sudoers file, and i restarted the network.... and I am getting:

    Fri Aug 8 15:20:14 2008 Initializing ldap...
    Fri Aug 8 15:20:14 2008 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 160.
    Fri Aug 8 15:21:03 2008 failed. (28928)
    Fri Aug 8 15:21:03 2008


    Something that may be of importance is that my zimbra install was within a VMWare image (running on ESXi).

    I then tried rebooting the system then running the PL again to try and write the config.... I now had:


    Checking for port conflicts
    Port conflict detected: 25 (zimbra-mta)
    Port conflict detected: 25 (zimbra-mta)
    Port conflicts detected! - Any key to continue

    So I contunied, and ended up back at:

    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.01001900-0000143252424.log

    And then full circle back to:

    IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 160.
    Fri Aug 8 15:25:12 2008 failed. (28928)



    Any ideas?

  5. #5
    Join Date
    Mar 2009
    Posts
    7
    Rep Power
    6

    Default

    I have exactly the same problem, on the same virtualization server!

    Fri... zimbra-ldap is enabled
    Fri ... Initializing ldap...
    Fri ... *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 160.
    Fri Mar 6 11:48:11 2009 failed. (28928)

    Tried re-running zmsetup.pl, the same thing happens ...
    When I run the zmstetup.pl, it checks for an MX record on my DNS server, and it says it doesn't exist. But if I execute "dig mx mail..com" it says is a vaild name!

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It would help if you had created a new thread instead of adding another 'me too' to an old and solved thread.

    Quote Originally Posted by iavellino View Post
    I have exactly the same problem, on the same virtualization server!

    Fri... zimbra-ldap is enabled
    Fri ... Initializing ldap...
    Fri ... *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 160.
    Fri Mar 6 11:48:11 2009 failed. (28928)

    Tried re-running zmsetup.pl, the same thing happens ...
    When I run the zmstetup.pl, it checks for an MX record on my DNS server, and it says it doesn't exist. But if I execute "dig mx mail..com" it says is a vaild name!
    Well, if the installer says it can't find an MX record then it doesn't exist for the domain name it's checking.

    As usual, run the following commands on the Zimbra server and post the output here:
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname`  <-- type that command exactly as you see it with backticks not single quotes.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Mar 2009
    Posts
    7
    Rep Power
    6

    Default

    Thank you bill for your response (and patience)
    This problem originated when i tried to change the domain name that Zimbra was configured for, but since I couldn't solve it, and we were not in production, I decided to reinstall Zimbra.

    The dig mx command was telling me that the domain name had an mx record on our internal dns server ...
    I really appreciate your concern on my problem and your help, but right now we are just reinstalling everything.
    We'll have to change the domain name soon, so I'd be browsing for posts about this matter shortly!
    Thank you again

    Ignacio

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    OK. When you're ready to do the install you should use the commands I've asked in my previous post - they will tell you if your DNS A & MX records are set correctly. If they are OK then install ZImbra and during the install set the domain name when asked if you want to change it and that should see you with a correctly set-up ZImbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Mar 2009
    Posts
    7
    Rep Power
    6

    Default

    Bill, I tried re installing Zimbra, and I get the same error!
    Here is the result of the commands you asked me to perform:

    Code:
    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1	localhost.localdomain	localhost
    ::1	localhost6.localdomain6	localhost6
    192.168.100.5	mail.mydomain.com.uy	mail
    Code:
    cat /etc/resolv.conf
    search mydomain.com.uy
    nameserver 192.168.100.5
    Code:
    [root@mail zcs-5.0.13_GA_2791.RHEL5_64.20090206123226]# dig mydomain.com.uy mx
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.com.uy mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6703
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.com.uy.       IN      MX
    
    ;; ANSWER SECTION:
    mydomain.com.uy. 3600   IN      MX      10 mail.mydomain.com.uy.
    
    ;; AUTHORITY SECTION:
    mydomain.com.uy. 3600   IN      NS      mydomain.com.uy.
    
    ;; ADDITIONAL SECTION:
    mail.mydomain.com.uy. 3600 IN   A       192.168.100.6
    mydomain.com.uy. 3600   IN      A       192.168.100.5
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.100.5#53(192.168.100.5)
    ;; WHEN: Mon Mar  9 11:30:01 2009
    ;; MSG SIZE  rcvd: 108
    Code:
    [root@mail zcs-5.0.13_GA_2791.RHEL5_64.20090206123226]# dig mydomain.com.uy any
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.com.uy any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19699
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.com.uy.       IN      ANY
    
    ;; ANSWER SECTION:
    mydomain.com.uy. 3600   IN      SOA     mydomain.com.uy. root.mydomain.com.uy. 6 10800 3600 604800 3600
    mydomain.com.uy. 3600   IN      NS      mydomain.com.uy.
    mydomain.com.uy. 3600   IN      A       192.168.100.5
    mydomain.com.uy. 3600   IN      MX      10 mail.mydomain.com.uy.
    
    ;; ADDITIONAL SECTION:
    mydomain.com.uy. 3600   IN      A       192.168.100.5
    mail.mydomain.com.uy. 3600 IN   A       192.168.100.6
    
    ;; Query time: 2 msec
    ;; SERVER: 192.168.100.5#53(192.168.100.5)
    ;; WHEN: Mon Mar  9 11:32:44 2009
    ;; MSG SIZE  rcvd: 165
    Code:
    host `hostname`
    Host mail.mydomain.com not found: 3(NXDOMAIN)
    I don't know what is going wrong ... i still get error 29829 (ldap fails)
    Thank you again

  10. #10
    Join Date
    Mar 2009
    Posts
    7
    Rep Power
    6

    Default

    Cannot believe how I missed that...
    The IP configured on the mailserver, is not the one it actually has!! (on /etc/hosts)
    It's 192.168.100.6 instead of 192.168.100.5 .. wich is our DNS's IP.
    Sorry for the inconvenience, I overlooked that part 100 times and still missed it!!

    Now the installation goes ok

    Thanks x 1000!

Similar Threads

  1. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 11:38 AM
  2. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  3. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM
  4. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  5. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •