Results 1 to 9 of 9

Thread: 5.02 - 5.06 upgrade, mailbox not running.

  1. #1
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default 5.02 - 5.06 upgrade, mailbox not running.

    Hi all, Upgraded from 5.02 to 5.06 over the weekend. Was a little bit nervous as I was thrown into a role where I had to administer Zimbra with little to no training, everything went pretty smoothly, but I have a couple of questions.

    1) When i do zmcontrol status, i get the following:

    imapproxy Stopped
    nginx is not running
    memcached is not running
    ldap Running
    logger Running
    mailbox Stopped
    mysql.server is not running
    mta Running
    snmp Running
    spell Running
    stats Stopped

    I had a look before the upgrade and I know that both stats and imapproxy were Stopped. The one I am concerned about above is mailbox being stopped. All mailboxes are working ok though, so am wondering what impact this has and what I need to do to get it started, and if its safe to do it during the day when all the users are here. Stats says stopped but I still see stats so dont know why.

    2) I use the Zimbra connector to sync with Mac Mail. I have entered in the LDAP address (In Address Book, preferences), and email addresses within our directory are auto populated. However when I click address I do NOT get a full list (in instances when I have to email everyone in the company this is useful). What this means is when i do emails to everyone I have to load up the web based client and do it from there (I am able to select everyone using this method). Any ideas on this one ? I had opened a ticket as this was happening in 5.02, and was told I just needed to upgrade, but the problem exists in 5.06 still.

    Thanks all for any help ! I would also like to know how to recover deleted emails lol, hope I'm not asking too much. Maybe if someone could point me in the direction of a good document that covers that.
    Last edited by nufan; 06-16-2008 at 07:56 AM.

  2. #2
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Can't answer your second question, but for your first question you definitely want to see the mailbox running. I would suggest trying (as the zimbra user) 'zmcontrol stop'; 'zmcontrol start'; and then check the status again. I had this happen to me after one of many Zimbra upgrades, but I was never able to track down the source of the problem. The stop/start got everything running properly, so it wasn't a big issue for me.

  3. #3
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    thanks for the reply, i did zmcontrol stop then zmcontrol start and it didnt fix it. Zimbra itself works but I still have mailbox reporting as stopped (along with all the other ones as per my original post)

    Any other ideas anyone ?

  4. #4
    Join Date
    Apr 2008
    Posts
    4
    Rep Power
    7

    Default

    Are there any useful errors in your /opt/zimbra/log/mailbox.log? Something similar happened to me after I upgraded one of my mailstores from 5.0.4 -> 5.0.6. There were java heap errors being reported in mailbox.log, so I modified the mailboxd_java_heap_memory_percent value and set it to 30 (instead of 37), restarted the service, and it came back up normally.

    Code:
    su - zimbra -c 'zmlocalconfig -e mailboxd_java_heap_memory_percent=30'
    su - zimbra -c 'zmcontrol stop && zmcontrol start'
    Nick Ragusa
    Systems Engineer Manager
    Brandeis University

  5. #5
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    thanks for the reply nick. I checked the java heap memory and mine was already set to 30. I stopped and started again (zmcontrol stop, zmcontrol start) still with no luck. I took note of the mailbox.log whcih showed this and don't see anything out of the ordinary. Is there a better way to view this log as i am just typing cat mailbox.log and seeing it populate in the command line. A real time running of the log would be ideal.

    Also still looking for any ideas on my problem, thanks !

  6. #6
    Join Date
    Apr 2008
    Posts
    4
    Rep Power
    7

    Default

    Try opening 2 SSH sessions to your Zimbra server. On one session, run
    Code:
    tail -f /opt/zimbra/log/mailbox.log
    and on the other restart the zimbra services
    Code:
    su - zimbra -c 'zmcontrol stop && zmcontrol start'
    This should at least get you to see any errors on shutdown / startup.
    Nick Ragusa
    Systems Engineer Manager
    Brandeis University

  7. #7
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    thanks i was able to save the log that way. There is a lot of stuff in there but doesnt seem to be anything obvious that would point to the reason the mailbox is showing as stopped.

    The main errors I am seeing all look like this, not sure if this makes sense to anyone:

    Code:
    ExceptionId:btpool0-0:1213717662679:01632893fb4c2b66
    Code:service.INVALID_REQUEST
            at com.zimbra.common.service.ServiceException.INVALID_REQUEST(ServiceException.java:260)
            at com.zimbra.cs.service.mail.CalendarUtils.lookupAndAddToTzList(CalendarUtils.java:384)
            at com.zimbra.cs.service.mail.CalendarUtils.parseDtElement(CalendarUtils.java:602)
            at com.zimbra.cs.service.mail.CalendarUtils.parseInviteElementCommon(CalendarUtils.java:753)
            at com.zimbra.cs.service.mail.CalendarUtils.parseInviteForCreate(CalendarUtils.java:122)
            at com.zimbra.cs.service.mail.SetCalendarItem$SetCalendarItemInviteParser.parseInviteElement(SetCalendarItem.java:76)
            at com.zimbra.cs.service.mail.ParseMimeMessage$InviteParser.parse(ParseMimeMessage.java:129)
            at com.zimbra.cs.service.mail.ParseMimeMessage.parseMimeMsgSoap(ParseMimeMessage.java:287)
            at com.zimbra.cs.service.mail.CalendarRequest.handleMsgElement(CalendarRequest.java:105)
            at com.zimbra.cs.service.mail.SetCalendarItem.getSetCalendarItemData(SetCalendarItem.java:147)
            at com.zimbra.cs.service.mail.SetCalendarItem.parseSetAppointmentRequest(SetCalendarItem.java:201)
            at com.zimbra.cs.service.mail.SetCalendarItem.handle(SetCalendarItem.java:96)
            at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:410)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:267)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:159)
            at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:266)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
            at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:189)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
            at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
            at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
            at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:716)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:406)
            at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)
            at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
            at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(RewriteHandler.java:350)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
            at org.mortbay.jetty.Server.handle(Server.java:313)
            at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)
            at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:844)
            at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:644)
            at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)
            at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)
            at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)
            at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)

  8. #8
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Another place to look is /opt/zimbra/log/stacktrace.* and see if any of the stacktrace files have timestamps corresponding to your attempted startup.

    You may also see clues in /var/log/messages.

    After you issue a zmcontrol stop, run top, then "u" and type "zimbra" to see if there are any processes being run by the zimbra user account. Kill those and then try a zmcontrol start while tailing /var/log/messages and let us know!

    Hope that helps,
    Mark

  9. #9
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    I had placed a ticket with Zimbra support and received help on the issue. We were able to set up a remote connection and the support tech. was able to fix the issue. It was something to do with killing a stale sql command ? I am not entirely sure what he did to fix it however it is all showing up as running now and email is working great. Thx Zimbra support !

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 09:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 09:22 AM
  3. mysql.server is not running
    By Oswald-Kolle in forum Installation
    Replies: 27
    Last Post: 05-01-2007, 09:28 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •