Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: zimbra problems receiving/sending

  1. #11
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    smtp_sasl_password_maps = hash:/opt/zimbra/postfix-2.2.5/conf/passwd

    Does your version of zimbra use 2.2.5 or 2.2.8?

    ls /opt/zimbra will show you.

  2. #12
    Join Date
    Feb 2006
    Posts
    15
    Rep Power
    9

    Default

    it uses
    postfix-2.2.5

    I am using the open source version I downloaded yesterday.

    This is frustrating but I am getting there.
    everything except sending mail works so I must be getting somewhere
    stupid port 25 blocking ISP

    Thanks

    ohh here is one thing I noticed.
    in my config file I have both smtpd_sasl_auth_enable = yes
    and smtp_sasl_auth_enable = yes

    should both be there?

    Luc

  3. #13
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    smtpd_sasl controls if your postfix instance will auth when it's acting as a daemon (when people connect to it).
    smpt_sasl controls how it acts as a client (when it connects to someone else).

    In your case, both should be "yes"

  4. #14
    Join Date
    Feb 2006
    Posts
    15
    Rep Power
    9

    Default

    ok I am at a lose then,
    I checked all my settings, read all the posts about relaying, followed one guys example for rogers itself yet I still can't send email.


    Code:
    message_size_limit = 10240000
    content_filter = smtp-amavis:[127.0.0.1]:10024
    myhostname = zimbra.lumacs.com
    recipient_delimiter =
    smtpd_sasl_auth_enable = yes
    smtpd_tls_auth_only = yes
    disable_dns_lookups = yes
    smtp_sasl_security_options =
    smtpd_sasl_security_options =
    smtp_sasl_auth_enable = yes
    relayhost = smtp.broadband.rogers.com:25
    smtp_sasl_password_maps = hash:/opt/zimbra/postfix-2.2.5/conf/passwd

    the only way I can send email is using the mail command from terminal
    mail user@address.com
    subject: blah
    balh blah
    .(enter)

    this comes threw as zimbra@zimbra.lumacs.com

    the log after trying to send an email from a valid user account.

    Code:
    Caused by: javax.mail.SendFailedException: Invalid Addresses;
      nested exception is:
            class com.sun.mail.smtp.SMTPAddressFailedException: 554 : Relay access denied
    
            at com.sun.mail.smtp.SMTPTransport.rcptTo(SMTPTransport.java:1141)
            at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:536)
            at javax.mail.Transport.send0(Transport.java:151)
            at javax.mail.Transport.send(Transport.java:80)
            at com.zimbra.cs.service.mail.SendMsg.sendMimeMessage(SendMsg.java:243)

  5. #15
    Join Date
    Feb 2006
    Posts
    15
    Rep Power
    9

    Default

    Ok I kinda got it going
    I unsinstalled Zimbra and started over.
    when I did the install I kept nearly all the defaults, instead of domain.com I left it as zimbra.domain.com etc

    now it works
    I am relaying without a problem.

    how would I go abouts doing this exact same thing but for domain.com instead of zimbra.domain.com

    I am willing to redo the install as its not hard/don't take long but last time I did that with domain.com it screwed up big time (hence this post hehe)

    Thanks again

    Luc

  6. #16
    Join Date
    Feb 2006
    Posts
    15
    Rep Power
    9

    Default

    nm got it working

    Luc

  7. #17
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    So, in the spirit of posting solutions, instead of just questions - what was the fix?

Similar Threads

  1. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 07:29 PM
  2. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 12:59 PM
  3. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •