Hello,

I finally got zimbra installed but now I am having problems sending and receiving email.
first off lets call my fqdn zimbra.domain.com.
I have a mx record for domain.com and a Cname for zimbra.
I then have my router forwarding all ports listed in the documentation to zimbra.domain.com.

hosts file has the required entry.
127.0.0.1 for localhost and then an entry with public ip address and fqdn.

I am on Rogers so I have to relay. I have followed every post (and there are many) about doing this and I don't know why its still not working. I have finally changed from rogers to my own server in Colocation that allows relaying with authentication on port 26, same problem.

When I try to send a message from Zimbra I get:
Code:
 at java.lang.Thread.run(Thread.java:595)
Caused by: javax.mail.SendFailedException: Invalid Addresses;
  nested exception is:
        class com.sun.mail.smtp.SMTPAddressFailedException: 554 : Relay access denied

        at com.sun.mail.smtp.SMTPTransport.rcptTo(SMTPTransport.java:1141)
        at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:536)
        at javax.mail.Transport.send0(Transport.java:151)
        at javax.mail.Transport.send(Transport.java:80)
        at com.zimbra.cs.service.mail.SendMsg.sendMimeMessage(SendMsg.java:243)
        ... 25 more
2006-02-28 13:34:11,652 INFO  [IndexWritersSweeper] [] MailboxIndex - open index
 writers sweep: before=1, closed=0, after=1 (0ms)
I have created a file and entered my mail.domain.com (for my other server) and id@domain.comassword
(it requires authentication with the @domain.com)
and ran postmap on it.
I have sent many test messages from my yahoo and another email address to my server and I have not received them.

here is part of my config file.

Code:
transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf

# If (email domain name == host name), we don't want $myhostname in
# mydestination for testing purposes.
mydestination = localhost.localdomain localhost

# Disable NIS which is in the default
alias_maps = hash:/etc/aliases

# for security...
allow_mail_to_commands =
allow_mail_to_files =

smtpd_helo_required = yes

smtpd_client_restrictions = reject_unauth_pipelining

smtpd_data_restrictions = reject_unauth_pipelining

smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_sender, reject_unauth_destination, permit

broken_sasl_auth_clients = yes

smtpd_use_tls = yes
smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
smtpd_tls_loglevel = 3

message_size_limit = 10240000
content_filter = smtp-amavis:[127.0.0.1]:10024
myhostname = zimbra.lumacs.com
recipient_delimiter =
smtpd_sasl_auth_enable = yes
smtpd_tls_auth_only = yes
disable_dns_lookups = yes
smtp_sasl_password_maps = hash:/opt/zimbra/postfix-2.2.5/conf/passwd
smtp_sasl_security_options =
smtp_sasl_auth_enable = yes
relayhost = mail.relaydomain.com:26
Any ideas?
if you would like any more info please let me know.

Luma