Results 1 to 3 of 3

Thread: [SOLVED] external authentication not working

  1. #1
    Join Date
    Jun 2008
    Rep Power

    Default [SOLVED] external authentication not working


    I am trying to authenticate externally. The details of my external auth setting are attached below. I can test one user authentication as is asked to me to test in admin console "configure authentication" window. Also i am able to do a ldap search from zimbra to my legacy system.The only issue is when i create a user in zimbra which already exist in my legacy LDAP, i dont get authenticated and gives me following error: -

    com.zimbra.common.service.ServiceException: system failure: Missing 'equals'
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.account.ldap.LdapProvisioning.extern alLdapAuth(
    at com.zimbra.cs.account.auth.AuthMechanism$LdapAuth. doAuth(
    at com.zimbra.cs.account.ldap.LdapProvisioning.verify PasswordInternal(
    at com.zimbra.cs.account.ldap.LdapProvisioning.verify Password(
    at com.zimbra.cs.account.ldap.LdapProvisioning.authAc count(
    at com.zimbra.cs.account.ldap.LdapProvisioning.authAc count(
    at com.zimbra.cs.service.account.Auth.handle(Auth.jav a:120)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:267)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:159)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:266)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:148)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: n: Missing 'equals'; remaining name 'cn=users,dc=kuniv,dc=edu,dc=kw'
    at com.sun.jndi.ldap.Filter.encodeSimpleFilter(Filter .java:305)
    at com.sun.jndi.ldap.Filter.encodeFilter( 151)
    at com.sun.jndi.ldap.Filter.encodeFilterString(Filter .java:55)
    at a:520)
    at com.sun.jndi.ldap.LdapCtx.doSearch( 44)
    at com.sun.jndi.ldap.LdapCtx.searchAux( 806)
    at com.sun.jndi.ldap.LdapCtx.c_search( 31)
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_sea rch(
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.searc hDir(
    at com.zimbra.cs.account.ldap.LdapUtil.ldapAuthentica te(
    at com.zimbra.cs.account.ldap.LdapProvisioning.extern alLdapAuth(
    ... 36 more

    Can anyone help me in knowing what can be the issue ?
    Attached Images Attached Images

  2. #2
    Join Date
    Mar 2007
    Rep Power


    Welcome to the forums.

    For your LDAP filter, I see you only have '%u'. I don't know your naming schema, but normally for the filter you use something like 'uid=%u' or 'cn=%u', depending on how you have them named. You may try changing that. (just guessing from the "missing equals" bit)

  3. #3
    Join Date
    Jun 2008
    Rep Power



    Thanks this works fine.. i was missing 'uid=%u' ..

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. External auth / order of authentication process
    By joukom in forum Administrators
    Replies: 3
    Last Post: 05-18-2008, 12:55 AM
  3. External LDAP authentication problem
    By mchamboredon in forum Installation
    Replies: 2
    Last Post: 01-16-2008, 09:02 AM
  4. External Authentication with Active Directory via LDAPS
    By merrill in forum Administrators
    Replies: 1
    Last Post: 10-21-2007, 01:13 PM
  5. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts