Results 1 to 6 of 6

Thread: Installation Problem - Possibly LDAP

Threaded View

  1. #1
    Join Date
    Mar 2006
    Posts
    5
    Rep Power
    9

    Default Installation Problem - Possibly LDAP

    Hi there

    Just started playing with Zimbra over past couple of days.
    Some details
    =========
    Using the Network edition on Red Hat Enterprise.
    Internal(Private IP) address of Zimbra: 10.0.0.8
    I have an mx record setup for my testing site mail.mydomain.com pointing to External IP address on our Firewall 83.245.69.36.
    I port forward all traffic on port LDAP(389), SMTP(25) and LMTP(24) from 83.245.69.36 to 10.0.0.8

    I install Red Hat
    Stopped Sendmail as required
    chkconfig sendmail off
    service sendmail stop

    Checked my host file which displays the following
    127.0.0.1 localhost.localdomain localhost
    83.245.69.36 mail.mydomain.com mail



    Then I start the installation
    [root@mail zcs]# ./install.sh

    Operations logged to /tmp/install.log.10733
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-core...NOT FOUND


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra...cense_1.0.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.7p5-30.1.3
    libidn...FOUND libidn-0.5.6-1
    curl...FOUND curl-7.12.1-5
    fetchmail...FOUND fetchmail-6.2.5-6
    gmp...FOUND gmp-4.1.4-3
    /usr/lib/libstdc++.so.5...FOUND

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell


    Select the packages to install

    Install zimbra-ldap [Y]

    Install zimbra-logger [Y]

    Install zimbra-mta [Y]

    Install zimbra-snmp [Y]

    Install zimbra-store [Y]

    Install zimbra-spell [Y]

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] Y

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-ldap......zimbra-ldap-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-logger......zimbra-logger-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-mta......zimbra-mta-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-snmp......zimbra-snmp-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-store......zimbra-store-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-apache......zimbra-apache-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    zimbra-spell......zimbra-spell-3.0.0_GA_156.RHEL4-20060206092416.i386.rpm...done
    Operations logged to /tmp/zmsetup.log.11758
    Setting defaults...Done
    Checking for port conflicts

    Main menu

    1) Hostname: mail.mydomain.com
    2) Ldap master host: mail.mydomain.com
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@mail.mydomain.com
    ******* +Admin Password UNSET
    +SMTP host: mail.mydomain.com
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://mail.mydomain.com:7780/aspell.php

    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help) 6


    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@mail.mydomain.com
    ** 4) Admin Password UNSET
    5) SMTP host: mail.mydomain.com
    6) Web server HTTP port: 80
    7) Web server HTTPS port: 443
    8) Web server mode: http
    9) IMAP server port: 143
    10) IMAP server SSL port: 993
    11) POP server port: 110
    12) POP server SSL port: 995
    13) Use spell check server: yes
    14) Spell server URL: http://mail.mydomain.com:7780/aspell.php

    Select, or 'r' for previous menu [r] 4

    Password for admin@mail.mydomain.com (min 6 characters): [47Ltu1KS] passwordtest

    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@mail.mydomain.com
    4) Admin Password set
    5) SMTP host: mail.mydomain.com
    6) Web server HTTP port: 80
    7) Web server HTTPS port: 443
    8) Web server mode: http
    9) IMAP server port: 143
    10) IMAP server SSL port: 993
    11) POP server port: 110
    12) POP server SSL port: 995
    13) Use spell check server: yes
    14) Spell server URL: http://mail.mydomain.com:7780/aspell.php
    Select, or 'r' for previous menu [r]

    Main menu

    1) Hostname: mail.mydomain.com
    2) Ldap master host: mail.mydomain.com
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.11758]
    Saving config in /opt/zimbra/config.11758...Done
    The system will be modified - continue? [No] Yes
    Operations logged to /tmp/zmsetup.log.11758
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...Done
    Saving CA in ldap...Done
    Installing SSL certificate...Done
    Creating server entry for mail.mydomain.com...Done
    Setting spell check URL...Done
    Setting service ports on mail.mydomain.com...Done
    Adding mail.mydomain.com to zimbraMailHostPool in default COS...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.mydomain.com:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.mydomain.com:389)

    Done
    Installing zimlets... com_zimbra_wikipedia... com_zimbra_url... com_zimbra_ymaps... com_zimbra_xslt... com_zimbra_phone... com_zimbra_tracking... com_zimbra_amzn... Done
    Installing network zimlets... hsm... hotbackup... convertd... cluster... com_zimbra_domainadmin... Done
    Setting MTA auth host...Done
    Creating domain mail.mydomain.com...Done
    Creating user 1plpigxwh@mail.mydomain.com...Done
    Creating user 6j72qqxq@mail.mydomain.com...Done
    Setting spam training accounts...Done
    Creating user admin@mail.mydomain.com...Done
    Creating postmaster alias...Done
    Initializing store sql database...Done
    Setting zimbraSmtpHostname for mail.mydomain.com...Done
    Initializing logger sql database...Done
    Initializing mta config...Done
    Configuring SNMP...Done
    Setting services on mail.mydomain.com...Done
    Setting up zimbra crontab...Done
    Starting servers...Done.


    Operations logged to /tmp/zmsetup.log.11758

    Configuration complete - press return to exit


    Does anyone have any idea why this is happening.
    Any help would be greatly appreciated.

    Ger.
    Last edited by geroshea; 03-02-2006 at 02:38 AM.

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  3. External LDAP Problem
    By facerw in forum Installation
    Replies: 7
    Last Post: 05-08-2007, 05:29 AM
  4. problem with ldap installation
    By nemo12 in forum Installation
    Replies: 10
    Last Post: 03-19-2007, 06:40 PM
  5. Another installation ldap problem
    By genesis in forum Installation
    Replies: 10
    Last Post: 12-24-2005, 07:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •