Results 1 to 4 of 4

Thread: name or service not known

  1. #1
    Join Date
    Dec 2005
    Location
    Dallas
    Posts
    32
    Rep Power
    10

    Default name or service not known

    I have now moved everything from our sendmail server to the development Zimbra server. I am now getting emails back from several domains that have in the return message.

    Reporting-MTA: dns; mailhost.intdoc.com
    X-Postfix-Queue-ID: BE7C150457F
    X-Postfix-Sender: rfc822; sysop@intdoc.com
    Arrival-Date: Wed, 1 Mar 2006 18:20:57 -0600 (CST)

    Final-Recipient: rfc822; lzollinger@casham.com
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; casham.com: Name or service not known

    The domains listed are "real."

    Where should I start? I looked for similar problems on the forums but didn't see anything that fit. I have used Sendmail but am not familiar with Postfix.

    I am using 3.01 (160) on RHES 4
    Last edited by rdavisids; 03-02-2006 at 07:43 AM.

  2. #2
    Join Date
    Dec 2005
    Location
    Dallas
    Posts
    32
    Rep Power
    10

    Default

    Well I've found my problem. Postfix needed the relay host for our Postini mail servers to complete the deal.

    Sorry.

  3. #3
    Join Date
    Mar 2006
    Posts
    4
    Rep Power
    9

    Default I have this exact problem

    That solution is more of a workaround IMO.

    Here is the problem:

    If you are trying to send mail from Zimbra to a domain which doesn't have an A record associated with it, it will fail. It doesn't matter if it has MX records or not.

    > [root@mail log]# nslookup
    > casham.com
    Server: 10.92.1.1
    Address: 10.92.1.1#53

    Non-authoritative answer:
    *** Can't find casham.com: No answer
    > set querytype=mx
    > casham.com
    Server: 10.92.1.1
    Address: 10.92.1.1#53

    Non-authoritative answer:
    casham.com mail exchanger = 100 casham.com.mail1.psmtp.com.
    casham.com mail exchanger = 200 casham.com.mail2.psmtp.com.
    casham.com mail exchanger = 300 casham.com.mail3.psmtp.com.
    casham.com mail exchanger = 400 casham.com.mail4.psmtp.com.
    casham.com mail exchanger = 500 mail.casham.com.

    I am experiencing the same problem with the same type of nameserver responses from u.washington.edu.

    Thank you.

    BTW.. I used the same workaround, but I'm using a mail server which I'm trying to retire.

    -Jesse
    Last edited by jesse; 05-07-2006 at 02:50 PM. Reason: Spelling errors

  4. #4
    Join Date
    Mar 2006
    Posts
    4
    Rep Power
    9

    Default Fixed

    I turned on DNS lookups and this problem went away.

Similar Threads

  1. Replies: 21
    Last Post: 08-29-2006, 09:47 AM
  2. Replies: 2
    Last Post: 12-20-2005, 03:31 AM
  3. Spell Service Not Running
    By Ryan Frantz in forum Administrators
    Replies: 2
    Last Post: 12-05-2005, 10:15 AM
  4. Service provider price structuring
    By exothermic in forum Administrators
    Replies: 3
    Last Post: 11-25-2005, 09:38 AM
  5. Cannot SNMP service
    By tron in forum Administrators
    Replies: 1
    Last Post: 10-17-2005, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •