Results 1 to 3 of 3

Thread: Date/time update killed admin account access

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Milwaukee, WI
    Posts
    21
    Rep Power
    7

    Default Date/time update killed admin account access

    Folks,

    I completed installation of Zimbra 5.0.6 on Ubuntu 6.06 last Friday. I successfully batch-created 200+ user accounts and ran a successful LDAP test against my OS/X Open Directory. I'm currently still in pre-production.

    Over the weekend I noticed the date/time was *way* off and decided to wait to update it until I came in this morning. I ran the date command at the CLI which fixed the date/time. But at that point I could no longer login as admin via the web I/F either at the user login page or the administrative login page.

    After restarting the entire Zimbra suite the problem disappeared.

    The error in date/time was significant; it was over 48 hours in the future. One thing I noticed while shutting down Zimbra was the logger refused to stop. After waiting a few minutes I stopped it with a 'kill -9 PID' command and before it died a number of Zimbra processes fired up, ran for <3 secs. and stopped when the logger had stopped.

    Here is the output of a process list after initiating the kill command:

    admin@xxx:/opt/zimbra/bin$ ps aux|grep zim
    zimbra 1002 0.6 0.1 5372 2712 ? Ss 10:04 0:00 /usr/bin/perl /opt/zimbra/libexec/zmstatuslog
    zimbra 1009 1.4 0.2 7004 4332 ? S 10:04 0:00 /usr/bin/perl /opt/zimbra/bin/zmcontrol status
    zimbra 1105 0.0 0.0 0 0 ? Z 10:04 0:00 [cron]
    zimbra 1150 5.0 0.0 4260 1692 ? S 10:04 0:00 sh -c /opt/zimbra/bin/zmstorectl status > /tmp/zmcontrol.status.7imNK 2> /tmp/zmcontrol.error.n0kmZ
    zimbra 1151 8.0 0.0 4284 1776 ? R 10:04 0:00 /bin/bash /opt/zimbra/bin/zmstorectl status
    admin 1157 0.0 0.0 2880 796 pts/0 R+ 10:04 0:00 grep zim
    zimbra 1158 0.0 0.0 2376 412 ? R 10:04 0:00 /bin/bash /opt/zimbra/bin/mysqladmin status
    admin@xxx:/opt/zimbra/bin$

    Is it simply the date/time inaccuracy that locked something up that caused the admin access to be unusable? Was this a coincidence with something else that was repaired with a restart? I could understand logger becoming confused but why would this break admin web access? Or am I just (un)lucky?

    Please let me know what you think. I'm moving closer to production, possibly by the end of this week.

    Cheers,
    Steven White
    Milwaukee Institute of Art & Design
    Steven White
    Zimbra 6.0.16 NE on CentOS 5.3 on Dell 1950
    at Milwaukee Institute of Art & Design on Earth in Sol

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi Steven,
    Hard to say. The logger can get a little skizo sometimes, and it's hard to tell what caused it. A fresh restart should cure what ails you. If you see it again, please post as many logs as you can.

  3. #3
    Join Date
    Jun 2008
    Location
    Milwaukee, WI
    Posts
    21
    Rep Power
    7

    Default

    Thanks, the restart did bring things back for the admin account.

    Next hurdle: migration from FirstClass 5 to Zimbra. I know there's a migration patht from FC8 but hopefully imapsync will be the only tool I need.
    Steven White
    Zimbra 6.0.16 NE on CentOS 5.3 on Dell 1950
    at Milwaukee Institute of Art & Design on Earth in Sol

Similar Threads

  1. Compartmentalized groups or locations sharing a domain
    By dstoliker in forum Administrators
    Replies: 5
    Last Post: 07-14-2008, 01:06 PM
  2. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 05:21 PM
  3. restore admin account
    By preem in forum Administrators
    Replies: 2
    Last Post: 01-19-2007, 07:56 AM
  4. Replies: 9
    Last Post: 08-31-2006, 09:02 AM
  5. Filtering user access per account
    By PNE in forum Administrators
    Replies: 7
    Last Post: 06-26-2006, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •