Results 1 to 2 of 2

Thread: [SOLVED] /etc/hosts CentOS 5.2 install

Hybrid View

  1. #1
    Join Date
    Jul 2008
    Rep Power

    Default [SOLVED] /etc/hosts CentOS 5.2 install


    I seem to be having some problems installing Zimbra on CentOS 5.2. When I run the I get the following error message:
    ERROR: Installation can not proceeed. Please fix your /etc/hosts file
    to contain: localhost.localdomain localhost

    Zimbra install grants mysql permissions only to localhost and
    localhost.localdomain users. But Fedora/RH installs leave lines such
    as these in /etc/hosts: myhost localhost.localdomain localhost

    This causes MySQL to reject users coming from as users from You can read more details at:

    MySQL Bugs: #11822: Reverse lookup for not accounted for in mysql_install_db

    I know the message seems to indicate a problem with my /etc/hosts file but it is correct and has the local host line in the format specified in the error:
    # Do not remove the following line, or various programs
    # that require network functionality will fail. xxxx localhost.localdomain localhost

    I did a google search on the error and found a couple of threads from 2006 that refereed to commenting out the "hostname -fqdn" line but I'd like to actually figure out what is causing this error.

    Thanks for any help.


  2. #2
    Join Date
    Jul 2008
    Rep Power


    I actually figured this out already!

    It appears that in the instal CentOS didn't set the line for my server's FQDN correctly. It set it to the loopback IP instead of the actual IP address of my server. I changed it to the actual server IP and everything is working correctly now.

    Sorry for the false alarm

Similar Threads

  1. Replies: 11
    Last Post: 02-23-2014, 12:08 PM
  2. Problems with Zimbra 5.06 install on Centos 5.1
    By wanderson in forum Installation
    Replies: 3
    Last Post: 06-19-2008, 04:57 PM
  3. Centos 5 Install Guide
    By demminal in forum Installation
    Replies: 39
    Last Post: 07-31-2007, 09:28 AM
  4. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 08:09 AM
  5. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts